operation not permitted when adding SMB share
#1
I just changed from a jellybean rom to a kitkat rom on my mini-pc model MK809III quad core RK3188 cpu.
On jellybean I had no problem adding SMB network shares. With Kitkat I get an error "operation not permitted" when adding SMB share.
I can navigate the share I'm trying to add using ES file explorer.
Here is the debug log.
http://xbmclogs.com/show.php?id=168535
Reply
#2
Somehow, I doubt your server is named "WORKGROUP"...
Reply
#3
(2014-04-08, 08:44)Koying Wrote: Somehow, I doubt your server is named "WORKGROUP"...

You are correct, WORKGROUP is not the server name. The problem is that I can't get past the point where you select the network name, that's when the "Operation not Permitted error pops. Also, like I said, I can select "WORKGROUP", select and logon to the server navigate the files using the Android app ES explorer. It used to work properly in the XBMC nightie I'm using until I upgraded to Android KitKat 4.4.2. I tried a few different nighties as well.
I guess sometimes the log isn't enough. lol so here's a pic of what I'm seeing.
Image
Reply
#4
Same issue here on a Xperia Z2 Tablet, works well connecting to a real windows server, but not to a Synology NAS.
It works as it should with all the other XBMC boxes I have though. I have changed the workgroup name in settings, but no luck.
Reply
#5
In my case I have 2 MK809III mini PC/TV sticks.
One has Android 4.2.2, It connects to all shares in the network named WORKGROUP just fine.
The other has Android 4.4.2. It gives the Operation not permitted error when WORKGROUP is selected while browsing for network shares so a list of servers is not presented. Before upgrading this unit had Android 4.2.2 on it, It all connected and worked correctly then.
Reply
#6
I just discovered that I can stream content from the servers in the network named WORKGROUP using upnp. I still can't connect to the shares on the servers using SMB.
Reply
#7
Can anybody help on this, streaming using upnp stutters a lot so isn't a good solution. When I used to be able to connect via SMB it worked perfectly.
Could this be an incompatibility issue between XBMC and Android 4.4.2 since it worked fine under 4.2.2?
Thanks in advance.
Reply
#8
I made a little headway on this issue.
I selected Add network location and added a SMB location, entered ip address of one of the servers in the network named WORKGROUP along with username/password
Image
Image
It added SMB://192.168.2.2/ to the list
Image
I can see all the drive and stream the content from that server.
Image

The question remains, why can I browse to the servers in the network when using the tv stick that has Android Jellybean 4.2.2 on it but can't browse to the servers when using the tv stick that has Android 4.4.2 KitKat?

(sorry, had a little trouble getting the images uploaded)
Reply
#9
Just to add a new twist to this, I rebooted router on my network. Low and behold I could browse the network, I added a music source, scanned to library, all went well.
I went to add a video source, I got the Operation not permitted error again. I rebooted the router again and was able to add a video source, set content and scan, etc.
I went to add another video source, got the Operation not permitted error again.
Seems in XBMC I can browse the network once with each router reboot. However, In ES file explorer I can always scan and browse the network. Both use SMB. Makes it hard to isolate the source of the problem. If the issue was with the router, wouldn't both programs be affected?
Any thoughts on why this is happening?
Reply
#10
How or why does XBMC handle SMB shares differently than ES file explorer.
Reply
#11
No idea. What is hosting your SMB server?
Reply
#12
Thanks for responding.
A windows 7 PC is hosting the shares.
From my Android device, ES file explorer can always browse the shares while XBMC can browse once with each router reboot. Once the content source is added it can always be accessed from the shares in XBMC. New content is added when XBMC scans the library at startup.
So it's not that XBMC can't access the shares but rather that XBMC can't always browse the shares. So it makes me wonder what ES file explorer does differently.
Reply
#13
SMB browsing and netbios stuff is kind of a dark art, from what I understand. A lot of reverse engineering and things don't always play nicely. It's hard to say what is different here since I don't believe ES File Explorer is open source, so we don't know what they are doing differently.
Reply
#14
Thanks Ned,
I have heard of others having same issue so thought SMB browsing could be improved in XBMC.
Reply
#15
Ok, so after all this time there's still no solution for this issue then?? Why is this site so damn useless? Every time I or someone else has a problem, there's never a solution. I remember years ago when I had an issue with XBMC and came here and NO ONE could help me. The answer was "It works for most people. If it's not working for you, then you must be doing something wrong." Well, I just got a new Android box last week and I'm getting this ridiculous "Operation not permitted message" and no one has any idea how to fix it.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
operation not permitted when adding SMB share00