•   
  • 1
  • 152
  • 153
  • 154(current)
  • 155
  • 156
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
Is it possible to have kodi boot animation on xbmc if it is how can i achieve that?
(2014-12-14, 17:56)expandables Wrote: Is it possible to have kodi boot animation on xbmc if it is how can i achieve that?

XBMC, as in Gotham 13.x on OpenELEC? I guess it would be possible, with some effort - at the moment it's really only a "proof of concept" for Helix and needs more work to clean it up.

If you really wanted to add it to OpenELEC 4.x, you'd need to add the new kodi-splash.service and plumb that into systemd (add it to /storage/config/systemd, run systemctl daemon-reload etc.). The service executes /usr/bin/kodi-splash.sh which you would need to modify to run from your /storage partition. You can find the various files on a Helix build.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-12-09, 22:16)popcornmix Wrote:
(2014-12-09, 21:35)gandharva Wrote: Hyperion is broken in latest builds. Last good build is #1204. Starting with #1205 hyperion is not working.

Can you try adding "device_tree=" to config.txt? This will disable the device tree support and indicate roughly whether this is a DT-related problem or something else.

Hi I tried it with latest Milhouse build: devel-20141213213941-r19802-g1fe5994

With "device_tree=" in config.txt hyperion is working.

Without this entry in config.txt hyperion isn't working at all.

To set up my Ambilight sytem I used this HowTo.
So it seems to be related to new devicetree support?!
(2014-12-14, 20:21)tija Wrote: To set up my Ambilight sytem I used this HowTo.

What HowTo? Are you explicitly loading or blacklisting any modules?

Maybe @gandharva could share his configuration as it appears to be working for him.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-12-14, 20:41)Milhouse Wrote:
(2014-12-14, 20:21)tija Wrote: To set up my Ambilight sytem I used this HowTo.

What HowTo? Are you explicitly loading or blacklisting any modules?

Maybe @gandharva could share his configuration as it appears to be working for him.

Sorry I forgot the Link Smile
http://pibob.nadnerb.co.uk/hardware.html

I'm not loading or blacklisting something explicitily.
(2014-12-06, 01:54)Milhouse Wrote: New OpenELEC Helix build: #1205
(Supercedes previous build)

Build Details:

[*]newclock4:
  • New commits in this build:
    • native resolution (b70241c2)
    • allow to disable native resolution switching through GUI (eaf445d7)
This is a nice feature. Now we can use the dedicated chips from our AVRs to upscale to 1080p.
I had no time to test the update, but thank you very much popcornmix.

Do you think we will see this one in the official openelec?
New OpenELEC Helix build: #1214
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 3.18.0 #1 PREEMPT Sun Dec 14 21:03:10 GMT 2014 armv6l GNU/Linux

# vcgencmd version
Dec 13 2014 15:32:57
Copyright (c) 2012 Broadcom
version ba46211b55252156d2f1e507a7aa71bd18ec0482 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20141214210200-r19806-g86372de [Build #1214]

Based on tip of OpenELEC master (86372de7, changelog) and tip of XBMC master (9f830979, changelog) with the following modifications:
  • Includes newclock4 patches
  • Excludes the OpenELEC fernetmenta patches due to conflicts with newclock4
  • Excludes the OpenELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-3.18.y
  • Excludes the OpenELEC xbmc-001-newclock4 patch in favour of sourcing these and possibly more recent patches directly from newclock4 branch
  • Default setting for "Show RSS Feed" changed to disabled (new installs only) [patch details]
  • Disabled "Total Duration" in Confluence (see build #0221 for details)
  • Adapted service.openelec.settings to take advantage of PR:5217 [patch details]
  • Includes latest libnfs master (9c1d3848)
  • Includes latest libcec master (9f000e43)
  • Includes latest xbmc-pvr-addons master (9f63d1bc)
  • Includes latest xbmc-addon-xvdr master (328fa653)
  • Includes additional ffmpeg codecs/muxers enabled for testing/benchmarking purposes (see patch)
  • Includes animated splash support (patch)
  • Includes commits from libcec-2.2.0 (popcornmix)
  • Disabled package RTL8812AU: Realtek 802.11ac driver doesn't currently build against kernel 3.18
  • Included pastebin: Enable kernel device-tree support
  • Included pastebin: Add device tree kernel trailer
  • Included pastebin: Add *.dtb files to firmware
  • Included PR:3657: [rfc] kodi crashlogs
  • Includes PR:393: [pvr.mythtv] Release v1.9.29: Critical fixes (kodi-pvr-addons)
  • Includes PR:5573: webserver: improved caching control (see discussion)
  • Includes PR:5747: [database] - add setting for hiding watched movies/episodes in recently added lists
  • Includes PR:5752: [jsonrpc] Allow retrieving empty TV shows via VideoLibrary.GetTVShows.
  • Includes PR:5894: [addons] display a more helpful message on python script error
  • Includes PR:5941: media library: fix path history for items with a real path differing from the requested path
  • Includes PR:5947: [vfs] CFile::Open: don't use buffered io for VFS with ChunkSize == 1
Build Highlights:
  1. Updated arm-mem
  2. Added PR:5947 to fix NFS/IFO segfault issue
Build Details:
  1. OpenELEC:
    • projects/*/linux: build RTSX USB and PCIe cardreader drivers statically (d44122d5)
    • projects/RPi/patches/kodi: use helix backport patch (b7d591d1)
    • kodi: add patch to disable unsupported powerfunctions for iMX6 builds (d0f72372)
    • arm-mem: update to arm-mem-2e6f275 (86372de7)
  2. XBMC:
    • VAAPI: Take more care when probing filters (PR:5940, 1 commit, 1 file changed)
    • [metadata.tvdb.com] Added option to use IMDB ratings if it's possible (PR:5778, 1 commit, 5 files changed)
  3. Additional commits/pull requests not yet merged upstream:
    • Added: PR:5947: [vfs] CFile::Open: don't use buffered io for VFS with ChunkSize == 1
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Link isn't working. I got an 404 Error - File not found.
(2014-12-15, 00:19)shadowghost Wrote: Link isn't working. I got an 404 Error - File not found.

Sorry about that, upload appears to have crapped out half-way (will try to make that a little more robust). Should be there now though.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
@ Milhouse:
did you miss that: 1861122 (post) ?
is libmad in your OE-build. It is in 4.2.1
Thx
Wetek Play: LibreELEC 9.0.x as TVH-server --- Odroid N2: CoreELEC 9.2.2 (Unfussy) - searching for good and fast LiveTV Skin - Tips welcome --- Orbsmart 500: Kodi18 (Estouchy) as Online-radio/TV in the kitchen
(2014-12-14, 14:21)Solo0815 Wrote: Is "libmad" in OE?
Code:
find / -name "*libmad*"
returns nothing. Shouldn't it be there? In this post it is mentioned: 1856007 (post)

Sorry missed that post. It should be there, but it's not building automatically (it does build if I build it manually). I'm just trying a clean build to confirm whether it will be built or not, and if not I'll report the problem upstream as it may be missing a dependency of some kind.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-12-15, 09:28)Milhouse Wrote:
(2014-12-14, 14:21)Solo0815 Wrote: Is "libmad" in OE?
Code:
find / -name "*libmad*"
returns nothing. Shouldn't it be there? In this post it is mentioned: 1856007 (post)

Sorry missed that post. It should be there, but it's not building automatically (it does build if I build it manually). I'm just trying a clean build to confirm whether it will be built or not, and if not I'll report the problem upstream as it may be missing a dependency of some kind.

libmad is built statically, so any 3rdparty stuff needs to be built against a statically built libmad too and there is no libmad.so* shipped anymore
greetings, Stephan

Image
Image
Thanks sraue.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I'm experiencing some trouble with new builds based on kernel 3.18.
Moving from a wired to a wireless connection through Openelec add-on causes a black screen after/during playback a remote video.

Today, with #1214, I got a black locked screen after changing to a wireless connection, then raspi did a reboot.

Build #1208 seems do not have these problems.

lsmod's output on #1214:
Code:
Module                  Size  Used by
cfg80211              221039  0
r8712u                161848  0
lirc_rpi                6008  3
lirc_dev                7885  1 lirc_rpi
rc_core                16231  1 lirc_dev
bcm2708_rng              812  0

Thanks for 'watching' and again... sorry for my very bad English.
(2014-12-14, 20:41)Milhouse Wrote:
(2014-12-14, 20:21)tija Wrote: To set up my Ambilight sytem I used this HowTo.

What HowTo? Are you explicitly loading or blacklisting any modules?

Maybe @gandharva could share his configuration as it appears to be working for him.
I think he is right. I still have "device_tree=" in my config.txt, as this was the first thing popcornmix told me to check, but I didn't remove it afterwards... This didn't fix the problem with builds #1205 to #1210.
Build #1211 then fixed my issue, but obviously only if "device_tree=" is present in config.txt. So it seems there have been two bugs and the one that is related to device tree support is still present in current builds.

I'm going to remove "device_tree=" from config.txt after work to confirm the report from tija.
  •   
  • 1
  • 152
  • 153
  • 154(current)
  • 155
  • 156
  •   
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888
This forum uses Lukasz Tkacz MyBB addons.