Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
I've been checking openelec/pi out for a year and a half now, official builds, my own builds, and now these test builds. I was running r17644 from Feb for a while, tried r18050 from Mar briefly but backed it out due to serious regressions. I've been trying some of these recent builds (#531, #601, #619) and while they are *significantly* better (to the point of being almost usable for day to day watching and in front of company) than the Feb build, there's a few newly introduced issues:

(My use case is DVDs as a VIDEO_TS folder structure off hard disk.)

1) The video jitter which I presume is the same others have pointed out here. Seems to be random whether it happens or not. Often won't after start of playback or a skip to a chapter point, often will after returning to normal speed after trickplay. Feels like 3-5 times a second the video just stops for a few frames. Audio is flawless (mostly). I tried playing with the "adjust display refresh rate", "sync playback to display" and "vertical blank sync" options, but the jitter persists. (So I've returned them to "off"/"off"/"always".)

2) While watching LOTR I was getting occasional short "veep" noises, as if one uninitialized sample buffer had been queued. Given the positioning I think that was at chapter boundaries, or possibly other longer-scale structural boundaries within the DVD stream. I've heard it a couple of times on a few other disks too, though the length factor biases the sample!

3) On a few (but not all) DVD menus, it feels like the ENTER/OK action is being queued and not performed for (variably) 2-8 seconds, though the visible feedback (highlight/colour change) happens immediately when the button is pressed. Normally just an irritation, but on the BSG boxsets, rather than a list of episodes, it gives one selectable menu item which scrolls through the 4 episodes. The variable delay makes it impossible to select the right one. Further, when the click action finally happens and the video switches, the episode that plays is often not only not the one clicked on originally, but not the one visible at the time of the action either, but something after that.

Older problems: trickplay still needs a little work. Delivery is extremely erratic (seems to play a burst of frames, then wait half a second, burst again), and the clock speed doesn't much resemble the speed label selected. Time will often jump both forwards and backwards, whether or not the playback direction is forwards or backwards. (If I had to guess, I'd say it feels like the normal speed playback timer hasn't been stopped, and both timebases are now competing with each other to set the next position.)

At least menus work at all now, fairly well on pretty much every disk I've tried. And the temporary video blackout just before the end of video sections appears to be gone now.

(I should be clear that as of Feb I switched the default player from omx to dvd, so the above applies to that. And great work on the huge improvements so far!)
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average


Messages In This Thread
Re: RE: - by Mafarricos - 2014-06-04, 20:21
Live tv issues again - by pootler - 2014-06-04, 23:29
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by jsxbmc - 2014-06-20, 01:23
RE: OpenELEC Testbuilds for RaspberryPi Part 3, - by removed151214 - 2014-08-04, 23:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-19, 00:11
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-21, 20:42
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:20
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:34
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:44
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 01:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 23:24
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-25, 01:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:26
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-05, 01:07
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 03:48
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 04:06
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 11:29


Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888
This forum uses Lukasz Tkacz MyBB addons.