Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
(2014-06-29, 19:22)MilhouseVH Wrote:
(2014-06-29, 17:51)calcon79 Wrote: Edit2: Oh BTW is your DVDPlayer working on other DVD ISO files and mpeg2 files. At least in my setup once I start getting the black video but audio playing that problem also occurs on other DVD ISOs and even mpeg2 files when I play them with DVDPlayer. Here is a copy of my log:

I only get the problem when playing this Power 90 ISO. For me, it's the music menu that causes the problem - my only other test ISO doesn't have a similar secondary menu.

Oh and please use pastebin when posting more than half a dozen lines of log... this thread is now unreadable on my Nexus 7 tablet when .

I have made some progress in figuring out my issue. It ONLY occurs when deinterlacing is enable. I can disable deinterlacing and the problem never occurs. I can go back to the main menu and everything. Here is what I did.

I started with clean slate again and kept ALL settings to default. Only added my NFS share so I could play the ISO. Then I played the Power 90 DVD and everything played just fine. I was able to go back to menu and open music menu and start playing the main video with video and audio all working. BUT when I enable deinterlacing and it doesn't matter if it is set to On or Auto the issues start. Once deinterlacing is enabled and I go back to the menu I can only hear audio. No video. I can make the selections in both the main menu and music menu and I can hear the audio of the main video playing but no video. If I go and disable deinterlacing and then back to the main menu and now I can see video and audio again. I select the music on the music menu and everthing plays just fine. I did this repeatedly and it even seems to be doing the same thing on my P90X Chest and Back DVD too.

Can you try this and see if it does the same for you? I have no other settings other than default when running Openelec official 4.0.6.

Update:

I tried disabling OpenMax and it appears that on my P90X DVD the video and audio will play again. Reenabling OpenMax causes the issue to come right back. But when I tried playing the Power 90 DVD it froze on the music selection screen with OpenMax disabled. I'm going to try this from my local usb and see if it is any different. I am also going to start from a clean slate and see if it behaves any different if I never try to play the Power 90 DVD. I am going to try and see if DVDPlayer deinterlacing breaks if I never try to play that particular ISO.

I should add that playback is horribly slow with OpenMax disabled using DVDPlayer but I'm sure that is expected though.

Update 2:

DVDPlayer does NOT play video for any mpeg2 file when deinterlacing is enabled. This is what happens for me. Not sure why though. I haven't tried formatting my SD card and starting over that way lately so who knows. I could have swore at one time DVDPlayer was working with deinterlacing enabled. OMXPlayer continues to work very well. I saw no difference when attempting to play my ISO from local USB either. Except I didn't freeze when trying to play with OpenMax disabled.
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average


Messages In This Thread
Re: RE: - by Mafarricos - 2014-06-04, 20:21
Live tv issues again - by pootler - 2014-06-04, 23:29
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by calcon79 - 2014-06-29, 19:58
RE: OpenELEC Testbuilds for RaspberryPi Part 3, - by removed151214 - 2014-08-04, 23:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-19, 00:11
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-21, 20:42
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:20
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:34
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:44
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 01:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 23:24
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-25, 01:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:26
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-05, 01:07
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 03:48
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 04:06
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 11:29


Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888