•   
  • 1
  • 38
  • 39
  • 40(current)
  • 41
  • 42
  • 156
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
@doveman2

I have been having similar issues as you describe for quite a while.

Have removed USB hub - didn't make any improvement
Changed power supply - no improvement.
Have changed SD cards - slight improvement, occasion mmc error in logs dissappeared.
Run without movie database - no improvement.
Removed overclocking - no improvement.
Increased overclocking - no improvement.
Increase memory setting - no improvement.
Tryed different FIQ settings - no improvement
Turned off CEC - good improvement.
Add/remove MPEG/vc1 codec - no improvement.

Last message in logs is usually "WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer"

Usually the Pi becomes unresponsive and extremely slow over SSH connection. Most of the time it locks and needs to be power cycled. Sometimes it will automatically reboot and occassionally it will start up again 15m to several hours later.

I have 256Mb Pi connected to a Pioneer VSX923 Amp for audio decoding (pass through) and then to a Panasonic TV.

Regards Phil.
Here are my overclocking settings. I have found if I go higher than this I will get lockups. Especially on sdram_freq and core_freq. Unless I am still too high?

arm_freq=900
core_freq=400
sdram_freq=450
over_voltage=2

I will try increasing memory and setting hvs_priority. I also started from a completely clean slate with Openelec Official 4.0.6. Another issue I noticed that seems to be tied to deinterlacing enabled (OMXPlayer) is sometimes when the audio blanks out when it comes back it is no longer in sync with the video. I also saw some people mention this previously in this thread. They were talking about LiveTV and it so happens my files are all 1080i TV recordings that this is happening to.

Also on another note. I get lockups with the newest Milhouse Build #0703. It was doing it before but I wasn't really paying attention to it. It seems to be related to standby settings. If it sits long enough to go into standby (screen goes dark) instead of going into standby my Pi will freeze up. I see that this has been discussed recently. Maybe there is something I need to disable? Disable standby if I am using Milhouse test builds? I think in my settings I have the screen go dark when the Pi sits for a while.
(2014-07-04, 16:30)calcon79 Wrote: Here are my overclocking settings. I have found if I go higher than this I will get lockups. Especially on sdram_freq and core_freq. Unless I am still too high?

arm_freq=900
core_freq=400
sdram_freq=450
over_voltage=2

over_voltage is low. I imagine if you set it to a higher number (e.g. 6) you will be able to increase arm_freq and core_freq.
If you set over_voltage_sdram (try with the same value as over_voltage) you may be able to increase sdram_freq more.
(2014-07-04, 16:30)calcon79 Wrote: Here are my overclocking settings. I have found if I go higher than this I will get lockups. Especially on sdram_freq and core_freq. Unless I am still too high?

You may need to bump over_voltage_sdram up a notch or two if you are struggling to hit sdram_freq=450. Also, over_voltage=2 may not be sufficient. You should try higher voltages (both of them) and then scale one back in turn until you hit instability, then go back up one notch. Repeat for the other voltage.

A good stress-test is the script in my sig, it will max out the Core block and give your Pi a pretty good work out (ie. thrashing). You can run it from a remote PC too (Windows, Linux etc.), which can make life a bit easier.

(2014-07-04, 16:30)calcon79 Wrote: Also on another note. I get lockups with the newest Milhouse Build #0703. It was doing it before but I wasn't really paying attention to it. It seems to be related to standby settings. If it sits long enough to go into standby (screen goes dark) instead of going into standby my Pi will freeze up. I see that this has been discussed recently. Maybe there is something I need to disable? Disable standby if I am using Milhouse test builds? I think in my settings I have the screen go dark when the Pi sits for a while.
Are you able to ping the Pi? Connect over ssh? What are your Power Saving settings - you definitely have Suspend and not Shutdown selected? If you want to disable Suspend, just turn off the Shutdown Timer. The screensaver has nothing to do with suspending the Pi, or placing it in Standby.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-07-04, 16:44)MilhouseVH Wrote: Are you able to ping the Pi? Connect over ssh? What are your Power Saving settings - you definitely have Suspend and not Shutdown selected? If you want to disable Suspend, just turn off the Shutdown Timer. The screensaver has nothing to do with suspending the Pi, or placing it in Standby.

I am unable to ping the Pi or connect SSH when this happens. The Samba server wasn't working either because I was going to try and put the official .tar file in the update folder and go back. It went offline when it froze. In the past this has been due to overclocking settings. Maybe with your builds the lower voltage setting is causing me issues? I'll mess with that and see if it helps.
@ Popcornmix Your a genius man. Your recommendations worked! At least for the audio and video glitching issue. Here is what i did:

I enabled "Turbo" overclocking settings manually in config.txt

arm_freq=1000
core_freq=500
sdram_freq=500
over_voltage=6

Starting from scratch again and all default settings except deinterlacing enabled. I still got the audio dropouts and video blinking. I do notice speed improvements here. In the past I have had issues with lockups at these overclock settings. I am even using heatsinks in my Pi. I will keep them for now and see if I still get lockups (I was using Raspmc and Xbian before which seems to be more temperamental with high overclocking)

I then enabled the following settings:

"Sync Playback To Display" enabled
"Adjust Display Refresh Rate to Match Video" Set to "On Start/Stop"
"Pause During Refresh Rate Change" set to 5 sec
I had "A/V Sync Method" set to "Video Clock (Resample Audio)
HW Acceleration was enabled
Audio output was set to 5.1 and passthrough enabled on Dolby Digital and DTS only
Vsync is "always enabled"
1080P resolution and 60Hz refresh rate for the GUI

With these settings I still got the audio drop outs and video blinking.

Now I tried setting gpu_mem to 352 (btw I did experience lockup and reboot a few times while navigating the gui with this setting so I suspect this was the cause)

With the higher gpu_mem I still got the audio drop outs and video blinking.

Next I set gpu_mem back to 256 and then tried your setting of hvs_priority=0x32ff

Now there are no audio random dropouts and video blinking.

If I comment out the hvs_priority setting the audio dropouts and video blinking returns. I tried this more than once to make sure it wasn't a coincidence.

The DVDPlayer issue was never resolved with any of these settings though. I always get no video and only audio when trying to playback the file with deinterlacing enabled. The only way I can get video and audio with deinterlacing is if I disable Openmax and keep hardware acceleration enabled (but this is bad because it is so slow it is unwatchable). I have tried disabling hardware accleleration completely and using software and I still get no video only audio with DVDPlayer and deinterlacing enabled.

Update: I think there is something with the .ts file that is causing the audio glitches at commercial changeovers (the onces that made me briefly lose audio sync). BUT I they only occur when I have my settings at default. It seems setting the following settings alleviates the glitches that occur at some commercial changeovers and once the main show starts.

"Sync Playback To Display" enabled
"Adjust Display Refresh Rate to Match Video" Set to "On Start/Stop"
"Pause During Refresh Rate Change" set to 5 sec
I had "A/V Sync Method" set to "Video Clock (Resample Audio)
HW Acceleration was enabled
Audio output was set to 5.1 and passthrough enabled on Dolby Digital and DTS only
Vsync is "always enabled"
1080P resolution and 60Hz refresh rate for the GUI

If i disable these settings and go back to default there are glitches on some commercial changes and at the start of the main show. This is most likely due to changes in the audio track in the recorded raw mpeg-2 .ts file (I can hear an obvious change in volume when it occurs). It's not big deal since that is expected. Sometimes when there is a change from stereo to surround the files don't play at all. I don't believe this is the fault of the Pi though. Raw .ts files don't always work well on media players because it's just dumping a raw mpeg-2 stream into a file. I'm not sure if my uploaded .ts file will exhibit this because I used VideoRedo to cut the sample. Sometimes VideoRedo fixes these types of issues in audio tracks.
I can reproduce the audio stutter/glitching prior to the Goldfish advert and before Paw Patrol begins.

The audio glitch definitely occurs as the audio switches from AC3/Stereo to AC3/5.1, with the audio switching back to AC3/Stereo after the Goldfish advert (as the Quadcopter advert starts, with no obvious audio glitch) then back to 5.1 (with glitch) as Paw Patrol starts.

No video blinking though. Nothing special in config.txt.

Audio set to HDMI 2.1, optimized, no stereo upmix, no normalize levels on downmix, medium resample quality, keep audio alive 1 minute, and no passthrough.

Video resolution DESKTOP, refresh 60Hz, higher colour depth enabled, 1080 GUI, vertical blank sync always enabled.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-07-04, 18:25)MilhouseVH Wrote: I can reproduce the audio stutter/glitching prior to the Goldfish advert and before Paw Patrol begins.

The audio glitch definitely occurs as the audio switches from AC3/Stereo to AC3/5.1, with the audio switching back to AC3/Stereo after the Goldfish advert (as the Quadcopter advert starts, with no obvious audio glitch) then back to 5.1 (with glitch) as Paw Patrol starts.

No video blinking though. Nothing special in config.txt.

Audio set to HDMI 2.1, optimized, no stereo upmix, no normalize levels on downmix, medium resample quality, keep audio alive 1 minute, and no passthrough.

Video resolution DESKTOP, refresh 60Hz, higher colour depth enabled, 1080 GUI, vertical blank sync always enabled.

yeah you responded before my edit lol. The glitch goes away when I enable the settings I mentioned in my above edited post. I suspected it was due to change from stereo to surround because they are raw recorded Live TV .ts streams. For the video blinking/ audio dropouts if I don't enable the setting popcornmix gave me I will get it at random times while playing my mpeg-2 videos over nfs shares. his setting really seems to be fixing that issue for me.

What about when you try using DVDPlayer and deinterlacing enabled? Does the file play with video and audio? It doesn't for me. Even on a fresh install of OpenElec 4.0.6.
Is it possible with me going through both an HDMI switch and an AVR receiver that could be contributing to my video blinking and audio dropout issue? Could the setting popcornmix be giving me be causing the Pi to keep a better HDCP handshake? The reason I ask is this really seems to be something similar to what I have seen when I am using my HDMI over ethernet balasts to send my living room hdmi video to my kitchen TV. I would see little glitches just like this when using that setup recently. In fact the last time I tried playing my Pi on my kitchen TV the handshake kept going away and I ended up giving up on it (it used to work quite well but I didn't realize that maybe this video/audio blinking thing could be related to that). Both issues are recent for me too because I never had that issue before. I used to be able to watch my Pi on my kitchen TV with no problems. I'm going to try some more stuff and see how well it works now on my kitchen TV with the settings popcornmix gave me.

I'm betting I might need to boost my hdmi output too. I believe there is a setting for this correct? I will look it up and try that setting as well.
(2014-07-04, 18:37)calcon79 Wrote: What about when you try using DVDPlayer and deinterlacing enabled? Does the file play with video and audio? It doesn't for me. Even on a fresh install of OpenElec 4.0.6.

Right, my previous testing was with omxplayer which plays video and the glitchy audio with all deinterlace settings (off, on, auto).

With dvdplayer and deinterlace set to either Auto or On (unlike omxplayer, it's necessary to stop and restart dvdplayer after changing the deinterlace setting), I get no video only audio. In fact it's just made the Pi freeze but it hasn't crashed, an ssh session is still going but responding very slowly to key presses, so it seems as though some xbmc.bin thread has gone into overdrive. After about 1-1.5 minutes the audio has now resumed (intermittently, very stuttery) with ssh also responding, and I've finally been able to stop the video playing and regain control (edit: just noticed 100% of my swap - 128MB - is now in use, so maybe the "freeze" was due to an out of control memory issue - looks like a big chunk of RAM has been leaked somewhere, I'm down from my usual 163MB free at idle to only 70MB free at idle).

With dvdplayer, and deinterlace off, both video and audio play fine. Interestingly dvdplayer (with deinterlace off) handles the audio channel changes without any glitching.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Yep, there's a definite memory issue with dvdplayer and deinterlace=on with this Paw Patrol video - see bcmstat.sh when starting dvdplayer with deinterlace enabled, the free RAM rapidly reduces until swap starts to be used at which point the Pi freezes (starting at 18:11:19). On this occasion it's impossible to regain control of the GUI (too far gone on the memory front), so I'll have to power cycle...
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Awesome! Glad to know that my Pi isn't just being weird lol. BTW I am experiencing lockups on "Turbo" overclock settings. I'm going down to "High" settings and see how that fares. I can definitely feel that the Pi is hotter when I take the SD card out too. I do believe that was the reason I had my voltage settings lower. Higher voltage means higher heat. I had those previous overclock settings running very stable for me for quite a while. My Pi is inside an entertainment center so that probably is the reason I can't overclock too high. Less airflow. I'm looking more into the random audio/video dropouts and trying to determine if it somehow has to do with my setup.
I did more testing. I tried hooking my Pi directly to the TV and without the hvs_priority=0x32ff I still get random audio/video dropouts. So it seems the switch has no effect on that part. I also fixed my issue with HDCP dropouts to the kitchen TV. It had nothing to do with the Pi itself. My switch has EDID memory. I captured the EDID of my television and walla no more dropouts to the kitchen over my hdmi to ethernet run. That makes the Pi think the swtich is the TV so the HDCP handshake happens there instead of over the long hdmi run.

So when using hvs_priority=0x32ff I no longer get audio dropouts. I also don't get the glitching on stereo/surround changes when I use the following settings:

"Sync Playback To Display" enabled
"Adjust Display Refresh Rate to Match Video" Set to "On Start/Stop"
"Pause During Refresh Rate Change" set to 5 sec
I had "A/V Sync Method" set to "Video Clock (Resample Audio)
HW Acceleration was enabled
Audio output was set to 5.1 and passthrough enabled on Dolby Digital and DTS only
Vsync is "always enabled"
1080P resolution and 60Hz refresh rate for the GUI

Those settings make the playback smooth and the glitches are not present when using them. (So far lol)

As for the DVDPlayer issue. That one has no workaround for me. Other than disabling deinterlacing.
Is it possible to create a build with ZRAM enabled? I noticed that in kernel 3.15, ZRAM now has the ability to use lz4 compression as well as the old lzo. It would be interesting to see if this could help performance wise with the 256mb boards.
(2014-07-04, 20:34)xer0 Wrote: Is it possible to create a build with ZRAM enabled? I noticed that in kernel 3.15, ZRAM now has the ability to use lz4 compression as well as the old lzo. It would be interesting to see if this could help performance wise with the 256mb boards.

Do you have the config options? Might be interesting to try it, though you'd have to ask OpenELEC for long term support - if they're not interested there would be little point me including it.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 38
  • 39
  • 40(current)
  • 41
  • 42
  • 156
  •   
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888
This forum uses Lukasz Tkacz MyBB addons.