•   
  • 1
  • 41
  • 42
  • 43(current)
  • 44
  • 45
  • 156
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
(2014-07-06, 19:43)Mafarricos Wrote: So now feels like a placebo effect Wink

I've never seen swap being needed on a 512M Pi for xbmc. Perhaps if you have other applications (e.g. torrents) running alongside, but not xbmc on its own.
A 256M is different. You can hit memory limits when using streaming add-ons, and swap may be required.

You can simulate a 256M Pi with "total_mem=256" in config.txt if you want to test the behaviour.
I think I detected a bug. In all addons settings isn't possible to see any "comment" setting, the ones only with text to inform user of things and grouping labels. This happens with anyone else?
(2014-07-06, 19:52)Mafarricos Wrote: I think I detected a bug. In all addons settings isn't possible to see any "comment" setting, the ones only with text to inform user of things and grouping labels. This happens with anyone else?

Could you post a screenshot? It could be PR4919, but this was also present in #0703.

Edit1: OK, I see the problem on Artwork Downloader -> Settings -> Info tab.
Edit2: Yep, same problem in #0703. This patch set has been in builds for a while (included newclock3) so hard to say definitively that it's responsible, but probably is.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-07-06, 19:48)popcornmix Wrote:
(2014-07-06, 19:43)Mafarricos Wrote: So now feels like a placebo effect Wink

I've never seen swap being needed on a 512M Pi for xbmc. Perhaps if you have other applications (e.g. torrents) running alongside, but not xbmc on its own.
A 256M is different. You can hit memory limits when using streaming add-ons, and swap may be required.

You can simulate a 256M Pi with "total_mem=256" in config.txt if you want to test the behaviour.

The placebo was about loading time opening a video that I was testing, probably solves on other things.
I have more applications but not using them when testing.

(2014-07-06, 19:56)MilhouseVH Wrote:
(2014-07-06, 19:52)Mafarricos Wrote: I think I detected a bug. In all addons settings isn't possible to see any "comment" setting, the ones only with text to inform user of things and grouping labels. This happens with anyone else?

Could you post a screenshot? It could be PR4919, but this was also present in #0703.

In #0703 I didn't change any setting.
I will check on the other pi and see if result is the same or is something that went wrong in this RPI.
Still doing some tests with Zram. Just checking to see if addons or videos are loading any quicker. Checking boot speed. Though at the moment, it doesn't seem to have made any difference. I think I'll up the swappiness and give it a day or more testing to see.

One thing that was puzzling me was I noticed when doing 'free -m' my memory total is shown as 118mb. It's also like this without Zram module loaded. Looking at /proc/meminfo it says MemTotal:121468 kB. Am I missing 10mb of ram somewhere or is it meant to be like this. My gpu_mem is set to 128mb so I would assume that would have 128mb for arm.

Code:
OpenELEC:~ # vcgencmd get_mem arm && vcgencmd get_mem gpu
arm=128M
gpu=128M
(2014-07-06, 19:56)Mafarricos Wrote: In #0703 I didn't change any setting.
I will check on the other pi and see if result is the same or is something that went wrong in this RPI.

I've tried reverting PR4919 and the problem is still there, so it's probably another commit that is the problem... investigating.

Edit: Addon text is fine in #0701b, but broken in #0703 onwards.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
The problem in addon settings:
Image
How should be:
Image

Screens taken in android. Xbmc 13.1 (OK) vs xbmc 14 (NOK) from 5 of July.

Separator labels also doesn't show.
Yep.

#0701:
Image
#0703:
Image

#0701:
Image
#0703:
Image

I've just created a test build based on #0706 but without any newclock3 commits, and the addon text is still missing, so it's not newclock3. I'm pretty sure this is PR4919, maybe I didn't revert it correctly.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Regarding the problem with addon text disappearing, the problem is introduced by PR4971 and not PR4919.

PR4971 has made various addon settings case-sensitive so it's possible those addons that are "broken" by PR4971 now need to be updated.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
But this happens to official and non official addons.
Shouldn't the case sensitive be reverted instead?
So the problem is that in the settings some case sensitive option or label is missing the case sensitive?

For eg:

<setting type="lsep" label="Trakt"/>

How that should be to be OK in that PR?
I'm only guessing as to the precise cause, I haven't looked at the addons themselves.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-07-06, 22:20)MilhouseVH Wrote: I'm only guessing as to the precise cause, I haven't looked at the addons themselves.

Yes, but in the example I posted I don't understand why that lsep option isn't shown... I don't see any case sensitive problem...
There may be another reason, I'm only surmising based on the description of what the PR is supposed to do, and the description may not detail every one of the included 13 patches.

All I can say with any certainty is that a build without PR4971 doesn't have the problem but a build with it, does.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Action type labels also doesn't show.
If you check official addon trakt, in General option you don't see the label to reload the settings.
using 706 i just had the issue that when I was watching stuff from video addons using a playlist that XBMC is crashing and restarting as soon as I try to skip the first video or XBMC tries to advance to the next. Was watching stuff yesterday running 703 and didn't have the issue. Haven't tested with local videos in a playlist yet because nas is down atm. not having issues with audio though.
Anybody experiencing the same?
  •   
  • 1
  • 41
  • 42
  • 43(current)
  • 44
  • 45
  • 156
  •   
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888
This forum uses Lukasz Tkacz MyBB addons.