Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
Thanks for the last builds. Videos are working great for me on r18930.
Now my only problem is with airplay. It's very unstable.
I use it with an iphone on iOS 7.1.2
It often works the first time when i boot my Pi.
But the it gets quite messy. For example right now if i connect to AirPlay (and play as this is what actually starts the stream) then i see on my phone that it is connecting but it disconnects after a few seconds.
My main problem is actually that i don't see any log related to Airplay . I have set the debug log level in my advancesettings
Code:
<loglevel hide="true">2</loglevel>
Am i missing something, or isn't there any airplay log?

I also should mention that i have tried with and without:
Code:
<audio>
     <defaultplayer>omxplayer</defaultplayer>
</audio>

UPDATE: i just thought of something, why not get the log from my phone!
Code:
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.164540 wlan.N[1293] IO80211AWDLPeerManager::configureStrategy() AirPlay services:2, others:0 schedstate:Minimum insertInfraForAirplay(1), _useInfraOnSocialTimeslots(1), _setMasterChannelToInfra(1), dynamic_off(1)
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.164605 wlan.N[1294] awdl-interfaceStateChange: Channel 36 is not allowed in this locale; default allowed channel 6
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.164634 wlan.N[1295] awdl-interfaceStateChange: [reason: Mdns] ENABLE-AWDL  (state 0x5 CONFIGURED QUIET _syncState 1 numservices 3 (valid 2) valid_infra 1 cur_infra_channel 36 awdl_solo 0 _mdns_trigger 1 AwdlStateMachine)
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.164679 wlan.N[1296] awdl-interfaceStateChange get infra channel valid 1 infraChannel 36 flags 20 _stateFlags 5 strategy 1 masterChannel 36/0 syncConfigured channelConfigured
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.164831 wlan.A[1297] AppleBCMWLANProximityInterface::setSYNC_ENABLED(): set AWDL->ON pm 8 minExt 7 MasterChan 36/0 step 7 [36 36 36 36]
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.164854 wlan.A[1298] AppleBCMWLANProximityInterface::doSetSyncState(): Cancelled fAWDLOffTimer
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.164946 wlan.N[1299] awdl-interfaceStateChange did enable state 3
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.167752 wlan.N[1300] IO80211AWDLPeerManager::updateLocalRequests() Added Advertising Service
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.167830 wlan.N[1301] IO80211AWDLPeerManager::configureStrategy() AirPlay services:2, others:0 schedstate:MinimumFast insertInfraForAirplay(1), _useInfraOnSocialTimeslots(1), _setMasterChannelToInfra(1), dynamic_off(1)
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.167884 wlan.N[1302] awdl-interfaceStateChange: Channel 36 is not allowed in this locale; default allowed channel 6
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.167912 wlan.N[1303] awdl-interfaceStateChange: [reason: Mdns] ENABLE-AWDL  (state 0x3 CONFIGURED SYNC-ACTIVE _syncState 1 numservices 3 (valid 2) valid_infra 1 cur_infra_channel 36 awdl_solo 0 _mdns_trigger 1 AwdlStateMachine)
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.167954 wlan.N[1304] awdl-interfaceStateChange get infra channel valid 1 infraChannel 36 flags 20 _stateFlags 3 strategy 1 masterChannel 36/0 syncConfigured !channelConfigured
Aug 15 18:40:59 mguillon-iPhone kernel[0] <Debug>: AppleH6CamIn::setPowerStateGated: 0
Aug 15 18:40:59 mguillon-iPhone kernel[0] <Debug>: AppleH6CamIn::power_off_hardware
Aug 15 18:41:01 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:01.311830 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:03 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:03.355202 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:05 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:05.398542 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:05 mguillon-iPhone kernel[0] <Debug>: 104273.229386 wlan.A[1305] AppleBCMWLANProximityInterface::setSYNC_ENABLED(): set AWDL->OFF
Aug 15 18:41:07 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:07.441886 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:09 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:09.485273 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:11 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:11.528664 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:13 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:13.571982 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:15 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:15.615331 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:17 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:17.658704 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:19 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:19.702045 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.356219 PM [AirPlay] ### Endpoint "XBMC (OpenELEC)" options error: -6722/0xFFFFE5BE kTimeoutErr
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.356604 PM [AirPlay] Start summary: TP=WiFi E=RSA L=2000 ms Bonjour=5 ms Connect=4 ms Auth=0 ms Ann=0 ms Setup=0 ms Rec=0 ms Total=30012 ms Err -6722/0xFFFFE5BE kTimeoutErr
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.356998 PM [AirPlay] Disconnected from 192.168.1.20:36666
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.357382 PM [AirPlay] ### Endpoint "XBMC (OpenELEC)" start failed: -6722/0xFFFFE5BE kTimeoutErr
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.357736 PM [BonjourBrowser] Reconfirming PTR for XBMC (OpenELEC)._airplay._tcp.local. on en0
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.358043 PM [BonjourBrowser] Reconfirming PTR for [email protected] (OpenELEC)._raop._tcp.local. on en0
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.358621 PM [AirPlay] Tore down for stream GeneralAudio
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.359081 PM [AirPlay] Posted 'com.apple.AirTunes.endpointStartError' with -6722/0xFFFFE5BE kTimeoutErr
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.359216 PM [AirPlay] Posting kAudioDevicePropertyDataSourceInfoForID: item 77 error: -6722/0xFFFFE5BE kTimeoutErr
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.359711 PM [AirPlay] Client stop finished
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.359901 PM [AirPlay] Quiescing endpoint 'XBMC (OpenELEC)'
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.360126 PM [AirPlay] Posting EndpointDeactivated on quiesce for item 77
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: >vad< ERROR:    18:41:21.361 [tid 0x1024a4000] [158]: CAException thrown from property listener: 4294960569.
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.371728 PM [AirPlay] Stopping HAL audio for AirPlay < Output >
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.375221 PM [AirPlay] Client stop finished
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Error>: 18:41:21.512 ERROR:     [0x1029f4000] >aqme> 241: (0x1310825b0): scope 1, element 0, tag=0x0, 2 channel descriptions [L, R]: error -10851

PS: i am asking here because i remember reading on some post a comment from Memphiz that airplay issues might be distrib related

Thanks
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average


Messages In This Thread
Re: RE: - by Mafarricos - 2014-06-04, 20:21
Live tv issues again - by pootler - 2014-06-04, 23:29
RE: OpenELEC Testbuilds for RaspberryPi Part 3, - by removed151214 - 2014-08-04, 23:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by carmenm - 2014-08-15, 18:39
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-19, 00:11
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-21, 20:42
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:20
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:34
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:44
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 01:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 23:24
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-25, 01:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:26
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-05, 01:07
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 03:48
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 04:06
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 11:29


Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888
This forum uses Lukasz Tkacz MyBB addons.