•   
  • 1
  • 69
  • 70
  • 71(current)
  • 72
  • 73
  • 156
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
(2014-08-20, 12:11)Bohlendach Wrote: Cannot play iso or img movies, but plays mkv's and avi's. When a iso/img movie is stated the cpu usage is 100% and stays there. The movie does not start, but i am able to navigate in XBMC and reboot the pi.

Just spotted a bug that causes a hang and 100% usage when using dvdplayer (with default options this will be chosen for iso/img files) and flushing (I was seeing it on seek, but it may happen in other situations).

I've pushed a fix to newclock4. newclock3 wasn't affected.
New OpenELEC Helix build: #0820
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 3.16.1 #1 PREEMPT Wed Aug 20 21:00:14 BST 2014 armv6l GNU/Linux

# vcgencmd version
Aug 12 2014 18:21:28
Copyright (c) 2012 Broadcom
version f32b2bbfdea55d48c9a52b92e5c798f9aa5f47bc (tainted) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20140820205859-r19038-gfd36711 [Build #0820]

Based on tip of OpenELEC master (fd367117, changelog) and tip of XBMC master (303d857f, changelog) with the following modifications:
  • Includes newclock3 patches
  • Excludes the OpenELEC fernetmenta patches due to conflicts with newclock3
  • Excludes the OpenELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-3.16.y
  • Excludes the OpenELEC xbmc-001-newclock3 patch in favour of sourcing these and possibly more recent patches directly from newclock3 branch
  • Default setting for "Show RSS Feed" changed to disabled
  • Disabled "Total Duration" in Confluence (see build #0221 for details)
  • Includes latest libnfs master (5fe97d10)
  • Includes latest libcec master (81e38211)
  • Includes libcec double-key suppression.
  • Includes libcec CEC Standby Fix.
  • Increase scan interval of PeripBusCEC from 5000 to 60000, reducing CPU loading by about 2% (1GHz Pi) every 5 seconds (even when CEC is "disabled")
  • Includes CONFIG_COREDUMP=y to allow creation of coredumps
  • Includes PR5222: videodb: Add column name on GROUP query otherwise sub query returns no rows
  • Includes PR5237: [WIP][3D] add support for stereomode switches in video playlist
  • Includes PR5244: [UX] keymap fixes - don't overload pause action with something else
  • Includes PR5245: [UX] consistent playback behavior for music and video
  • Includes PR5247: StringUtils: optimize Split(), new overloads for Split() and Tokenize()
Build Highlights:
  1. newclock3-based build.
  2. PR5237: [WIP][3D] add support for stereomode switches in video playlist
Build Details:
  1. XBMC:
    • AESinkPULSE: Fix linear volume to do the same as other PA apps (PR:5231, 3 commits, 2 files changed)
    • [Make] - don't install .git directories (PR:5243, 1 commit, 1 file changed)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Experimental newclock4 build uploaded: #0820b

Same as build #0820, but with newclock4 patches in place of newclock3. See here for details.

newclock4 additions since previous build #0819b:
  • [omxcodec] Need to resend codec config after flushing
  • [omxplayer] Flush clock after components
  • [omxplayer] Remove flush on seek
  • [omxplayer] Use 0 for video timestamps when using trickplay

Feedback on omxplayer while seeking/trickplay would be welcomed, as this code has changed quite a bit with the dvdplayer refactor.

Feedback on dvdplayer performance (including seeking/trickplay) would also be appreciated.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Just confirming that the crash on starting Airplay is gone in the current build (820). Thanks very much.

Confluence skin update.

Hi, should updates from here updates skins too? I see the LiveTV section of the Confluence skin has changed (see http://wiki.xbmc.org/index.php?title=Ski...ix_release and https://github.com
/xbmc/xbmc/blob/master/addons/skin.confluence/720p/MyPVRChannels.xml) but my install doesn't have MyPVRChannels.xml. I update using the .update folder method. My Confluence skin files are mainly dated 24/05/2013.
Where are your Confluence skins stored - what's the path?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Default path I think: /storage/.xbmc/addons/skin.confluence

Paul
I thought you knew the path as you checked the dates. Anyway, if that is the path then it's a version of Confluence you've installed that has superseded the built-in version. Delete that folder.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
[I noticed because I use the ConfluenceWMC skin which has amendments for the ServerWMC PVR addon - and this recently stopped working (screen just goes blank when selecting any of the Live TV menu options). My xbmc.log shows

09:16:32 415.470856 T:3059613696 DEBUG: ------ Window Init (MyPVRChannels.xml) ------
09:16:32 415.471375 T:3059613696 INFO: Loading skin file: MyPVRChannels.xml, load type: KEEP_IN_MEMORY
09:16:32 415.472900 T:3059613696 ERROR: unable to load:/storage/.xbmc/addons/skin.confluence.wmc/720p/MyPVRChannels.xml, Line 0
09:16:50 433.569366 T:3059613696 DEBUG: ------ Window Deinit (MyPVRChannels.xml) ------

.. however the default Confluence skin doesn't have that file either].

Oh unless some one-time migration is done when I pick the Confluence skin? I'll try that...

> Oh unless some one-time migration is done when I pick the Confluence skin? I'll try that...

Nope. I can grab the updated skin files from github so it's no issue, just raised it in case there's an upgrade problem somewhere.

Paul

The 'I think' was about it being the default, that is the path. I'll need to do some more digging into the wmc version of that skin. Thanks for the pointers.

Paul
(2014-08-21, 04:12)whiffyfuzzball Wrote: .. however the default Confluence skin doesn't have that file either].

Oh unless some one-time migration is done when I pick the Confluence skin? I'll try that...

> Oh unless some one-time migration is done when I pick the Confluence skin? I'll try that...

Nope. I can grab the updated skin files from github so it's no issue, just raised it in case there's an upgrade problem somewhere.

There's nothing wrong with the upgrade.

Code:
rpi512:~ # ls -la /usr/share/xbmc/addons/skin.confluence/720p/MyPVRChannels.xml
-rw-rw-r--    1 root     root         13421 Aug 20 21:50 /usr/share/xbmc/addons/skin.confluence/720p/MyPVRChannels.xml

The version of skin.confluence you've installed has taken precedence over the built-in version, and the version you've installed is out of date. Delete it, and stop installing Confluence from git, it's totally unnecessary.

(2014-08-21, 04:12)whiffyfuzzball Wrote: The 'I think' was about it being the default, that is the path. I'll need to do some more digging into the wmc version of that skin. Thanks for the pointers.
It's only the "default" path if you've installed your own non-standard version of skin.confluence.

You'll need to contact the skin.confluence.wmc author for support in Helix, PVR support is a moving target right now.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
So if anyone else has this, I had to re-do this procedure:

http://wiki.xbmc.org/index.php?title=Add..._recording

All good now.

Thanks,

Paul
Been away for a while. But the latest builds broke my setup. Still using Newclock3, and using HifiBerry Digi for audio and Hyperion/Lightpack for ambilight and dvdplayer as the video player. The last build which is fine is 0806, so something in 0807 screws things over... I'm not able to play video's with multichannel audio since the 0807 build, it's playing, but it's playing at 15 fps (CPU around 20%) and no sound at all.

Stereo files use HDMI, so don't use the Hifiberry, and are playing fine. Disabling passthrough in the settings didn't resolve the play issue for multichannel audio.


Debug log
Thanks for the report! What if you remove Hyperion/Lightpack from the equation, still the same problem?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Skipping a h.264 video using dvdplayer on newclock4 appears to now work perfectly on the latest builds. Huge thanks Milhouse and popcornmix for your continued excellent work.
Without Hyperion still the same.
Disabling Hifiberry from boot (remove the conf file from modules-load.d) will resolve this issue though (and, of course, set speaker config to 2.0 and disable passthrough, since my tv can't handle passthrough).

So it's something with the HifiBerry, it's mentioned in the 0817 build (Hifiberry DAC+ support), but nothing in 0807...

Are there any other Hifiberry Digi users out there?

Edit: Newclock4 completely crashed when starting a video with hifyberry enabled, had to pull the plug. With Hyperion and Hifiberry disabled the 820b Newclock4 build also plays a video. (the debug log didn't show anything usefull, so didn't mention this).
O.K - latest new clock 4 build.

Channel change on live tv seems to work without blank screen
BUT- there is a serious video problem.
Picture jitters and stutters on all channels.
Really gives you a headache to watch it!

pootler
  •   
  • 1
  • 69
  • 70
  • 71(current)
  • 72
  • 73
  • 156
  •   
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888