•   
  • 1
  • 72
  • 73
  • 74(current)
  • 75
  • 76
  • 156
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
(2014-08-21, 20:46)ijsbeer79 Wrote: Without Hyperion still the same.
Disabling Hifiberry from boot (remove the conf file from modules-load.d) will resolve this issue though (and, of course, set speaker config to 2.0 and disable passthrough, since my tv can't handle passthrough).

So it's something with the HifiBerry, it's mentioned in the 0817 build (Hifiberry DAC+ support), but nothing in 0807...

Are there any other Hifiberry Digi users out there?

Are there no Hifiberry Digi users out there?
(2014-08-20, 23:36)Milhouse Wrote: Feedback on omxplayer while seeking/trickplay would be welcomed, as this code has changed quite a bit with the dvdplayer refactor.
Feedback on dvdplayer performance (including seeking/trickplay) would also be appreciated.

Well, here is some feedback on #0823b.
I have not had any problem with omxplayer.

Seeking in DVD/iso's works ok at speed x2, but above trick play are problematic with black screens for for half a second or more. When forwarding/seeking x16 or x32 it looses pace and sometimes stepping a bit forward and backward. However, I think its a minor problem.
(2014-08-25, 14:26)popcornmix Wrote:
(2014-08-24, 14:59)Jönke Wrote: Ok but then live-tv uses dvdplayer, not OMXplayer.

How to set omxplayer for live tv ?

I've just has a look and with the 3 acceleration options enabled it uses omxplayer for livetv (e.g. codec omx-h264 or omx-mpeg2).
If you are not getting that can you post a debug enabled log file.

http://xbmclogs.com/show.php?id=276614

Played 2 diffrent sd channels and 1 hdtv channel and all was using dvdplayer.
(2014-08-25, 18:23)popcornmix Wrote:
(2014-08-25, 15:00)evanspae Wrote: I tried DSD multi channel audio on this build but afraid playback lots of clicks and plops.
I am comparing this latest RPI build against my stock Windows7 PC with XXBMC (13.0-ALPHA12 Git:20140210-699163e) which fully supports multi audio.

Which file were you playing? The first sample linked from the PR is 352kHz.
We were refusing to resample above 192kHz, but I've removed that limit with latest commit and that sample seems to play.

If you were trying to play something below 192kHz then it may be another issue and a sample file would be useful.

I have tried a few different 5.1 commercial files 176400, I will try to put together a sample.
Code:
General
Complete name                            : \\ARGUSSERVER-W7\Flac\flac\HD-96-24\Elton John - Captain Fantastic And The Brown Dirt Cowboy\01 - Elton John - Captain Fantastic And The Brown Dirt Cowboy.flac
Format                                   : FLAC
Format/Info                              : Free Lossless Audio Codec
File size                                : 468 MiB
Duration                                 : 5mn 48s
Overall bit rate mode                    : Variable
Overall bit rate                         : 11.3 Mbps
Album                                    : Captain Fantastic And The Brown Dirt Cowboy
Track name                               : Captain Fantastic And The Brown Dirt Cowboy
Track name/Position                      : 1
Performer                                : Elton John
Genre                                    : Other
Recorded date                            : 2004-14-10

Audio
Format                                   : FLAC
Format/Info                              : Free Lossless Audio Codec
Duration                                 : 5mn 48s
Bit rate mode                            : Variable
Bit rate                                 : 11.3 Mbps
Channel(s)                               : 6 channels
Channel positions                        : Front: L C R, Back: L R, LFE
Sampling rate                            : 176.4 KHz
Bit depth                                : 24 bits
Stream size                              : 468 MiB (100%)
Writing library                          : libFLAC 1.3.0 (UTC 2013-05-26)
Location UK; Media server Windows 7 with ArgusTV 2.3 with TBS6981 DVB-S2 x4 and DVB-T x 2:All network connections cabled on 1Gb router Raspberry Pi2 1GB x 2; RPI 3 x1; PiB+512MB x 3; TV Samsung 55" C8000; AV Denon AVR X2200W
New OpenELEC Helix build: #0825
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 3.16.1 #1 PREEMPT Mon Aug 25 22:08:04 BST 2014 armv6l GNU/Linux

# vcgencmd version
Aug 20 2014 22:46:14
Copyright (c) 2012 Broadcom
version daf2c8c0795066867ef863d938bbbcc7391f1b4a (tainted) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20140825220649-r19098-g0763615 [Build #0825]

Based on tip of OpenELEC master (07636151, changelog) and tip of XBMC master (f60bdf77, changelog) with the following modifications:
  • Includes newclock3 patches
  • Excludes the OpenELEC fernetmenta patches due to conflicts with newclock3
  • Excludes the OpenELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-3.16.y
  • Excludes the OpenELEC xbmc-001-newclock3 patch in favour of sourcing these and possibly more recent patches directly from newclock3 branch
  • Default setting for "Show RSS Feed" changed to disabled
  • Disabled "Total Duration" in Confluence (see build #0221 for details)
  • Includes latest libnfs master (5fe97d10)
  • Includes latest libcec master (81e38211)
  • Includes libcec double-key suppression.
  • Includes libcec CEC Standby Fix.
  • Increase scan interval of PeripBusCEC from 5000 to 60000, reducing CPU loading by about 2% (1GHz Pi) every 5 seconds (even when CEC is "disabled")
  • Includes CONFIG_COREDUMP=y to allow creation of coredumps (see here)
  • Includes PR5217: [python] add xbmc.abortEvent
  • Includes PR5222: videodb: Add column name on GROUP query otherwise sub query returns no rows
  • Includes PR5237: [WIP][3D] add support for stereomode switches in video playlist
  • Includes PR5244: [UX] keymap fixes - don't overload pause action with something else
  • Includes PR5245: [UX] consistent playback behavior for music and video
  • Includes PR5247: StringUtils: optimize Split(), new overloads for Split() and Tokenize()
  • Includes PR5281: Dbwrappers return error value fix
  • Includes PR5285: guilib: Fix CGUIListGroup::MoveRight()
Build Highlights:
  1. newclock3-based build.
  2. DSD playback should be working now.
Build Details:
  1. OpenELEC:
    • xbmc: add PR5275
    • samba: clean up unused configure opts
    • samba: link with -fwhole-program
    • xbmc: link with -fwhole-program
    • repository.unofficial.addon.pro: TARGET_ARCH is better...
  2. XBMC:
    • Added SFTP to the check for internet streams (fixes #15391) (PR:5278, 1 commit, 1 file changed)
    • pvr: fix deadlock caused by pollling channel group name (PR:5269, 1 commit, 5 files changed)
  3. newclock3:
    • [PiSink] Fix typo in list of passthrough samplerates
    • [resamplepi] Support samplerates above 192kHz
  4. Custom:
    • Added: PR5281, Dbwrappers return error value fix
    • Added: PR5285, guilib: Fix CGUIListGroup::MoveRight()
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Experimental newclock4 build uploaded: #0825b

Same as build #0825, but with newclock4 patches in place of newclock3. See here for details.

newclock4 additions since previous build #0823b:
  • [omxcodec] Tidy up
  • [PiSink] Fix typo in list of passthrough samplerates
  • [resamplepi] Support samplerates above 192kHz
  • [omxcodec] Tidy up 2
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
o.K -

I'm sorry to keep going on about this - BUT -

Is there no-one else out there having major problems with live tv at the moment using the latest newclock3/4 builds??

It feels like it has gone back a year to the good old days when you couldn't get a picture!

I use latest VDR and am using a DVB-T tuner

Works fine on Official 4.14.

Am I alone with this Smile

thanks

pootler


I
Just so you don't feel alone, yes, there's someone else having problems with PVR... Big Grin

I'm also having problems with PVR using newclock4.

Specifically, I'm having problems with HD channels using newclock4. Same channels play nice with newclock3.

I'm still investigating and more info is on the way once I have the time.
Searching in the YouTube addon will cause xbmc.bin to segfault in both #0825 (newclock3) and #0825b (newclock4) - this is caused by "xbmc: link with -fwhole-program", which will be reverted in the next build.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-08-26, 00:58)pootler Wrote: o.K -

I'm sorry to keep going on about this - BUT -



Is there no-one else out there having major problems with live tv at the moment using the latest newclock3/4 builds??

It feels like it has gone back a year to the good old days when you couldn't get a picture!

I use latest VDR and am using a DVB-T tuner

Works fine on Official 4.14.

Am I alone with this Smile

thanks

pootler




I

(2014-08-26, 02:18)h.udo Wrote: Just so you don't feel alone, yes, there's someone else having problems with PVR... Big Grin

I'm also having problems with PVR using newclock4.

Specifically, I'm having problems with HD channels using newclock4. Same channels play nice with newclock3.

I'm still investigating and more info is on the way once I have the time.
Can you check if OMXplayer or dvdplayer are used at yours setup for live tv ?
I have problem with live tv with menus on dvdplayer but not OMXplayer
@Jönke,

Skimming through the debug log, I'm almost certain dvdplayer is being used but, like I said earlier, I'll investigate further at a later time (currently enjoying some much deserved vacation).

@popcornmix

I'm also seeing something fishy with newclock4 OSD and video FPS decoupled mechanism. Behaviour goes like this:

Power on RPi >> OSD FPS stays around 30 like it does with newclock3
After a while(?) >> OSD FPS drops to 2 and stays there

After FPS drop, OSD becomes very sluggish and unresponsive. I'm seeing something like 5 secs to respond to remote control, i.e. nearly unusable.

It feels like the CPU is busy with something and can't process commands fast enough. Videos play nice and without problems.

All in all, excellent work guys!

h.udo
(2014-08-26, 02:18)h.udo Wrote: Just so you don't feel alone, yes, there's someone else having problems with PVR... Big Grin

I'm also having problems with PVR using newclock4.

Specifically, I'm having problems with HD channels using newclock4. Same channels play nice with newclock3.

I'm still investigating and more info is on the way once I have the time.
I'm also having problems with PVR. The SD Channels works fine. The video of the HD Channels is fine also, but with the audio I have problems. When I select AC3 audio I only hear noice, the other audio streams (mp2) works fine.

Here is the log file: [/URL] http://xbmclogs.com/show.php?id=277168 [/URL]

When I watch a recording everything works fine.
I use the newclock4 build 825
(2014-08-25, 21:23)Jönke Wrote: Played 2 diffrent sd channels and 1 hdtv channel and all was using dvdplayer.

This is the issue:
Code:
20:51:30 116.395012 T:2725516368  NOTICE: COMXPlayer::CreatePlayers OMXPlayer unsuitable due to video codec

I suspect this is due to the PVR client and the fast channel change patch where we can actually start playing before the codecs are known (only once a video packet is seen we initialise the video decoder) which avoids the usual delay while probing for audio/video formats.

I think it makes more sense to treat no codecs at all as supported rather than unsupported, which will make omxplayer get chosen in future.
Just updated from 5 Aug release to #0825 and after xbmc starts it reboots and enter in bootloop (reboots, enter in xbmc and then reboots and so one). No one with this problem?
(2014-08-26, 19:33)Mafarricos Wrote: Just updated from 5 Aug release to #0825 and after xbmc starts it reboots and enter in bootloop. No one with this problem?

Probably an addon causing a segfault, possibly the same problem triggered by searching in the YouTube addon (which will be fixed in tonights build). Try testing against #0824 (which doesn't have the YouTube problem), and confirm if #0826 fixes the problem once it is released (in another 2-3 hours time).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 72
  • 73
  • 74(current)
  • 75
  • 76
  • 156
  •   
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888