•   
  • 1
  • 74
  • 75
  • 76(current)
  • 77
  • 78
  • 156
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
(2014-08-27, 11:18)da-anda Wrote: @popcornmix do you have some time to look into the resolution switch issue with video playlists and 3D movies? Or tell me what debug info you need - here is a debug log ( http://xbmclogs.com/show.php?id=277676 ) using a playlist with 3d, 2d, 3d, 2d movies.

It's on my list to investigate, but there's a few things ahead of it. Hopefully soon...
thanks - only wanted to know if you gonna look at it - no pressure. Just ping me if you want me to test something or need further debugging info
(2014-08-26, 18:48)popcornmix Wrote:
(2014-08-25, 21:23)Jönke Wrote: Played 2 diffrent sd channels and 1 hdtv channel and all was using dvdplayer.

This is the issue:
Code:
20:51:30 116.395012 T:2725516368  NOTICE: COMXPlayer::CreatePlayers OMXPlayer unsuitable due to video codec

I suspect this is due to the PVR client and the fast channel change patch where we can actually start playing before the codecs are known (only once a video packet is seen we initialise the video decoder) which avoids the usual delay while probing for audio/video formats.

I think it makes more sense to treat no codecs at all as supported rather than unsupported, which will make omxplayer get chosen in future.

Thanks for fixing ! Working again in latest build Smile
New OpenELEC Helix build: #0827
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 3.16.1 #1 PREEMPT Wed Aug 27 22:45:09 BST 2014 armv6l GNU/Linux

# vcgencmd version
Aug 27 2014 00:01:04
Copyright (c) 2012 Broadcom
version 6acafacba2a565f920610499c785831c2d5638bf (tainted) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20140827224351-r19131-g6be4489 [Build #0827]

Based on tip of OpenELEC master (6be4489f, changelog) and tip of XBMC master (afdbb56c, changelog) with the following modifications:
  • Includes newclock3 patches
  • Excludes the OpenELEC fernetmenta patches due to conflicts with newclock3
  • Excludes the OpenELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-3.16.y
  • Excludes the OpenELEC xbmc-001-newclock3 patch in favour of sourcing these and possibly more recent patches directly from newclock3 branch
  • Default setting for "Show RSS Feed" changed to disabled
  • Disabled "Total Duration" in Confluence (see build #0221 for details)
  • Includes latest libnfs master (5fe97d10)
  • Includes latest libcec master (81e38211)
  • Includes libcec double-key suppression.
  • Includes libcec CEC Standby Fix.
  • Increase scan interval of PeripBusCEC from 5000 to 60000, reducing CPU loading by about 2% (1GHz Pi) every 5 seconds (even when CEC is "disabled")
  • Includes CONFIG_COREDUMP=y to allow creation of coredumps (see here)
  • Includes PR5217: [python] add xbmc.abortEvent
  • Includes PR5222: videodb: Add column name on GROUP query otherwise sub query returns no rows
  • Includes PR5237: [WIP][3D] add support for stereomode switches in video playlist
  • Includes PR5244: [UX] keymap fixes - don't overload pause action with something else
  • Includes PR5245: [UX] consistent playback behavior for music and video
  • Includes PR5247: StringUtils: optimize Split(), new overloads for Split() and Tokenize()
Build Highlights:
  1. newclock3-based build.
  2. Updated firmware, fixes omx-encoding errors introduced by 20 Aug firmware.
Build Details:
  1. Firmware (Aug 27):
    • firmware: ril_top: fix for setting parameter sizes on get_parameter. Fixes issue with image_encode returning errors from openmax
    • vchi: Remove unimplemented vchi_exit prototype
    • firmware: image_fx: Ensure pending_vc_image is reset when clearing vc_image. Fixes issue when flushing image_fx
    • firmware: arm_display: Handle display closed without busy spinning or asserts. See: link
    • mmal: Plumb in OMX_IndexConfigCommonInterlace to mmal
  2. OpenELEC:
    • projects/*/linux: sync kernel config
    • libva-intel-driver: update upstream patches
    • projects/Cuboxi/linux: enable thermal driver, thanks to 'vpeter'
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Should this firmware fix the issue with fanart not reloading for the currently selected item when stopping a movie?
(2014-08-28, 14:02)bagofcrap24 Wrote: Should this firmware fix the issue with fanart not reloading for the currently selected item when stopping a movie?

Not that I'm aware of. The issue observed was when caching an image to the thumbnail cache (i.e. the first time it ws viewed) was producing an error and falling back to the non-accelerated code path. I believe it would have still worked, but been much slower.

I've not seen the problem with fanart not reloading after stopping. Can you provide more details and perhaps a debug log file?
On #0824 and #0827 noticed that some addons doesn't update, and when forced to update xbmc just hangs... I'm able to reboot via ssh.

Addons like keymap editor (program) and legendasdivx.com (subtitles) both in official xbmc repo.
Those 2 addons have been updated but aren't able to update, probably a problem related with segfault problem?

Already checked logfile and didn't saw nothing special, will provide latter if necessary.

Edit:
Probably a problem with xbmc server?
Now I got this on logfile:
http://xbmclogs.com/show.php?id=278542
Can this be caused by other thing?
(2014-08-28, 15:10)Mafarricos Wrote: On #0824 and #0827 noticed that some addons doesn't update, and when forced to update xbmc just hangs... I'm able to reboot via ssh.

Addons like keymap editor (program) and legendasdivx.com (subtitles) both in official xbmc repo.
Those 2 addons have been updated but aren't able to update, probably a problem related with segfault problem?

Already checked logfile and didn't saw nothing special, will provide latter if necessary.

Edit:
Probably a problem with xbmc server?
Now I got this on logfile:
http://xbmclogs.com/show.php?id=278542
Can this be caused by other thing?
Yes, the xbmc mirrors are down right now, which is the problem you are most likely seeing.

Thanks for letting us know your reboot loop is fixed.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-08-28, 14:21)popcornmix Wrote:
(2014-08-28, 14:02)bagofcrap24 Wrote: Should this firmware fix the issue with fanart not reloading for the currently selected item when stopping a movie?

Not that I'm aware of. The issue observed was when caching an image to the thumbnail cache (i.e. the first time it ws viewed) was producing an error and falling back to the non-accelerated code path. I believe it would have still worked, but been much slower.

I've not seen the problem with fanart not reloading after stopping. Can you provide more details and perhaps a debug log file?

Steps To Reproduce.
1. Start a movie from the library.
2. Stop the movie
It takes you back to the movie list however the fanart for the currently highlighted film is not reloaded.
Moving up or down will show the correct fanart, however highlighting the original item that i just stopped will not reload the fanart.
Going into the info and choose fanart does not show the preview of the current fanart or poster either.
Choosing a different film and stopping that will move the problem to that film. The first film will now show proper fanart but the one i just stopped will not.
See Video Below

http://youtu.be/6a9PD1kgbYA

Here is the debug log
http://pastebin.com/xVXmnHBy

at about 15:37:14 is where i stopped the video and it loads the poster but not the fanart.
(2014-08-28, 17:03)bagofcrap24 Wrote: Steps To Reproduce.
1. Start a movie from the library.
2. Stop the movie
It takes you back to the movie list however the fanart for the currently highlighted film is not reloaded.
Moving up or down will show the correct fanart, however highlighting the original item that i just stopped will not reload the fanart.
Going into the info and choose fanart does not show the preview of the current fanart or poster either.
Choosing a different film and stopping that will move the problem to that film. The first film will now show proper fanart but the one i just stopped will not.

This is Amber? Does it also occur with Confluence?
@bagofcrap24: Can you reproduce with stock Confluence (I can't). Assuming you don't see the same issue with Confluence, it's most probably a skin issue/bug. Do you also see this problem with 4.0.7/4.1.4?

Edit: I'm too slow... Smile

Edit2: Just tested with Amber and unable to reproduce (I tested with all of the movie library views). Maybe some issue with Textures13.db/caching?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Sorry. Should have really used confluence for debugging but yes. The behavior is exactly the same

This wasnt here in 4.0.7
I did a clean wipe when I jumped from 4.0.7 to your test build 15th august. I've had the issue in all builds since. I'll try 4.1.5 now
Assuming it's not also an issue in 4.1.5, the next step would be to work back through these test builds to try and determine when the problem first appears (which is tedious, I know, but necessary).

Edit: Actually, working back through these builds would be a good idea whether the issue is present in 4.1.5 or not, as 4.1.5 is based on Gotham not master and it could be a change added to master. Though as I can't reproduce and nobody else has mentioned it, I'd be more inclined to think it's a glitch with the caching.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
arrggh, cant test 4.0.7 or 4.1.5 without starting fresh because my first DB version with your test build is already higher than they are using XD.

I'll see if I can track it down

Forgot about my 2nd pi that my dad uses. That has older dB's on it so I'll check with that one.

Updated to same build on his b that is on my b+ and error is repeatable.
Will work my way backwards to find when it works
Ok, so it still does it on 4.0.7

there must be something wrong with my setup
  •   
  • 1
  • 74
  • 75
  • 76(current)
  • 77
  • 78
  • 156
  •   
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888