•   
  • 1
  • 115
  • 116
  • 117(current)
  • 118
  • 119
  • 156
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
hi,

maybe stupid question, but is any possibility to get work webgrabplus?
(2014-10-22, 19:07)paulyz Wrote: hi,

maybe stupid question, but is any possibility to get work webgrabplus?

See "Feature Requests" section in the first post.

Edit: I meant this post not the first thread.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
ok ok, I understand

If you want - do by yourself Smile
(2014-10-22, 17:52)slack3r Wrote: Does anyone have problems with subtitles? Here videos stutter every 20-30 seconds.
I had problems with <1019 builds (didn't test all), but with #1019 they are gone. Will report back, if they show up again.
Wetek Play: LE 9.0.x as TVH-server --- RPi3: latest Milhouse LE 9.x (Matrix) with AeonNoxSilvo --- Orbsmart 500 with Kodi18 as Online-radio/TV in the kitchen
(2014-10-22, 19:33)Solo0815 Wrote:
(2014-10-22, 17:52)slack3r Wrote: Does anyone have problems with subtitles? Here videos stutter every 20-30 seconds.
I had problems with <1019 builds (didn't test all), but with #1019 they are gone. Will report back, if they show up again.
K, thank you.
(2014-10-22, 12:38)Milhouse Wrote:
(2014-10-22, 12:23)platin Wrote: this is very weird, iam with #1021 and after i send the log it still on #1019

After the rebranding, the log is now called kodi.log (from #1020/#1021 onwards) - you're uploading your old log from #1019 which is when the log was last called xbmc.log. Maybe there needs to be a symbolic link from xbmc.log to kodi.log.

I've just installed the OpenELEC Dev Update addon from github (sha:9b1d605e, install from zip) and configured it to use my folder as the Source URL (ie. "MilhouseVH Builds (RPI)") with everything else left as default, and it fails while looking for "/usr/lib/xbmc/xbmc.bin" which no longer exists (it''s now "/usr/lib/kodi/kodi.bin").

Haven't been able to reproduce any BS4 failure.

Debug log: http://sprunge.us/hCLO
Thanks for the log. I've now fixed this problem.
Leopold's Repository: Home of LibreELEC Dev Updater ...
(2014-10-22, 22:42)Leopold Wrote:
(2014-10-22, 12:38)Milhouse Wrote:
(2014-10-22, 12:23)platin Wrote: this is very weird, iam with #1021 and after i send the log it still on #1019

After the rebranding, the log is now called kodi.log (from #1020/#1021 onwards) - you're uploading your old log from #1019 which is when the log was last called xbmc.log. Maybe there needs to be a symbolic link from xbmc.log to kodi.log.

I've just installed the OpenELEC Dev Update addon from github (sha:9b1d605e, install from zip) and configured it to use my folder as the Source URL (ie. "MilhouseVH Builds (RPI)") with everything else left as default, and it fails while looking for "/usr/lib/xbmc/xbmc.bin" which no longer exists (it''s now "/usr/lib/kodi/kodi.bin").

Haven't been able to reproduce any BS4 failure.

Debug log: http://sprunge.us/hCLO
Thanks for the log. I've now fixed this problem.

thanks its working now
New OpenELEC Helix build: #1022
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 3.17.1 #1 PREEMPT Wed Oct 22 21:03:54 BST 2014 armv6l GNU/Linux

# vcgencmd version
Oct 17 2014 17:56:05
Copyright (c) 2012 Broadcom
version 845092531e360acd37f2f1964157f8079c77edfb (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20141022210241-r19452-g0858c78 [Build #1022]

Based on tip of OpenELEC master (0858c78a, changelog) and tip of XBMC master (94636baf, changelog) with the following modifications:
  • Includes newclock4 patches
  • Excludes the OpenELEC fernetmenta patches due to conflicts with newclock4
  • Excludes the OpenELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-3.17.y
  • Excludes the OpenELEC xbmc-001-newclock4 patch in favour of sourcing these and possibly more recent patches directly from newclock4 branch
  • Default setting for "Show RSS Feed" changed to disabled
  • Disabled "Total Duration" in Confluence (see build #0221 for details)
  • Adapted service.openelec.settings to take advantage of PR5217
  • Includes latest libnfs master (ab1af695)
  • Includes latest libcec master (81e38211)
  • Includes latest xbmc-pvr-addons master (067befe6)
  • Includes latest xbmc-addon-xvdr master (2bf2563c)
  • Includes libcec double-key suppression
  • Includes libcec CEC Standby Fix
  • Increase scan interval of PeripBusCEC from 5000 to 60000, reducing CPU loading by about 2% (1GHz Pi) every 5 seconds (even when CEC is "disabled")
  • Includes CONFIG_COREDUMP=y to allow creation of coredumps (see here)
  • Includes additional ffmpeg codecs/muxers enabled for testing/benchmarking purposes. See patch
  • Includes PR:5312: dvdplayer: do a seek after having changed subtitle stream
  • Includes PR:5416: added: POC mp4 movie/episode tag support
  • Includes PR:5524: Respect parent path decision when cleaning paths.
Build Highlights:
  1. vdr-plugin-vnsiserver bump
  2. Allow player to retry read in case of read errors
Build Details:
  1. OpenELEC:
    • service.openelec.settings: update to service.openelec.settings-0.4.4
    • service.openelec.settings: update to service.openelec.settings-0.4.5
    • scripts/image: add ARCH= and BUILD= to /etc/os-release
    • scripts/image: prefix OpenELEC own variables with OPENELEC_ in /etc/os-release
    • vdr-plugin-vnsiserver: update to vdr-plugin-vnsiserver-a7cb405
    • vdr-addon: update changelog
    • vdr-addon: bump addon version to 4.3.1
  2. XBMC:
    • dxva: fix memory leak caused by additional ref on video surfaces (PR:5541, 1 commit, 1 file changed)
    • [pvr] bump add-ons (PR:5544, 1 commit, 2 files changed)
    • Allow player to retry read in case of read errors (PR:5537, 2 commits, 3 files changed)
    • Fix gtests after rebrand (PR:5552, 2 commits, 3 files changed)
    • [pvr] fix unnecessary creation of new CPVRChannel instances (PR:5473, 1 commit, 1 file changed)
    • [pvr] fix continue playback of last watched channel on startup if group was deleted or channel was moved (PR:5526, 1 commit, 5 files changed)
    • [pvr] fix call to base class GetContextButtons() to re-add favorite entry (PR:5547, 1 commit, 5 files changed)
    • [git] - add generated FEH-ARM.py and FEH.py to gitignore
    • [osx] - don't release strings we didn't alloc - fixes crash on shutdown (introduced in rebrand)
    • [buildsteps] fix linux32 gtests invocation as well
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
K, log attached when video stuttering occurs:

http://pastebin.com/N058EK5h

See my previous post.

I'm running build #1022.

Thanks
(2014-10-23, 09:17)slack3r Wrote: K, log attached when video stuttering occurs:

http://pastebin.com/N058EK5h

Always post the complete log. Don't cut it down.
(2014-10-23, 12:28)popcornmix Wrote: Always post the complete log. Don't cut it down.

Ok. I will do it asap, thank you.

P.s.
Build #1004 seems running fine.
(2014-10-23, 12:28)popcornmix Wrote: Always post the complete log. Don't cut it down.

Attached:
http://pastebin.com/q5AMwHhL
(2014-10-23, 14:38)slack3r Wrote: Attached:
http://pastebin.com/q5AMwHhL

I suspect these are important:
Code:
14:17:05 399.017242 T:2729636944   ERROR: CCurlFile::FillBuffer - Failed: Failure when receiving data from the peer(56)
14:17:05 399.017944 T:2729636944  NOTICE: CCurlFile::FillBuffer - Reconnect, (re)try 1
but there's not much info there. Enabling component specific debugging and enabling curl may give more info.

Also you say #1004 is good and #1022 is bad - can you identify the exact build that started the problem.
That may indicate an updated library or a pull request that caused the problem.
(2014-10-23, 14:43)popcornmix Wrote: I suspect these are important:
Code:
14:17:05 399.017242 T:2729636944   ERROR: CCurlFile::FillBuffer - Failed: Failure when receiving data from the peer(56)
14:17:05 399.017944 T:2729636944  NOTICE: CCurlFile::FillBuffer - Reconnect, (re)try 1
but there's not much info there. Enabling component specific debugging and enabling curl may give more info.
I will post it asap. Thank you very much.

Quote:Also you say #1004 is good and #1022 is bad - can you identify the exact build that started the problem.
That may indicate an updated library or a pull request that caused the problem.
I think the issue occurs between #1004 and #1007, but I'm not sure. I'll let you know.
@popcornmix
New log with curl debugging:

http://pastebin.com/Rn28VVsV
  •   
  • 1
  • 115
  • 116
  • 117(current)
  • 118
  • 119
  • 156
  •   
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888