Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
(2014-10-27, 15:08)shadowghost Wrote: For me DVD-playback isn't working in the latest builds. Last working build for me was #1018 before the Kodi-rebranding (haven't tried all between but I'm pretty sure it wasn't working since then). Tried renaming .kodi folder and setting it up fresh but had no effect. There isn't even the "Working..." showing up on the bottom right.
Only thing in log I found which is connected to a DVDPlayer Error:

DVD ISO and IFO playback is working for me, at least with my one test DVD that I've ripped to both ISO and extracted as folders.

Code:
13:26:08 47825.785156 T:3041030144  NOTICE: DVDPlayer: Opening: /storage/freenas/media/Video-Test/DVDTS/Hitchikers Guide - Extra/VIDEO_TS/VIDEO_TS.IFO
13:26:08 47825.785156 T:3041030144 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
13:26:08 47825.785156 T:2661209168  NOTICE: Thread DVDPlayer start, auto delete: false
13:26:09 47825.785156 T:2661209168  NOTICE: Creating InputStream
13:26:09 47825.914062 T:2661209168  NOTICE: DVDPlayer: playing a file with menu's
13:26:09 47825.917969 T:2661209168  NOTICE: Creating Demuxer
13:26:09 47826.339844 T:2661209168 WARNING: could not find codec parameters for /storage/freenas/media/Video-Test/DVDTS/Hitchikers Guide - Extra/VIDEO_TS/VIDEO_TS.IFO
13:26:09 47826.339844 T:2661209168  NOTICE: COMXPlayer::CreatePlayers OMXPlayer unsuitable due to dvd menus
13:26:09 47826.343750 T:2661209168  NOTICE: COMXAudio::Deinitialize start
13:26:09 47826.343750 T:2661209168  NOTICE: COMXAudio::Deinitialize end
13:26:09 47826.343750 T:2661209168  NOTICE: COMXAudio::Deinitialize start
13:26:09 47826.343750 T:2661209168  NOTICE: COMXAudio::Deinitialize end
13:26:09 47826.343750 T:2661209168  NOTICE: ActiveAE::Resume
13:26:09 47826.343750 T:3041014864  NOTICE: CActiveAE::StateMachine - AE_TOP_CONFIGURED_SUSPEND/CActiveAEControlProtocol::INIT
...

One obvious difference is that with my IFO, the following line is output which is presumably when it switches to dvdplayer:
Code:
13:26:09 47826.339844 T:2661209168  NOTICE: COMXPlayer::CreatePlayers OMXPlayer unsuitable due to dvd menus

Check you have all the video acceleration options enabled, and codec licences (MPEG2 etc. in config.txt) configured.

If that isn't the problem, can you upload a full debug log of your IFO not playing with the latest build, and also a debug log of when it *does* play with build #1018, for comparison purposes.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average


Messages In This Thread
Re: RE: - by Mafarricos - 2014-06-04, 20:21
Live tv issues again - by pootler - 2014-06-04, 23:29
RE: OpenELEC Testbuilds for RaspberryPi Part 3, - by removed151214 - 2014-08-04, 23:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-19, 00:11
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-21, 20:42
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:20
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:34
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:44
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 01:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 23:24
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-25, 01:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:26
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-05, 01:07
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 03:48
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 04:06
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 11:29
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by Milhouse - 2014-10-27, 15:40


Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888