Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
(2014-10-31, 13:27)popcornmix Wrote:
(2014-10-30, 23:01)Forage Wrote:
  1. Having the settings on 300/0/0 (default) will perform an action only ones when keeping the button pressed.
  2. Changing the release setting to at least 50 fixes this.
  3. Setting release to at least 250 is then required to prevent double actions from occurring
  4. Changing the CEC settings also only works ones. After the first go you get the updated notification after pressing OK, this doesn't happen on a second attempt. A reboot is required to apply a subsequent change. The settings of the first change will be used until that time.
  5. Setting release to 400 or higher makes it stop repeating again when keeping the button pressed

I guess your TV isn't sending button up events. Strange as my Panasonic does. Can you enable debugging and "CEC" component specific debugging and press a few keys and check for lines like:
Code:
10:21:13 30651.439453 T:2947544144   DEBUG: CecLogMessage - >> TV (0) -> Playback 1 (4): vendor remote button up (8B)

If you don't get any "button up" events then a non-zero release is required. It may be possible to determine this at runtime.
I've noticed the "CEC settings changed" popup only occurs once. Don't think it's related to this change but probably an existing bug. I'll have a dig around.
I'll try with a release of 400 to see if I see the same effect.

Here's a snippet of the log after pressing the up and down button a couple of times with the release settings set to 0 again: http://pastebin.com/t0YuGQ3i

It does fire a button up event as far as I can tell.

Here's a log keeping the up button pressed for about 5 seconds: http://pastebin.com/dnmqbfdR
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average


Messages In This Thread
Re: RE: - by Mafarricos - 2014-06-04, 20:21
Live tv issues again - by pootler - 2014-06-04, 23:29
RE: OpenELEC Testbuilds for RaspberryPi Part 3, - by removed151214 - 2014-08-04, 23:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-19, 00:11
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-21, 20:42
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:20
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:34
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:44
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 01:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 23:24
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-25, 01:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:26
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-05, 01:07
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 03:48
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 04:06
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 11:29
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by Forage - 2014-10-31, 19:44


Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888