•   
  • 1
  • 140
  • 141
  • 142(current)
  • 143
  • 144
  • 156
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
Since Version OpenELEC-RPi.arm-Milhouse-20141123220755-r19686-g16a5a30 i have a problem playing live-tv with vnsi. When i start the stream i get green noise as tvpicture and after 2secs the Pi hangs and needs a reboot. With OpenELEC-RPi.arm-Milhouse-20141123220755-r19686-g16a5a30 which is the last working release for me i get a black picture when first tuning a live-tv-channel with VNSI. When i then change the channel everything is fine. Only starting the first channel has this problems.
So #1124 is the build with green screen/hang?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Starting from OpenELEC-RPi.arm-Milhouse-20141124223600-r19690-gec9fd72.tar all further builds have the same green noisy picture and hang.
(2014-11-28, 09:17)PeaceMkr Wrote: Since Version OpenELEC-RPi.arm-Milhouse-20141123220755-r19686-g16a5a30 i have a problem playing live-tv with vnsi. When i start the stream i get green noise as tvpicture and after 2secs the Pi hangs and needs a reboot. With OpenELEC-RPi.arm-Milhouse-20141123220755-r19686-g16a5a30 which is the last working release for me i get a black picture when first tuning a live-tv-channel with VNSI. When i then change the channel everything is fine. Only starting the first channel has this problems.

Seen the same on some 1080i hdtv channels with tvheadend
Just updated to Openelec Beta5 and I would like to thank the development team on the noticeable speed bump in this release from Beta4.
Its very noticable when scrolling through the EPG and more responsive in the GUI in general.

Keep up the good work, the Helix final must be close.

(2014-11-28, 03:10)Milhouse Wrote: @popcornmix: I've lost GUI sounds with build #1127 - I'm seeing lots of OMX/audio related ERRORs in the log: http://sprunge.us/FhWG
...
#1126 does not have this problem. Any suggestion which PR/commit to revert?

Yes, I can reproduce. (Not sure why this didn't show up when originally testing...)
Anyway I have a fix and will push a firmware fix later today.
(2014-11-28, 09:49)PeaceMkr Wrote: Starting from OpenELEC-RPi.arm-Milhouse-20141124223600-r19690-gec9fd72.tar all further builds have the same green noisy picture and hang.

This seems like the most likely culprit introduced in this build.
I'll revert it for next build and we'll see if that fixes it.

Does the green/hang only affect live TV or do you see the same with recordings? If you see the issues with recordings then a small sample file would be useful.
(2014-11-28, 03:10)Milhouse Wrote: @popcornmix: I've lost GUI sounds with build #1127 - I'm seeing lots of OMX/audio related ERRORs in the log: http://sprunge.us/FhWG
Talking about GUI sounds:
Ever since the introduction of the sounds it always takes 2 or 3 clicks for the navigation sounds to be played again when coming back from the screen darkening.

Steps to reproduce:
  1. Wait for the screen to darken (1 minute?)
  2. Press a remote key to activate Kodi again: no sound played
  3. Press a remote key to move up/down/left/right: no sound played
  4. Press a remote key to move up/down/left/right: no sound played
  5. Press a remote key to move up/down/left/right: sound played
Are you guys experiencing the same?
@popcornmix, I`ve had the hangs on recordings as well as live tv
After the screen "darkens" (you mean the "Dim" screensaver has activated?), for me it takes one remote control input to disable the screensaver (this generates no sound), then I hear GUI/navigation clicks for all subsequent remote control inputs.

I've also tested this when resuming from suspend, and again I hear all the clicks (apart from the initial remote control input that "wakes" the sleeping Pi).

Presumably you have audio over HDMI? Can you provide a debug log?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-11-28, 17:44)Forage Wrote: Ever since the introduction of the sounds it always takes 2 or 3 clicks for the navigation sounds to be played again when coming back from the screen darkening.

That is expected behaviour. When audioengine shuts down the gui sound samples are dropped.
When audioengine starts up, it loads the samples and resamples them as a low priority process.
If the sample is not available it is skipped (so as to not to hold up the GUI).

Set the "keep alive" to a large value so audioengine doesn't shut down if this bothers you.
(2014-11-28, 17:57)stuCONNERS Wrote: @popcornmix, I`ve had the hangs on recordings as well as live tv

Can you provide a sample?
(2014-11-28, 02:42)Milhouse Wrote: Did you try adding "textmode" to the end of your line in /flash/cmdline.txt, and look at dmesg or try to determine why ssh isn't working? It should confirm if your partition is hosed before you blow it away.

Did that. Didn't have any error/warning messages in dmesg, but during boot process there were scrolling some "orange" messages. Managed to read from the screen "Failed to start avahi defaults". Same for cron and samba. Than I ran "systemctl status avahi-defaults.service" and this gave me the answer - error was that during boot system was unable to copy default *.conf files to /storage/.cache. I've checked - my ".cache" was a file insted of folder?!? Definitelly corruption of a file-system. Removed .cache, rebooted and everything works like a charm...

Thanks.
(2014-11-28, 18:03)Milhouse Wrote: After the screen "darkens" (you mean the "Dim" screensaver has activated?), for me it takes one remote control input to disable the screensaver (this generates no sound), then I hear GUI/navigation clicks for all subsequent remote control inputs.
I mean the dim screensaver yes.
(2014-11-28, 18:03)Milhouse Wrote: Presumably you have audio over HDMI? Can you provide a debug log?
Correct again. Based on popcornmix's reply I don't think a log will be needed any more.
(2014-11-28, 18:12)popcornmix Wrote:
(2014-11-28, 17:44)Forage Wrote: Ever since the introduction of the sounds it always takes 2 or 3 clicks for the navigation sounds to be played again when coming back from the screen darkening.

That is expected behaviour. When audioengine shuts down the gui sound samples are dropped.
When audioengine starts up, it loads the samples and resamples them as a low priority process.
If the sample is not available it is skipped (so as to not to hold up the GUI).

Set the "keep alive" to a large value so audioengine doesn't shut down if this bothers you.
Thanks for the info.
It's not bothering me that much. It's just a slight imperfection that doesn't stand in the way of normal functioning. I just though I should mention it because it might have been something that has been overlooked.
New OpenELEC Helix build: #1128
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 3.17.4 #1 PREEMPT Fri Nov 28 21:04:36 GMT 2014 armv6l GNU/Linux

# vcgencmd version
Nov 28 2014 18:00:41
Copyright (c) 2012 Broadcom
version 99709519ca7b803472349b3167c20d5212388d90 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20141128210325-r19703-gf0b95eb [Build #1128]

Based on tip of OpenELEC master (f0b95ebd, changelog) and tip of XBMC master (44c2e69a, changelog) with the following modifications:
  • Includes newclock4 patches
  • Excludes the OpenELEC fernetmenta patches due to conflicts with newclock4
  • Excludes the OpenELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-3.17.y
  • Excludes the OpenELEC xbmc-001-newclock4 patch in favour of sourcing these and possibly more recent patches directly from newclock4 branch
  • Default setting for "Show RSS Feed" changed to disabled (new installs only) [patch details]
  • Disabled "Total Duration" in Confluence (see build #0221 for details)
  • Adapted service.openelec.settings to take advantage of PR:5217 [patch details]
  • Includes latest libnfs master (080d2311)
  • Includes latest libcec master (9f000e43)
  • Includes latest xbmc-pvr-addons master (14d98287)
  • Includes latest xbmc-addon-xvdr master (328fa653)
  • Includes CONFIG_COREDUMP=y to allow creation of coredumps (see here)
  • Includes additional ffmpeg codecs/muxers enabled for testing/benchmarking purposes (see patch)
  • Includes commits from libcec-2.2.0 (popcornmix)
  • Includes PR:5573: webserver: improved caching control (see discussion)
  • Includes PR:5747: [database] - add setting for hiding watched movies/episodes in recently added lists
  • Includes PR:5752: [jsonrpc] Allow retrieving empty TV shows via VideoLibrary.GetTVShows.
Build Highlights:
  1. New firmware, reverting last change.
  2. Revert newclock4 commit that may be causing green screen/hang with LiveTV
Build Details:
  1. Firmware (Nov 28):
    • firmware: Revert upstream patch that breaks audio_render when used without clock. See: link
    • firmware: venc: Release images when error after open occurs which prevents a hang. See: link. See: link. See: link
  2. XBMC:
    • shorten the wiki migration url (PR:5834, 1 commit, 1 file changed)
    • [depends] - add boblight to depends but don't install it (used for compi... (PR:5835, 1 commit, 3 files changed)
    • [rebrand] web interface rename XBMC - Kodi (PR:5839, 1 commit, 1 file changed)
    • [pvr] always use last played group as current group on startup (PR:5824, 2 commits, 1 file changed)
  3. newclock4:
    • New commits in this build:
      • [mmalcodec] Skip some setup that is not required when closing (79a94ace)
      • [languageinvoker] Reduce priority of python threads (906bfad1)
      • [mmalcodec] Try reducing number of video frames (cfe254aa)
      • Revert "[MMALCoded] Call port settings changed from callback to avoid thread unsafe code" (95d5dda0)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 140
  • 141
  • 142(current)
  • 143
  • 144
  • 156
  •   
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888