Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
@Solo0815:

Just looking at the "systemctl stop kodi" shutdown process on my system (latest build):

Code:
17:05:22 410.215088 T:3040694272    INFO: Received SIGTERM...
17:05:22 410.215363 T:3040694272   DEBUG: CAnnouncementManager - Announcement: OnQuit from xbmc
17:05:22 410.215668 T:3040694272   DEBUG: GOT ANNOUNCEMENT, type: 8, from xbmc, message OnQuit
17:05:22 410.216095 T:3040694272  NOTICE: Storing total System Uptime
17:05:22 410.216736 T:3040694272  NOTICE: Saving settings
17:05:22 410.225281 T:3040678976    INFO: Received SIGTERM...
17:05:22 410.225586 T:3040678976   DEBUG: CAnnouncementManager - Announcement: OnQuit from xbmc
17:05:22 410.225891 T:3040678976   DEBUG: GOT ANNOUNCEMENT, type: 8, from xbmc, message OnQuit
17:05:22 410.226379 T:3040678976  NOTICE: Storing total System Uptime
17:05:22 410.227173 T:3040678976  NOTICE: Saving settings
and the same from your system:
Code:
13:38:09 1768.387329 T:3041046528    INFO: Received SIGTERM...
13:38:09 1768.387573 T:3041046528   DEBUG: CAnnouncementManager - Announcement: OnQuit from xbmc
13:38:09 1768.422729 T:3041031232    INFO: Received SIGTERM...
13:38:09 1768.423218 T:3041031232   DEBUG: CAnnouncementManager - Announcement: OnQuit from xbmc

Two things that stand out:

1) Why are two separate threads both saving settings on shutdown?
2) Your system doesn't seem to handle the OnQuit announcement(s), so chances are the threads are simply hanging at that point

There is also a regression somewhere which results in settings being "lost" and reverting to defaults (guisettings.xml being trashed?) - I wonder if that is related somehow. Can't spend any more time on this today but if you can send me the archive maybe I can reproduce and investigate further tomorrow.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average


Messages In This Thread
Re: RE: - by Mafarricos - 2014-06-04, 20:21
Live tv issues again - by pootler - 2014-06-04, 23:29
RE: OpenELEC Testbuilds for RaspberryPi Part 3, - by removed151214 - 2014-08-04, 23:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-19, 00:11
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-21, 20:42
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:20
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:34
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:44
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 01:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 23:24
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-25, 01:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:26
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-05, 01:07
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 03:48
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 04:06
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 11:29
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by Milhouse - 2014-12-06, 19:14


Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888