Release CNET Podcasts Video-Addon
#1
Hello folks,

This addon stopped working recently and unfortunately i haven't been able to reach the author of the addon (divingmule). Therefore i made some alterations to the addon to get it up and running again. Also thanks to gtoons for the feedburner tip.

Image

It's available as a video addon in the official kodi repo. So you can install it as a video addon: HOW-TO:Install_add-ons (wiki)

If you got problems with the addon, just reply here with a link to a kodi log file (here are the instructions to make a logfile with kodi: Log_file/Easy (wiki) ).

Enjoy.

v1.1.6 (2018-01-20)
- addon now works in kode python 2 and should also work in python 3 (!!) once all dependencies work in python 3.
Kudo's to the python future package for making this possible. Kudo's to RomanVM for the help.
- removed caching
- adding a setting to only view all video category

v1.1.5 (2017-07-16)
rolling back changed foldername for strings because that doesn't work for gotham

v1.1.4 (2017-07-12)
reformatted changelog
removed strings.xml
added listitem.setInfo video for Kodi 18 and up
added sorting
added context item episode info
removed 'latest videos' category as that already exists as 'all' category
refactored listing the videos
changed foldername for strings
using requests

v1.1.3 (2017-03-03)
using po-files
fixed url in addon.xml as per request

v1.1.2 (2016-02-20)
added some utf-8 stuff
updated to latest requirements for a Kodi-addon
added fanart
added fanart-blurred

v1.1.1 (2014-04-20)
fix to get the addon working again after changes in the website.
I couldn't get in contact with divingmule, therefore i (Skipmode A1) made a new of the addon based on divingmule's sourcecode.
Thanks to gtoons for the feedburner tip.

v1.1.0
update for frodo/gotham

v1.0.8
fix for changes in Frodo

v1.0.7
updated podcasts list

v1.0.6
fix bug in scraper

v1.0.5
updated show list, thanks pkscuot

v1.0.2
fix for feed changes
new playback setting

v1.0.1
added the crave podcast

v1.0.0
new for eden

v0.0.4
added addon settings for video quality instead of categories

v0.0.3
updated icon.png

v0.0.2
added video descriptions
added categories for SD and HD

v0.0.1
initial
Reply
#2
Is there a way to get videos to play in 720p? All the videos play in the lower 360 resolution.
Reply
#3
Not that i know off.
Reply
#4
Ok cool. Thanks. The main site doesn't seem to play in HD, must have been one of the changes.
Reply
#5
Video works but no audio. It looks like CNET audio is in AAC. Other video addons with AAC audio work (such as Twit).
OS: OSX Mavericks 10.9.2
Audio Out: SPDIF Coax through USB (connects to Onkyo AVR)
CNET works fine with HDMI video and audio.
XBMC ver: 10.3b4

Also tried with audio passthrough and no passthrough. Same outcome- No audio
Reply
#6
Thx for the update but have also sound problems here.
Reply
#7
Not much i can do about that, the addon plays the video with the xmbc player.

The sound works for me with 12.x and even the 13.betax xbmc versions. You might try those...
Reply
#8
Sound is working but it's really poor quality
Reply
#9
(2014-04-27, 08:37)Skipmode A1 Wrote: Not much i can do about that, the addon plays the video with the xmbc player.

The sound works for me with 12.x and even the 13.betax xbmc versions. You might try those...

It, then, looks like a CNET streaming issue as all other add-ons using AAC audio codec have no issue with audio playback over USB to SP/DIF.

BTW, thanks for the effort.
Reply
#10
All the sound and low video quality issues appear to stem from a change of platforms by engineers at CNET, according to tweets from senior editor Brian Tong...

http://muckrack.com/brian-tong/statuses/...0683877376

http://muckrack.com/brian-tong/statuses/...5055875072
Reply
#11
(2014-05-04, 06:01)gtoons Wrote: All the sound and low video quality issues appear to steam from a change of platforms by engineers at CNET, according to tweets from senior editor Brian Tong...

Thanks for the update. Now it makes sense.
Reply
#12
I checked the Videos out today and they look great in high definition, finally the quality is better
Reply
#13
(2014-04-25, 17:40)macuniverse Wrote: Video works but no audio. It looks like CNET audio is in AAC. Other video addons with AAC audio work (such as Twit).
OS: OSX Mavericks 10.9.2
Audio Out: SPDIF Coax through USB (connects to Onkyo AVR)
CNET works fine with HDMI video and audio.
XBMC ver: 13.0

Also tried with audio passthrough and no passthrough. Same outcome- No audio

I, now, confirm that audio of CNET video addon works fine under above-mentioned Mac mini setup.

Thanks CNET people!
Reply
#14
I'm seeing issues on the apple tv 2 on certain podcasts. Cnet Update seems to catch up and play perfectly, however the Apple Byte never catches up and the video lags further and further behind the audio. I'm on Gotham with plugin 1.1.1 and IOS version 5.3 untethered

Anything I can try to get all podcasts working again?
Reply
#15
Works fine here with windows and xbmc 13.1 :/.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
CNET Podcasts Video-Addon00