Xbmc cannot connect
#1
I have two xbmc machines:
main htpc box and a boxee running xbmc.

mediaportal live tv works on the source htpc machine no issues.

i setup enabled the media portal pvr addon on the boxee and pointed it to the source machine.
when i go to live TV i can see all the channels and the EPG data. when i try to view a channel it buffers and then says no video or audio detected.

im running media portal 1.7 with mysql 5.6, TVServerXBMC plugin v1.6.0.125, schedulesdirect EPG 1.3.0.1, xbmc 13 beta 4 | on the source machine
windows firewall is disabled.

the boxee is running xbmc 13 beta 4 with what ever media portal pvr addon is included by default. xbmc is install to internal boxee memory.

any suggestions on where to look for issues? i cannot understand why it would be able to read the guide but not stream the tv channel

Oh. im using a HDHomeRun ASTC dual digital network tuner in case you need that info as well.

really considering ditching the boxee and moving to a different xbmc client... need to find a cheap replacement....
Reply
#2
just in case someone is having the same issue i am i was able to get live to work on both the source htpc pc and the xbmc machine in my bedroom.

turns out using UNC paths for the timeshift buffer location was causing issues. here are the errors in my log file of xbmc:

DEBUG: AddOnLog: MediaPortal PVR Client: Multiseat mode; need to translate 'E:\_MediaPortal\Timeshift\live3-0.ts.tsbuffer' to UNC filename.
NOTICE: AddOnLog: MediaPortal PVR Client: Translate path E:\_MediaPortal\Timeshift\live3-0.ts.tsbuffer -> smb://xbmc:[email protected]/_MediaPortal/Timeshift/live3-0.ts.tsbuffer
INFO: AddOnLog: MediaPortal PVR Client: FileReader::OpenFile() smb://xbmc:[email protected]/_MediaPortal/Timeshift/live3-0.ts.tsbuffer.
DEBUG: CSmbFile::Open - opened _MediaPortal/Timeshift/live3-0.ts.tsbuffer, fd=-1
INFO: FileSmb->Open: Unable to open file : 'smb://USERNAMETongue[email protected]/_MediaPortal/Timeshift/live3-0.ts.tsbuffer' unix_err:'d' error : 'Permission denied'

the username and password are correct so im not sure why it said this. i read else where there were issues with multiseat + UNC Paths. maybe someone can weigh in here and confirm that is the issue.

either way...

I was able to get live TV to work by switching the streaming method from TSReader to ffmpeg in the xbmc mediaportal pvr addon.
the channel changing is super slow which is what every says when using the method. slow channel changing is better than no TV.

the main htpc is still using TSReader streaming method without issue. it is only on the xbmc client that connects back to the main htpc i had to switch to ffmpeg.

If there is a solution to this please let me know.
Reply



Logout Mark Read Team Forum Stats Members Help
Xbmc cannot connect0
This forum uses Lukasz Tkacz MyBB addons.