•   
  • 1
  • 525
  • 526
  • 527
  • 528(current)
  • 529
  •   
Linux -  ChromeBox Kodi E-Z Setup Script (LibreELEC/Linux+Kodi) [2017/02/21]
(2018-12-29, 18:08)giant25 Wrote: Thanks. I went to the latest Beta as well and the black screen hasn't happened yet. I am running a completely fresh build with no add-ons (except pvr.wmc). However, I have other issues now:
-commercial skip isn't working with PVR.WMC
-sometimes all GUI text disappears completely and I have to reboot it change resolution to resolve.
-PVR playback would buffer regularly (kernel bug that I applied workaround to)

Anyone else see this with latest Beta on a Chromebox? 
  
it's likely an addon issue, so check the PVR subforum for WMC, or the LibreELEC forums
Questions about Kodi on a ChromeBox/Chromebook?  See:
Chromebox (wiki)
http://forum.kodi.tv/showthread.php?tid=194362
https://mrchromebox.tech
Reply
(2018-12-29, 19:39)Matt Devo Wrote:
(2018-12-29, 18:08)giant25 Wrote: Thanks. I went to the latest Beta as well and the black screen hasn't happened yet. I am running a completely fresh build with no add-ons (except pvr.wmc). However, I have other issues now:
-commercial skip isn't working with PVR.WMC
-sometimes all GUI text disappears completely and I have to reboot it change resolution to resolve.
-PVR playback would buffer regularly (kernel bug that I applied workaround to)

Anyone else see this with latest Beta on a Chromebox? 
  
it's likely an addon issue, so check the PVR subforum for WMC, or the LibreELEC forums
Agreed for pvr issues, but the text disappearing is the entire GUI regardless of skin. And it seems to be triggered when info comes up when playing a movie (pausing, etc). I'll go ask around LE forums, but it could be a GPU compatibility issue...
Reply
(2018-12-29, 21:14)giant25 Wrote:
(2018-12-29, 19:39)Matt Devo Wrote:
(2018-12-29, 18:08)giant25 Wrote: Thanks. I went to the latest Beta as well and the black screen hasn't happened yet. I am running a completely fresh build with no add-ons (except pvr.wmc). However, I have other issues now:
-commercial skip isn't working with PVR.WMC
-sometimes all GUI text disappears completely and I have to reboot it change resolution to resolve.
-PVR playback would buffer regularly (kernel bug that I applied workaround to)

Anyone else see this with latest Beta on a Chromebox? 
  
it's likely an addon issue, so check the PVR subforum for WMC, or the LibreELEC forums
Agreed for pvr issues, but the text disappearing is the entire GUI regardless of skin. And it seems to be triggered when info comes up when playing a movie (pausing, etc). I'll go ask around LE forums, but it could be a GPU compatibility issue...
what skin? not seeing any issues here with confluence or Eminence 2.0
Questions about Kodi on a ChromeBox/Chromebook?  See:
Chromebox (wiki)
http://forum.kodi.tv/showthread.php?tid=194362
https://mrchromebox.tech
Reply
(2018-12-29, 22:15)Matt Devo Wrote:
(2018-12-29, 21:14)giant25 Wrote:
(2018-12-29, 19:39)Matt Devo Wrote:   
it's likely an addon issue, so check the PVR subforum for WMC, or the LibreELEC forums
Agreed for pvr issues, but the text disappearing is the entire GUI regardless of skin. And it seems to be triggered when info comes up when playing a movie (pausing, etc). I'll go ask around LE forums, but it could be a GPU compatibility issue...
what skin? not seeing any issues here with confluence or Eminence 2.0
Estuary and Confluence on v8.95.1 Beta, Panther. I can try a rebuild or Milhouse if you think it'll help. I've found other "Kodi No Text" instances on the web but haven't gotten to the bottom of it yet.
Reply
Hi all, 

I have a question that may not be related to kodi nor chromebox. In which case, I am sorry.
The TV I have right now has been working for the past year with my chromebox cn60. The tv has CEC/ARC through HDMI with my soundbar. So for the past year my chromebox has been connected to an hdmi port on the tv and the sound is sent through the hdmi arc port. Same thing for my other devices. 

All of a sudden it stopped working. I just found out that when I unplug the hdmi cable of the chromebox, it start working again. Changing hdmi port or cable changes nothing.
I have a workaround. But I am curious to know if anyone else experienced something like this?
Reply
I have an HP Chromebox which I had used the E-Z Setup Script on for Kodi 17 which has been working great.  I decided to try the LibreELEC 8.95.2 beta a few days ago running Kodi 18 RC4 and it seemed like perhaps there are network issues in the kernel?  I couldn't play anything from my NAS via SMB without major buffering, nor could I use streams direct from my Emby server without buffering.  Even using the Kodi app from my phone to act as a remote control seemed almost jittery when using the arrows.  Has anyone else tried this and perhaps had a similar experience?
Reply
(2019-01-11, 05:01)vult2000 Wrote: I have an HP Chromebox which I had used the E-Z Setup Script on for Kodi 17 which has been working great.  I decided to try the LibreELEC 8.95.2 beta a few days ago running Kodi 18 RC4 and it seemed like perhaps there are network issues in the kernel?  I couldn't play anything from my NAS via SMB without major buffering, nor could I use streams direct from my Emby server without buffering.  Even using the Kodi app from my phone to act as a remote control seemed almost jittery when using the arrows.  Has anyone else tried this and perhaps had a similar experience?
 fix here: https://forum.kodi.tv/showthread.php?tid...pid2798901
Questions about Kodi on a ChromeBox/Chromebook?  See:
Chromebox (wiki)
http://forum.kodi.tv/showthread.php?tid=194362
https://mrchromebox.tech
Reply
(2019-01-11, 05:01)vult2000 Wrote: I have an HP Chromebox which I had used the E-Z Setup Script on for Kodi 17 which has been working great.  I decided to try the LibreELEC 8.95.2 beta a few days ago running Kodi 18 RC4 and it seemed like perhaps there are network issues in the kernel?  I couldn't play anything from my NAS via SMB without major buffering, nor could I use streams direct from my Emby server without buffering.  Even using the Kodi app from my phone to act as a remote control seemed almost jittery when using the arrows.  Has anyone else tried this and perhaps had a similar experience?
Yup, kernel bug. You can read earlier posts in this thread from late Nov/early Dec for details. I was able to ssh into my Chromebox, mount /flash as RW, append the line "pci=nomsi" to the end of syslinux.cfg, save, mount /flash back to RO, then reboot. Or boot into ChromeOS per instructions from earlier posts if you're dual boot. Alternately, go back to an earlier build until it's fixed. Good luck.

Edit: Matt beat me to it!
Reply
If I purchase a new CHROMEBOX 3-N017U  and manage to get it set up using the e-z setup script, can I use a saved backup of LibreElec from our current Chromebox M004U  to restore  addons and their settings such as tvheadend ? 

I am only interested in using Libreelec, no dual boot.  We are using the current release of LibreElec, not an alpha or beta.

We do have a Wetek Play2 and a Mecool M8S Pro (?)  both running Libreelec on sd cards but as we prefer to use our Chromebox probably 99.9% of the time,  a new Chromebox that is a little more powerful at $230 sounds really interesting.

thanks in advance

joe
Reply
(2019-01-12, 19:48)Pajoe Wrote: If I purchase a new CHROMEBOX 3-N017U  and manage to get it set up using the e-z setup script, can I use a saved backup of LibreElec from our current Chromebox M004U  to restore  addons and their settings such as tvheadend ? 

I am only interested in using Libreelec, no dual boot.  We are using the current release of LibreElec, not an alpha or beta.
 
yes, simply set up the new Chromebox3 as a standalone LE, backup on old device, restore on the other. I'd highly recommend updating the CB3 to the latest LE beta/Kodi RC (after restoring the backup), since the older kernel in 8.2.5 stable is simply suboptimal for the Kabylake SoC. Also, be aware that HD Audio passthru likely won't work with a USB-C/HDMI 2.0 adapter; you'll need to use the native HDMI 1.4b output for that.

FWIW, I've been using a CB3 as my main Kodi box since release last spring.
Questions about Kodi on a ChromeBox/Chromebook?  See:
Chromebox (wiki)
http://forum.kodi.tv/showthread.php?tid=194362
https://mrchromebox.tech
Reply
Thanks Matt,


I continue to believe the ChromeBox set up with your E-Z Setup, running LibreElec is the best Kodi setup for us, and plan to order a new CHROMEBOX 3-N017U  when the store reopens after the Shabbos holiday. Likewise, I will do as you recommend and upgrade to the latest LE beta once I get the LibreElec  backup from our current ChromeBox installed.

Thanks again,

joe
Reply
Hi Matt,

Been a long time user of your work and this weekend (After a baby who is now 20 months old!) decided to update LibreELEC but came across the Network SMB performance issue which for me started in "#1023, 23-Oct-2018: Generic -- Release post (New 4.19.0 kernel; Kodi 18 Beta 5 starts; pvr.iptvsimple: RapidXML new package)" (Milhouse build).

I have followed your advice here but it didn't seem to help, moving to the (5GHz) WiFi connection as advised does fix things but this isn't ideal as I may need to move this box further away where WiFi isn't as strong in the near future.

Is there a log I can check to confirm the fix I entered is working as desired or does it not always help?

My hardware is the ASUS Chromebox M061U Desktop (Core i3 4010U 1.7GHz, 4GB RAM, 16GB SSD) and I am also going to check if you have updated anything in the firmware that might also help.
Reply
(2019-01-13, 11:26)D-an-W Wrote: Hi Matt,

Been a long time user of your work and this weekend (After a baby who is now 20 months old!) decided to update LibreELEC but came across the Network SMB performance issue which for me started in "#1023, 23-Oct-2018: Generic -- Release post (New 4.19.0 kernel; Kodi 18 Beta 5 starts; pvr.iptvsimple: RapidXML new package)" (Milhouse build).

I have followed your advice here but it didn't seem to help, moving to the (5GHz) WiFi connection as advised does fix things but this isn't ideal as I may need to move this box further away where WiFi isn't as strong in the near future.

Is there a log I can check to confirm the fix I entered is working as desired or does it not always help?

My hardware is the ASUS Chromebox M061U Desktop (Core i3 4010U 1.7GHz, 4GB RAM, 16GB SSD) and I am also going to check if you have updated anything in the firmware that might also help.
 would need to check the kernel boot parameters to verify that the parameter was correctly added. Easiest way is to check the kernel boot log (dmesg) after a fresh boot.  Throw it up on pastebin (eg).  The latest LE might even have a log-posting function in the LE addon, so that would be easiest
Questions about Kodi on a ChromeBox/Chromebook?  See:
Chromebox (wiki)
http://forum.kodi.tv/showthread.php?tid=194362
https://mrchromebox.tech
Reply
It seems I had two copies of syslinux.cfg, one in /flash/ and the other in /flash/EFI/BOOT/

As described here, I edited the second one and it seems to fix the network issue with the kernel.


EDIT: Thanks Matt, you made the procedure easy as always, just updated to "coreboot_tiano-panther-mrchromebox_20190104.rom" is there a changelog for this release or is it the same as the latest one mentioned on your website?
Reply
(2019-01-13, 16:48)D-an-W Wrote: It seems I had two copies of syslinux.cfg, one in /flash/ and the other in /flash/EFI/BOOT/

As described here, I edited the second one and it seems to fix the network issue with the kernel.


EDIT: Thanks Matt, you made the procedure easy as always, just updated to "coreboot_tiano-panther-mrchromebox_20190104.rom" is there a changelog for this release or is it the same as the latest one mentioned on your website?
 2019.01.04 is same as 2018.12.30 release, just a battery reporting fix for some devices (so not applicable to chromeboxes).
Questions about Kodi on a ChromeBox/Chromebook?  See:
Chromebox (wiki)
http://forum.kodi.tv/showthread.php?tid=194362
https://mrchromebox.tech
Reply
  •   
  • 1
  • 525
  • 526
  • 527
  • 528(current)
  • 529
  •   
 
Thread Rating:
  • 37 Vote(s) - 4.57 Average



Logout Mark Read Team Forum Stats Members Help
ChromeBox Kodi E-Z Setup Script (LibreELEC/Linux+Kodi) [2017/02/21]4.5737