Linux -  error: diskfilter writes are not supported
#1
Hi all

Just done a fresh install of xbmcbuntu v13.0 on a new SSD drive and get the following message just before it boots:

error: diskfilter writes are not supported
Press any key to continue

System will boot normally after i press the key or wait 5 seconds. Can anyone adivse what I can do to get rid of this message?

On a sidenote, are there any options I can implement to make my system boot a little quicker? It's not booting from the SSD as fast as I ws hoping although ti could be related to the above issue...
Reply
#2
https://bugs.launchpad.net/ubuntu/+sourc...ug/1274320
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
i have added the below code from #34 on that page to my 00_header file and issues the command update-grub. Still getting the error on boot. Have also changing between quick_boot="1" and "0" in the 10_linux file to no avail.

if [ "$quick_boot" = 1 ]; then
cat <<EOF
function recordfail {
set recordfail=1
EOF
GRUBMDDEVICE="$(grub-probe --target=disk "${grubdir}")"
GRUBLVMDEVICE="$(grub-probe --target=disk "${grubdir}")"
if echo "$GRUBMDDEVICE" | grep "/dev/md" > /dev/null; then
cat <<EOF
# GRUB lacks write support for $GRUBMDDEVICE, so recordfail support is disabled.
EOF
elif echo "$GRUBLVMDEVICE" | grep "/dev/mapper" > /dev/null; then
cat <<EOF
# GRUB lacks write support for $GRUBLVMDEVICE, so recordfail support is disabled.
EOF
else
FS="$(grub-probe --target=fs "${grubdir}")"
case "$FS" in
btrfs | cpiofs | newc | odc | romfs | squash4 | tarfs | zfs)
cat <<EOF
# GRUB lacks write support for $FS, so recordfail support is disabled.
EOF
;;
*)
cat <<EOF
if [ -n "\${have_grubenv}" ]; then if [ -z "\${boot_once}" ]; then save_env recordfail; fi; fi
EOF
esac
fi
cat <<EOF
}
Reply
#4
Have also confirmed my GRUB_SAVEDEFAULT=false as per this topic: https://forum.manjaro.org/index.php?topic=7425.0

Can anyone assist? Is this something to do with the way my SSD has been partitioned?
Reply
#5
you should post this to the bug report instead of here. We're not the ubuntu forums.
Reply
#6
Did anyone solve the problem?

it´s really annoying :|
Reply
#7
I have this problem too. This is installing KodiBuntu on a clean single drive machine. NONE of the solutions proffered by ANY ubuntu, debian or fedora site have even tickled it. so - yes - here we are a year later and bumpkis.

I have hammered on this thing and gotten nowhere. If anyone has any ideas - please. jump on in.
Reply
#8
Did you see that there seems to be a patch around if you follow fritschs' link?
Reply
#9
LOL, yes I've tried that patch. I have tried multiple different "fixes":
1. patched 00_header, 'quick_boot="0" in 10_linux
2. # in front of the "if [ -n "\${have_grubenv}" ] ...".
3. Adding GRUB_SAVEDEFAULT=false to /etc/default/grub
4. Changed recordfail function
5. Creating a /etc/grub.d/01_nowriting script (and making it executable)
6. Applied Ubuntu patch

I HAVE ran sudo upgrade-grub everytime and rebooted with every change. It almost appears as if the version of 14.04 that is bundled with Kodi, does not use GRUB
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
error: diskfilter writes are not supported00