XBMCBuntu 11.10 - 12.04 Updating to 12.3
#1
OK so, I'll make this quick, I tried finding more info on this but am having a hard time finding much info.

Just a heads up, I am a little green when it comes to linux... ok a lot. Just trying to upgrade from 12.2 to 12.3, or what ever is the current stable release on the default ppa. When ever I try I notive it just installed 12.2, also when checking the latest version in terminal it says the latest release is 12.2. As far as I have been able to piece together, it has something todo with the fact that my underlying distro version is 11.10, and it should be 12.04? If that is correct, that would be the version that was initially installed with Frodo, so I am wondering how I would go about updating the distro, preferably with terminal and even more preferable... without spending the next week trying to fix everything haha.

Thank you for your help
Kirt
Reply
#2
sudo apt-get install update-manager-core
sudo apt-get update && sudo apt-get dist-upgrade
sudo apt-get upgrade

and finally,

sudo do-release-upgrade

and follow the prompts
Reply
#3
Hi, thank you.

I tried all of the commands in order, and these messages (Last lines for each command):

sudo apt-get install update-manager-core:
0 upgraded, 0 newly installed, 0 to remove and 11 not upgraded.

sudo apt-get update && sudo apt-get dist-upgrade:
E: Some index files failed to download. They have been ignored, or old ones used instead.

sudo apt-get upgrade:
0 upgraded, 0 newly installed, 0 to remove and 11 not upgraded.

sudo do-release-upgrade:
Checking for a new ubuntu release
No new release found

Checked and it has an internet connection etc, so no idea why it doesn't find anything.
Reply
#4
What is the version of your distro?

Use either of these commands to find out:

lsb_release -a

or

cat /etc/issue

Then check your update manager:
sudo nano /etc/update-manager/release-upgrades

Anywhere in that file (but usually at the bottom) you should see the "Prompt=normal" or "Prompt=lts" depending on the version you have. LTS means Long Term System or something, basically its for systems that the user may not want updated as frequently as Ubuntu devs release updates. If you don't have LTS then change it to "Prompt=normal".

Hold Ctrl and hit 'X' to exit, then select 'y' for yes when prompted if you had to make changes. (Note: you will not be prompted to save changes if you didn't make any changes)

Now try
sudo do-release-upgrade -d

If it still doesn't updgrade then you have to edit your sources.list file manually which isn't hard, just dangerous.
Reply
#5
So here is what I got

lsb_release -a
Distributor ID: Ubuntu
Description: Ubuntu 11.10 - XBMCbuntu
Release: 11.10
Codename: oneiric

sudo nano /etc/update-manager/release-upgrades was set to:
prompt=never

So I changed this to normal and ran the last command and It appears to be getting further now, I am in the process of the "Follow the prompts" now. Will let you know how I go.
Reply
#6
Hi, I had some help from a guy who was able to get about 2gb free space, and I updated my Distro, everything when through perfectly, no errors and then rebooted, but it still seems to be on 11.10

I used the sudo do-release-upgrade -d and it took about 30 mins to download and install about 700 files, and when ever it got to a yes no, I just used the default setting (As mentioned in a post I found about updating.) not sure if I missed something.

Code:
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 11.10 - XBMCbuntu
Release:        11.10
Codename:       oneiric
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
XBMCBuntu 11.10 - 12.04 Updating to 12.300