TVHeadend dosnt find services
Im trying to get tvheadend working . I'm using a ubuntu server 14.04 and a dvbsky t680c tv-card for this.

unfortunately my cable provider (Tele2) isnt in the the "add by location" list so i have to add all the muxes manually, but i have all the frequencies, network id and symbolrate settings, so that shouldn't be an issue.

after I've added the muxes and they are green and says 100%, it starts to do the initial scan as its supposed to, after this is finished nothing happens.

on the right side it says "services: 0" "muxes: 13" "muxes awaiting initial scan: 0"

what am i doing wrong? is there anything more other than this I'm supposed to do? I'm new to this so its probably something obvious.


i tried to set it up on an other computer running xbmcbuntu now and had the same issue there. and i've also tested the tv card in a windows pc using the software that came with the tv-card and it worked flawlessly. so I'm kinda sure that I'm missing some setting durring the setup in tvheadend.
Basically that's telling you it hasn't detected any valid services within those defined muxes.
Best off just adding one mux and then using the autodetect/idle scanning.

For all we know those 13 muxes you added might be missing a 0 or whatever.
yea the problem is that it dosnt find any services. those muxes works in windows. so i know that they are correct. will try to only add one and see how it goes.
dosnt find anything if I just add one and let it idle scanning, must be something with the linux drivers for my card, but it strange that it even finds the card in that case. but it works awesome in mediaportal for windows..
Make sure the user that runs tvheadend is part of the "video" group (or whatever group happens to own /dev/dvb/adapterX). Reboot if any changes are necessary.
hi, output of "ls -l /dev/dvb" is: drwxr-xr-x 2 root root 140 maj 18 12:22 adapter0

the user running tvheadend is hts

i tried "sudo chown -R hts:video /dev/dvb" but that didn't work well because it changed back after a reboot.

so then i added hfs to the root goup "usermod -a -G root hts" (this might be a bad idea?) and rebooted, the issue however still persists Sad

any idea how to make the user "hts" and the group "video" own the adaptor? or is it normal that root is owns the adapter?

thanks for helping!
This must be some Ubuntu-specific issue, all operating systems I've ever seen make the group "video" own the adapter. You'll probably have to modify some udev rules to change it, it's definitely not for a newbie. Maybe someone else knows more details about it.

Enable debug logging and show us what happens when you add the muxes and let it scan for services.
okey, then the probable cause is permissions issues, then I'm a little more wiser at least.

again thanks for your help Smile

this is whats happening in the debugging log:

Loglevel debug: enabled
May 18 17:31:01.572 dvb: "/dev/dvb/adapter0" tuning to "306,000 kHz" (Initial autoscan)
May 18 17:31:01.731 dvb: /dev/dvb/adapter0 started dvr thread
May 18 17:31:01.753 dvb: "306,000 kHz" on adapter "Sit2 DVB-T2/C", status changed to OK
May 18 17:31:21.008 dvb: /dev/dvb/adapter0 stopping thread
May 18 17:31:21.009 dvb: /dev/dvb/adapter0 stopped thread
May 18 17:31:41.000 dvb: "/dev/dvb/adapter0" tuning to "306,000 kHz" (Autoscan)
May 18 17:31:41.159 dvb: /dev/dvb/adapter0 started dvr thread
May 18 17:32:01.008 dvb: /dev/dvb/adapter0 stopping thread
May 18 17:32:01.009 dvb: /dev/dvb/adapter0 stopped thread
I would suggest opening a bug report on since this has nothing to do with XBMC.
yea probably best to ask on their forum. but if anyone got a solution don't hesitate to post hereTongue

thanks Smile
Permissions look okay for 'buntu:

[email protected]:/dev/dvb$ ls -la
total 0
drwxr-xr-x  6 root root  120 May 13 14:13 .
drwxr-xr-x 18 root root 4660 May 14 17:27 ..
drwxr-xr-x  2 root root  120 May 13 14:13 adapter0
drwxr-xr-x  2 root root  120 May 13 14:13 adapter1
drwxr-xr-x  2 root root  120 May 13 14:13 adapter2
drwxr-xr-x  2 root root  120 May 13 14:13 adapter3

I know you said that you have the right parameters for the muxes, but is there any way to check those? It may be that you can see the muxes but not decode what they're broadcasting... I'm assuming you have driver (kernel or roll-your-own) and firmware installed...
It seems that the adapterX folders are indeed owned by root:root, but the files inside them are owned by root:video on Debian at least. Only owner and group has any access at all to those files, so you either have to be root or part of the video group.
Yes, you're right:

[email protected]:/dev/dvb/adapter0$ ll
total 0
drwxr-xr-x  2 root root     120 May 13 14:13 ./
drwxr-xr-x  6 root root     120 May 13 14:13 ../
crw-rw----+ 1 root video 212, 0 May 13 14:13 demux0
crw-rw----+ 1 root video 212, 1 May 13 14:13 dvr0
crw-rw----+ 1 root video 212, 3 May 13 14:13 frontend0
crw-rw----+ 1 root video 212, 2 May 13 14:13 net0

[email protected]:/dev/dvb/adapter0$ uname -a
Linux Server 3.5.0-49-generic #74~precise1-Ubuntu SMP Fri May 2 21:32:31 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
okej, this is the output from "ls -l /dev/dvb"
totalt 0
drwxr-xr-x 2 root root 140 maj 20 12:21 adapter0

this is the output from "ls -l /dev/dvb/adapter0"
totalt 0
crw-rw----+ 1 root video 212, 4 maj 20 12:21 ca0
crw-rw----+ 1 root video 212, 0 maj 20 12:21 demux0
crw-rw----+ 1 root video 212, 1 maj 20 12:21 dvr0
crw-rw----+ 1 root video 212, 3 maj 20 12:21 frontend0
crw-rw----+ 1 root video 212, 2 maj 20 12:21 net0

this is the output of "sudo groups hts"
hts : hts video

so in that case it looks like all this are correct?

i tested again to add one of the muxes in windows and that works, but it still can't find any channels in tv headend.
the settings is:

Frequency KHz: 306000
Symbolrate (baud): 6875000
Constellation: QAM-64
FEC: auto (don't know what this is?)

these settings works in windows mediaportal and the manufacturers software, apart from the FEC because i have not seen that one in windows, (and this mix contains unencrypted channels)

i followed this guide to install the drivers for the tv-card in ubuntu:

Thanks for helping
Hmmmm. Your settings look okay - permissions and frequency/symbol rate from what I can see.

I'm guessing now, so feel free to ignore me at this point...

Is there anything in dmesg or syslog as the tuner initialises? Anything to suggest that it isn't (or confirming that it is) starting correctly?

Can you try w_scan or similar, to see if it's a tvheadend problem or a Linux/tuner problem?

What version of tvheadend as well?

Is this a multi-tuner card? Is everything looking at the right (i.e. DVB-C) tuner versus any others?

Logout Mark Read Team Forum Stats Members Help
TVHeadend dosnt find services0
This forum uses Lukasz Tkacz MyBB addons.