•   
  • 1
  • 8
  • 9
  • 10(current)
  • 11
  • 12
  • 16
  •   
Zotac CI320-520-540 Fanless
(2014-11-19, 08:37)danik56 Wrote: I bought CI320 and installed OPENELEC.
Trying to configure a Harmony 700 remote to control the device. Loaded the Microsoft Media Center profile and can navigate the XBMC functions nicely.
Problem is I can power the device off from the remote but it won't wake up.
Is there any way to get this working ? Not sure what BIOS setting should be configured for IR wakeup to work.

Any idea if power on from sleep by remote control is possible with CI320 ?
Reply
(2014-11-22, 11:47)Ghostface Wrote: SN is G1442...
I figured out that if I enable deep sleep in the bios it will turn totally silent when turned off. The red light will be on for a second or so and then switch to green.
I assume it has something todo with powering the usb ports for wakeup actions or something.

It is a very very faint noise mind you but it is there, more of a humming than a ticking tho.

When I shutdown the power on my CI520 (red LED) and then connect a 2.5" USB powered hard drive, I again hear a very quiet ticking sound when within 4 inches of the box. The sound stops as soon as the hard drive spins down and goes to sleep. So it does seem like supplying power to the USB causes the slight noise. I'm very sensitive to high frequency noises from DC adapters and it's definitely not an issue on my sample. Looks like our units were manufactured 4 months apart. Maybe Zotac switched components and made things worse? Did you try with everything unplugged? Only leaving the power and video cable? If you don't have an internal drive, try booting into openelec via USB thumb drive.

My unit is still using the original first firmware release. I have never entered the BIOS or updated to the newer releases. You could try downgrading yours to see if it makes a difference.
Reply
Hello

Just bought an new Zotac CI520 to replace my Raspbery which served me well the last year

Installed xbmcbuntu 14.04 with XBMC 13.2
The Zotac boots diskless via PXE

So far so good
everything works as expected

Have an old Windows MCE that works via the standard lirc installation that came with xbmcbuntu
============================================================================
#Chosen Remote Control
REMOTE="Windows Media Center Remotes (new version Philips et al.)"
REMOTE_MODULES="lirc_dev lirc_mceusb2"
REMOTE_DRIVER=""
REMOTE_DEVICE="/dev/lirc0"
REMOTE_LIRCD_CONF="mceusb/lircd.conf.mceusb"
REMOTE_LIRCD_ARGS=""


[email protected]:/etc/lirc$ dmesg | grep lirc
[ 20.887181] lirc_dev: IR Remote Control driver registered, major 251
[ 20.903366] rc rc0: lirc_dev: driver ir-lirc-codec (nuvoton-cir) registered at minor = 0


Try to switch back to the Remote which I used with Openelec on Raspberry
The one that came with my DVBS card TBS6991 (http://www.tbsdtv.com/products/tbs6991-d...-card.html)

Fiddled arround with lire config, sofar with no luck
Tried different REMOTE_MODULES
Still don't get any response testing with irw


Does the built in IR Receiver accept other Remotes than MCE ??
If yes Any ideas what the right lirc config / modules would be ?

Logs can be provided if necessary

Thanks
Martin
vdr 2.2.0 (yavdr/unstable-vdr) / TBS 6991 dvbs-2 - Twin Tuner plus CI / vdr-plugin-vnsiserver 1.3.0 (FernetMenta's GIT) / Ubuntu 14.04 LTS
Zotac CI520 / kodibuntu 14.04 / Helix 14.1 stable, vdr addon 1.9.23 (Opdenkamp's GIT), Skin Rapier 7.2.0
MacBook Pro / OSX 10.10 / Helix 14.1 stable, vdr addon 1.9.23 (Opdenkamp's GIT), Skin Rapier 7.2.0
MySQL MediaDB
Reply
Same problem with remote control on my CI 520 with ubuntu 14.10 (and kodibuntu) here.
I also tried different configurations...

One interesting thing is that irw does not produce any output, but the following command does:
"sudo cat /dev/lirc0"

When I press a key on my remote I get some cryptic symbols on my shell (but at least some output).

BTW: The remote works great with openelec... so there must be a way to get this working :-)
Reply
After some time i finally found out, what I had to do.
Configuring remotes in linux does not seem to be an easy task :-)

I had to use quite some tools performing cat on the raw data of the event device, using irrecord and ir-keytable and reading posts in different forums... but finally it worked.
So for all of you having trouble with this... here is my configuration and the commands that need to be executed.

First... load the following keymap and save it as "/etc/rc_keymaps/zotac_mce"
Code:
0x8034043d KEY_POWER2
0x8034843d KEY_POWER2
0x8034048e KEY_WAKEUP
0x8034848e KEY_WAKEUP
0x80340437 KEY_RECORD
0x80348437 KEY_RECORD
0x80340430 KEY_PAUSE
0x80348430 KEY_PAUSE
0x80340431 KEY_STOP
0x80348431 KEY_STOP
0x80340429 KEY_REWIND
0x80348429 KEY_REWIND
0x8034042c KEY_PLAY
0x8034842c KEY_PLAY
0x80340428 KEY_FASTFORWARD
0x80348428 KEY_FASTFORWARD
0x80340421 KEY_BACK
0x80348421 KEY_BACK
0x80340420 KEY_NEXT
0x80348420 KEY_NEXT
0x80340483 KEY_ESC
0x80348483 KEY_ESC
0x803404cb KEY_INFO
0x803484cb KEY_INFO
0x8034045d KEY_MENU
0x8034845d KEY_MENU
0x80340458 KEY_UP
0x80348458 KEY_UP
0x8034045a KEY_LEFT
0x8034845a KEY_LEFT
0x8034045b KEY_RIGHT
0x8034845b KEY_RIGHT
0x80340459 KEY_DOWN
0x80348459 KEY_DOWN
0x8034045c KEY_OK
0x8034845c KEY_OK
0x80340410 KEY_VOLUMEUP
0x80348410 KEY_VOLUMEUP
0x80340411 KEY_VOLUMEDOWN
0x80348411 KEY_VOLUMEDOWN
0x8034040d KEY_MUTE
0x8034840d KEY_MUTE
0x8034041e KEY_CHANNELUP
0x8034841e KEY_CHANNELUP
0x8034041f KEY_CHANNELDOWN
0x8034841f KEY_CHANNELDOWN
0x80340401 KEY_NUMERIC_1
0x80348401 KEY_NUMERIC_1
0x80340402 KEY_NUMERIC_2
0x80348402 KEY_NUMERIC_2
0x80340403 KEY_NUMERIC_3
0x80348403 KEY_NUMERIC_3
0x80340404 KEY_NUMERIC_4
0x80348404 KEY_NUMERIC_4
0x80340405 KEY_NUMERIC_5
0x80348405 KEY_NUMERIC_5
0x80340406 KEY_NUMERIC_6
0x80348406 KEY_NUMERIC_6
0x80340407 KEY_NUMERIC_7
0x80348407 KEY_NUMERIC_7
0x80340408 KEY_NUMERIC_8
0x80348408 KEY_NUMERIC_8
0x80340409 KEY_NUMERIC_9
0x80348409 KEY_NUMERIC_9
0x80340400 KEY_NUMERIC_0
0x80348400 KEY_NUMERIC_0
0x80340433 KEY_PROG1 # *
0x80348433 KEY_PROG1 # *
0x80340432 KEY_PROG2 # #
0x80348432 KEY_PROG2 # #
0x8034043a KEY_PROG3 # CLEAR
0x8034843a KEY_PROG3 # CLEAR
0x8034042f KEY_TEXT
0x8034842f KEY_TEXT
0x8034043e KEY_PROG4
0x8034843e KEY_PROG4
0x80340434 KEY_PVR # ENTER
0x80348434 KEY_PVR # ENTER
0x8034046d KEY_RED
0x8034846d KEY_RED
0x8034046e KEY_GREEN
0x8034846e KEY_GREEN
0x8034046f KEY_YELLOW
0x8034846f KEY_YELLOW
0x80340470 KEY_BLUE
0x80348470 KEY_BLUE
I am not really sure why all the codes need to be in there twice, but that's how it works and how I found it on the vdr-portal forums (and I tested it with each key listed only once... this causes problems).
Next step is to include this keymap in "/etc/rc_maps.cfg". There seem to be some small differences to the rc-6 maps.
Open the rc_maps.cfg file and search for "rc-rc6-mce". Besides the "table" the "file" rc6_mce should be referenced.
Exchange rc6_mce with "zotac_mce" (or comment the rc5_mce line and add the identical line with zotac_mce exchanged again :-))

Next step is to load the keytable. This can be done using ir-keytable and the two commands (have to be executed in order):
Code:
sudo ir-keytable -c
Code:
sudo ir-keytable -a /etc/rc_maps.cfg
Now the keytable can be tested with
Code:
sudo ir-keytable -t
You now should see events generated for every keypress on your remote, but the most important part here is to check for events like "EV_KEY(0x01) key_up: KEY_RIGHT(0x0001)" (when the key "right" is pressed)

Now copy these settings to your /etc/lirc/hardware.conf. Note that the "load_modules" has to be set to false for the remote to work.
Code:
# /etc/lirc/hardware.conf
#
#Chosen Remote Control
REMOTE="Linux input layer (/dev/input/eventX)"
REMOTE_MODULES="lirc_dev nuvoton-cir"
REMOTE_DRIVER="devinput"
REMOTE_DEVICE="/dev/input/event4"
REMOTE_SOCKET=""
REMOTE_LIRCD_CONF=""
REMOTE_LIRCD_ARGS=""

#Chosen IR Transmitter
TRANSMITTER="None"
TRANSMITTER_MODULES=""
TRANSMITTER_DRIVER=""
TRANSMITTER_DEVICE=""
TRANSMITTER_SOCKET=""
TRANSMITTER_LIRCD_CONF=""
TRANSMITTER_LIRCD_ARGS=""

#Disable kernel support.
#Typically, lirc will disable in-kernel support for ir devices in order to
#handle them internally.  Set to false to prevent lirc from disabling this
#in-kernel support.
#DISABLE_KERNEL_SUPPORT="true"

#Enable lircd
START_LIRCD="true"

#Don't start lircmd even if there seems to be a good config file
START_LIRCMD="false"

#Try to load appropriate kernel modules
LOAD_MODULES="false"

# Default configuration files for your hardware if any
LIRCMD_CONF=""

#Forcing noninteractive reconfiguration
#If lirc is to be reconfigured by an external application
#that doesn't have a debconf frontend available, the noninteractive
#frontend can be invoked and set to parse REMOTE and TRANSMITTER
#It will then populate all other variables without any user input
#If you would like to configure lirc via standard methods, be sure
#to leave this set to "false"
FORCE_NONINTERACTIVE_RECONFIGURATION="false"
#START_LIRCMD=""

The /etc/lirc/lircd.conf also has to be modified to match the following snippet
Code:
include "/usr/share/lirc/remotes/devinput/lircd.conf.devinput"

After these changes things should work.
To test for a working remote the lirc service has to be restarted:
Code:
sudo /etc/init.d/lirc stop
sudo /etc/init.d/lirc start
After that the program irw can be used for testing.
Each keypress on the remote should generate a matching entry while irw is running

EDIT: Changes keycodes of number keys (from KEY_1 to KEY_NUMERIC_1), so they work with kodi out of the box
Reply
Just tested my instructions from the previous post with latest kodibuntu (which uses ubuntu 14.04 lts).
They also work :-)

2 things to keep in mind (which i did not mention before).
Before changes can be made, the lirc service has to be stopped by:
Code:
sudo /etc/init.d/lirc stop
and the package ir-keytable has to be insatlled
Code:
sudo aptitude install ir-keytable
Reply
It is better to work with a symlink that with the event directly.
I had some problems when using an external usb device (the event-device number changed).

So... be sure to create a udev rule that creates a symlink to the event-device using its name.
Instructions for doing that can be found in the ubuntu wiki (at the lirc page here: http://wiki.ubuntuusers.de/Lirc)
Reply
Good day,

has someone allready expirience within the CI540? I own a CI320 and think about to upgrade to the CI540, will be the GPU (HD Graphics 4200) more power/performance full as within the CI320 Celeron one (HD Graphics (Bay Trail) within Openelec or Kodibuntu?

Would be glad to get some mind - kind regards
Brujo
Reply
What do you think the CI540 is going to get you that the CI320 doesn't do?
Reply
High quality deinterlacing, High quality upscaling using Lanczos3 Optimized.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
(2014-12-30, 17:07)fritsch Wrote: High quality deinterlacing, High quality upscaling using Lanczos3 Optimized.
I blame Zotac for my n00b'ish question. They keep things nice and confusing. I was under the impression that the CI320 was a Haswell Celeron like the BI320, but it's not. Blush
Reply
I just bought one CI320 and I will use with 4GB RAM and SSD 32GB. All my content is in NAS.

Which best OS for best image quality and performance on Kodi ? Openlec, xbmcbuntu , Windows 7 or 8 ?
Reply
(2014-12-30, 20:32)vitaoudi Wrote: I just bought one CI320 and I will use with 4GB RAM and SSD 32GB. All my content is in NAS.

Which best OS for best image quality and performance on Kodi ? Openlec, xbmcbuntu , Windows 7 or 8 ?
I think the question is more what you want to do with it.

My understanding is: If you want HD audio over HDMI (DTS-MA / True-HD) Windows isn't an option. If you want HD Netflix, OpenELEC isn't an option. If you want to do other things with it like surf the web / play games, OpenELEC probably isn't an option (It does have some sort of browser add-on though).
Reply
(2014-12-30, 17:06)Stereodude Wrote: What do you think the CI540 is going to get you that the CI320 doesn't do?

Well the CI320 in general works fine but i struggle a bit within the CPU (Celeron 2930) & Intel HD Grafics GPU in the last time with Openelec

(2014-12-30, 17:07)fritsch Wrote: High quality deinterlacing, High quality upscaling using Lanczos3 Optimized.

this I hope to get within the CI540 and hope Openelec and/or Kodibuntu will work fine with it, but I dont know if the HD Graphics 4200 in the CI540 fullfill this? I did not found mutch Information about this :-(
Reply
(2014-12-30, 20:52)Stereodude Wrote: I think the question is more what you want to do with it.

My understanding is: If you want HD audio over HDMI (DTS-MA / True-HD) Windows isn't an option. If you want HD Netflix, OpenELEC isn't an option.

None of this is true. I use the CI320 and the CI520 (320 with OpenElec and a 520 with Windows 8.1) and both bitstream over HDMI just fine.

HD Netflix is an option if you use a backend transcoding platform like PlayOn in both Windows and OpenElec. Personally I prefer Roku for this as the interface is FAR nicer than anything in Kodi - but that is just me.
Reply
  •   
  • 1
  • 8
  • 9
  • 10(current)
  • 11
  • 12
  • 16
  •   



Logout Mark Read Team Forum Stats Members Help
Zotac CI320-520-540 Fanless1
This forum uses Lukasz Tkacz MyBB addons.