•   
  • 1
  • 5
  • 6
  • 7(current)
  • 8
  • 9
  • 10
  •   
Release [SteamOS] Kodi repository
#91
Thx for your response.
I will try it next wekkend with a fresh SteamOS installation and give you a feedback.
Reply
#92
Wink 
(2015-02-28, 22:30)ProfessorKaos64 Wrote:
(2015-02-18, 15:20)wsnipex Wrote: what happens if you do apt-get dist-upgrade?

I have done that, no effect. I still get unmet dependencies when trying to install xbmc or kodi. Kodi will look for kodi.bin, and attempting to install xbmc, results in dependency failure from kodi.

I kept digging on this and found that each time I pinned a higher version of a dependency, another dependency popped up. I am running vanilla SteamOS with the latest build (153 i think).

After I could not get that to work, I turned on SteamOS beta. No dice again.

next I edited the preferences file to be


Code:
Package: *
Pin: origin mirrors.xbmc.org
Pin-Priority: 800

Package: *
Pin: release l=SteamOS
Pin-Priority: 900

Package: *
Pin: release l=Debian
Pin-Priority: -10


This allowed me to get through the initial error but ran into:
Code:
The following packages have unmet dependencies:
kodi-bin : Depends: libva-x11-1 (> 1.3.0~) but 1.0.15-4 is to be installed
            Depends: libva1 (> 1.3.0~) but 1.0.15-4 is to be installed
E: Unable to correct problems, you have held broken packages.

Sigh.

Next I ran the apt-cache policy on those files and found SteamOS has the updated files I needed. Back to perferences file. It now reads:

Code:
Package: *
Pin: origin mirrors.xbmc.org
Pin-Priority: 800

Package: *
Pin: release l=SteamOS
Pin-Priority: 900

Package: *
Pin: release l=Debian
Pin-Priority: -10

Package: libva-x11-1
Pin: release l=SteamOS
Pin-Priority: 900

Package: libva1
Pin: release l=SteamOS
Pin-Priority: 900


tada!!! Kodi 14.1 installs.
Reply
#93
your pinning is essentially the same as on the OP.
Package: *
Pin: release l=SteamOS
Pin-Priority: 900

already includes libva stuff, so thats redundant. I wonder why you have debian in there(even if its -10). Did you install something from debian repos?
Reply
#94
@wsnipex. I am going to blow away the box, update it again, and then try to install Kodi again. I'll screen capture errors as I go.
Reply
#95
ok, thanks
Reply
#96
Followed every instruction to the letter on a fresh install of SteamOS, I keep getting unmet dependencies errors. First for kodi, then for kodi-bin, then I get "kodi-bin : Depends: libtag1c2a (>= 1.8) but 1.7.2+bsos8 is to be installed

Not sure how to fix this, any help would be greatly appreciated.
Reply
#97
I am in the same boat as @Arsoul. Any advice on how to get kodi up and running would be greatly appreciated!
Reply
#98
apt-cache policy libtag1c2a kodi

version 1.9 should be available in our repo. Maybe SteamOS changed something or you have some other package that hard-depends on that ancient 1.7 version.
Reply
#99
hello maybe someone can help me just bought the kodicast installed on my e-pad had already chromecast and allcast installed prior to this and once i got it all programmed nothing is streaming on the TV still playing on e-pad ....
Reply
(2015-04-04, 10:18)mbarreira43 Wrote: hello maybe someone can help me just bought the kodicast installed on my e-pad had already chromecast and allcast installed prior to this and once i got it all programmed nothing is streaming on the TV still playing on e-pad ....

completely off topic here. Whatever a "kodicast" is, it has nothing to do with SteamOS
Reply
(2015-04-04, 09:46)wsnipex Wrote: apt-cache policy libtag1c2a kodi

version 1.9 should be available in our repo. Maybe SteamOS changed something or you have some other package that hard-depends on that ancient 1.7 version.



[email protected]:~$ apt-cache policy libtag1c2a kodi
libtag1c2a:
Installed: 1.7.2-1+bsos8
Candidate: 1.7.2-1+bsos8
Version table:
1.9.1-2 0
800 http://mirrors.xbmc.org/apt/steamos/ alchemist/main amd64 Packages
*** 1.7.2-1+bsos8 0
900 http://repo.steampowered.com/steamos/ alchemist/main amd64 Packages
100 /var/lib/dpkg/status
1.7.2-1 0
110 ftp://ftp.us.debian.org/debian/ wheezy/main amd64 Packages
kodi:
Installed: (none)
Candidate: 2:14.1~git20150131.1014-38e4046-0
Version table:
2:14.1~git20150131.1014-38e4046-0 0
800 http://mirrors.xbmc.org/apt/steamos/ alchemist/main amd64 Packages



So I saw that there is indeed a 1.9.1-2 version package there.... So I just changed the pin-priority of the xbmc repo to 900 and made the steamOS pin-priority 800 in the preference file and tried again and.... it worked!
Hopefully nothing bad comes out of changing those pin-priorities. I changed them back to 800 and 900 respectively after the install.
Reply
thanks for reporting back. I've fixed the pinning file in the howto to prefer our version.
Reply
Only worked here when I added libtag1-vanilla to the exception, like that:

Package: libtag1c2a libtag1-vanilla
Pin: origin mirrors.xbmc.org
Pin-Priority: 901

I tested it on 2 fresh installs... on both times it refused to install kodi until I made the change above...
Reply
Are AMD GPU's still not supported? Typical! Have 6 Arctic MC001's with Atom D525 and AMD mobile GPU's inside and was hoping to add SteamOS once I build my new Media server and add IHS. The atoms will melt with software decode whereas these machines are fine for 1080 video with Vanilla Kodi.
Reply
I'm not the greatest at Debian based systems so I might be doing something wrong, but I've had this installed for months and it's still on 14.1 even after an 'aptitude full-upgrade'. Is this repository still maintained?
Reply
  •   
  • 1
  • 5
  • 6
  • 7(current)
  • 8
  • 9
  • 10
  •   



Logout Mark Read Team Forum Stats Members Help
[SteamOS] Kodi repository2
This forum uses Lukasz Tkacz MyBB addons.