• 1
  • 6
  • 7
  • 8
  • 9
  • 10(current)
Release [SteamOS] Kodi repository
I currently have libshairplay-dev 0.9.0-6 installed~vivid, but get
checking for libshairplay soname... libshairplay.so.0
checking for struct raop_callbacks_s.audio_remote_control_id... no
configure: error: "No airtunes library could be found. (libshairplay)"

I'm taking a look at the configure file now.

raop.h is located at

desktop@steamos:~/kodi$ sudo ldconfig -v | grep libshair*
/sbin/ldconfig.real: Can't stat /lib/i586-linux-gnu: No such file or directory
/sbin/ldconfig.real: Can't stat /usr/lib/i586-linux-gnu: No such file or directory
/sbin/ldconfig.real: Path `/lib/x86_64-linux-gnu' given more than once
/sbin/ldconfig.real: Path `/usr/lib/x86_64-linux-gnu' given more than once
/sbin/ldconfig.real: /lib/i386-linux-gnu/ld-2.19.so is the dynamic linker, ignoring

/sbin/ldconfig.real: /lib/x86_64-linux-gnu/ld-2.19.so is the dynamic linker, ignoring

        libshairplay.so.0 -> libshairplay.so.0.0.0
        libshairport.so.2 -> libshairport.so.2.0.0

Header file
desktop@steamos:~/kodi$ ls /usr/include/shairport

Seems related to:
Update: Building shairplay from https://github.com/juhovh/shairplay worked, so it seems even rebuilding shairplay from Ubuntu~Vivid in the Kodi stable PPA didn't provide/install what the system needed.

Update2: Built shairplay from the nightly Kodi PPA. That seems to have worked. Have to do a few clean builds before I go after the Lintian errors and warnings. A build is commencing now, then an attempt at the tools/Linux/packaging/mk-debian-package.sh script.

@wsnipex : Is there a chance you'd accept a pull request to specify the minimum shairplay/libshairplay* packages? It seems the stable XBMC PPA has too old a package, or is not packaged in the same way the nightly is.

Origin: ppa:team-xbmc/ppa
shairplay - 0.9.0-6~vivid

Origin: ppa:team-xbmc/xbmc-nightly
shairplay -

All my previous configure attempts with libbluray and airport enabled at configure time failed with the stable PPA (failure on airport, not libluray). The nightly shairplay package gave me successful airtuns and airplay checks.

./configure --prefix=/usr --enable-libbluray --enable-airport

...now works Smile

Update 3: Here are the lintian warnings

dpkg-source --after-build kodi
dpkg-buildpackage: full upload (original source is included)
Now running lintian...
E: kodi changes: bad-distribution-in-changes-file brewmaster
E: kodi source: source-is-missing addons/webinterface.default/js/jquery-1.8.2.min.js
E: kodi source: source-is-missing addons/webinterface.default/js/iscroll-min.js
E: kodi source: source-contains-prebuilt-ms-help-file project/Win32BuildSetup/tools/7z/7-zip.chm
E: kodi source: source-contains-prebuilt-ms-help-file lib/cximage-6.0/zlib/contrib/dotzlib/DotZLib.chm
W: kodi source: debhelper-but-no-misc-depends kodi-addon-dev
W: kodi source: debhelper-but-no-misc-depends kodi-screensaver-dev
W: kodi source: debhelper-but-no-misc-depends kodi-visualization-dev
W: kodi source: debhelper-but-no-misc-depends kodi-pvr-dev
W: kodi source: debhelper-but-no-misc-depends kodi-audio-dev
W: kodi source: debhelper-but-no-misc-depends kodi-tools-texturepacker
E: kodi source: debian-revision-should-not-be-zero 16.0~git20150924.2105-40441fb-0
E: kodi source: build-depends-on-obsolete-package build-depends: python-support => use dh_python2 instead
W: kodi source: ancient-standards-version 3.9.4 (current is 3.9.6)
E: kodi-eventclients-xbmc-send: debian-changelog-file-missing
E: kodi-eventclients-xbmc-send: debian-revision-should-not-be-zero 16.0~git20150924.2105-40441fb-0
E: kodi-screensaver-dev: debian-changelog-file-missing
E: kodi-screensaver-dev: debian-revision-should-not-be-zero 16.0~git20150924.2105-40441fb-0
W: kodi-bin: hardening-no-relro usr/lib/kodi/addons/library.kodi.adsp/libKODI_adsp-x86_64-linux.so
W: kodi-bin: hardening-no-relro usr/lib/kodi/addons/library.kodi.audioengine/libKODI_audioengine-x86_64-linux.so
W: kodi-bin: hardening-no-relro usr/lib/kodi/addons/library.kodi.guilib/libKODI_guilib-x86_64-linux.so
W: kodi-bin: hardening-no-relro usr/lib/kodi/addons/library.xbmc.addon/libXBMC_addon-x86_64-linux.so
W: kodi-bin: hardening-no-relro usr/lib/kodi/addons/library.xbmc.codec/libXBMC_codec-x86_64-linux.so
W: kodi-bin: hardening-no-relro usr/lib/kodi/addons/library.xbmc.pvr/libXBMC_pvr-x86_64-linux.so
W: kodi-bin: hardening-no-relro usr/lib/kodi/kodi-xrandr
E: kodi-bin: embedded-library usr/lib/kodi/kodi.bin: libpostproc
E: kodi-bin: embedded-library usr/lib/kodi/kodi.bin: libavutil
E: kodi-bin: embedded-library usr/lib/kodi/kodi.bin: libavfilter
W: kodi-bin: hardening-no-relro usr/lib/kodi/kodi.bin
W: kodi-bin: hardening-no-relro usr/lib/kodi/system/ImageLib-x86_64-linux.so
W: kodi-bin: hardening-no-relro usr/lib/kodi/system/libcpluff-x86_64-linux.so
W: kodi-bin: hardening-no-relro usr/lib/kodi/system/libexif-x86_64-linux.so
W: kodi-bin: hardening-no-relro usr/lib/kodi/system/libsse4-x86_64-linux.so
W: kodi-bin: hardening-no-relro usr/lib/kodi/system/players/dvdplayer/libdvdcss-x86_64-linux.so
W: kodi-bin: hardening-no-relro usr/lib/kodi/system/players/dvdplayer/libdvdnav-x86_64-linux.so
E: kodi-bin: debian-changelog-file-missing
E: kodi-bin: debian-revision-should-not-be-zero 16.0~git20150924.2105-40441fb-0
E: kodi-visualization-dev: debian-changelog-file-missing
E: kodi-visualization-dev: debian-revision-should-not-be-zero 16.0~git20150924.2105-40441fb-0
E: kodi-audio-dev: debian-changelog-file-missing
E: kodi-audio-dev: debian-revision-should-not-be-zero 16.0~git20150924.2105-40441fb-0
E: kodi-pvr-dev: debian-changelog-file-missing
E: kodi-pvr-dev: debian-revision-should-not-be-zero 16.0~git20150924.2105-40441fb-0
E: kodi-eventclients-j2me: debian-changelog-file-missing
E: kodi-eventclients-j2me: debian-revision-should-not-be-zero 16.0~git20150924.2105-40441fb-0
E: kodi-eventclients-common: debian-changelog-file-missing
E: kodi-eventclients-common: debian-revision-should-not-be-zero 16.0~git20150924.2105-40441fb-0
E: kodi-eventclients-common: depends-on-obsolete-package depends: python-support (>= 0.90.0) => use dh_python2 instead
W: kodi-eventclients-wiiremote: hardening-no-relro usr/bin/kodi-wiiremote
E: kodi-eventclients-wiiremote: debian-changelog-file-missing
E: kodi-eventclients-wiiremote: debian-revision-should-not-be-zero 16.0~git20150924.2105-40441fb-0
E: kodi: debian-changelog-file-missing
E: kodi: debian-revision-should-not-be-zero 16.0~git20150924.2105-40441fb-0
E: kodi: depends-on-obsolete-package depends: python-support (>= 0.90.0) => use dh_python2 instead
W: kodi: extra-license-file usr/share/kodi/addons/service.xbmc.versioncheck/LICENSE.txt
W: kodi: duplicate-font-file usr/share/kodi/addons/skin.confluence/fonts/Roboto-Bold.ttf also in fonts-roboto
W: kodi: duplicate-font-file usr/share/kodi/addons/skin.confluence/fonts/Roboto-Regular.ttf also in fonts-roboto
W: kodi: extra-license-file usr/share/kodi/addons/skin.confluence/media/Subtitles/flags/LICENSE.txt
W: kodi: binary-without-manpage usr/bin/xbmc
E: kodi-tools-texturepacker: embedded-library usr/bin/TexturePacker: libpng
E: kodi-tools-texturepacker: embedded-library usr/bin/TexturePacker: zlib
E: kodi-tools-texturepacker: embedded-library usr/bin/TexturePacker: libm
E: kodi-tools-texturepacker: embedded-library usr/bin/TexturePacker: libjpeg
E: kodi-tools-texturepacker: statically-linked-binary usr/bin/TexturePacker
E: kodi-tools-texturepacker: debian-changelog-file-missing
E: kodi-tools-texturepacker: debian-revision-should-not-be-zero 16.0~git20150924.2105-40441fb-0
W: kodi-tools-texturepacker: binary-without-manpage usr/bin/TexturePacker
E: xbmc: debian-changelog-file-missing
W: xbmc: description-starts-with-leading-spaces
E: xbmc: debian-revision-should-not-be-zero 16.0~git20150924.2105-40441fb-0
E: kodi-addon-dev: debian-changelog-file-missing
E: kodi-addon-dev: debian-revision-should-not-be-zero 16.0~git20150924.2105-40441fb-0
E: kodi-eventclients-ps3: debian-changelog-file-missing
E: kodi-eventclients-ps3: debian-revision-should-not-be-zero 16.0~git20150924.2105-40441fb-0
E: kodi-eventclients-dev: debian-changelog-file-missing
E: kodi-eventclients-dev: debian-revision-should-not-be-zero 16.0~git20150924.2105-40441fb-0
N: 1 tag overridden (1 error)
Finished running lintian.
Now signing changes and any dsc files...
signfile kodi_16.0~git20150924.2105-40441fb-0.dsc wsnipex <[email protected]>
gpg: skipped "wsnipex <[email protected]>": secret key not available
gpg: /tmp/debsign.jMtWH3L3/kodi_16.0~git20150924.2105-40441fb-0.dsc: clearsign failed: secret key not available
debsign: gpg error occurred!  Aborting....
debuild: fatal error at line 1295:
running debsign failed
output directory: /home/desktop/kodi/..
I don't give a shit about lintian warnings. Its never going into debian anyway. About the only thing I might fix is the no-relro stuff.
Oh trust me, neither do I for a simple deb package. For simple source package rebuilds from git repos I tend to just use checkinstall to get a basic set of docs. For the GPG sign error, would modifying my fork's changelog take care of that? Or based on the above was the deb package written to a directory within my build dir? Thank you for the reply.
Got the debs built for Jarvis. Working on Getting some for Isengard since Jarvis is still in development.

I’ve read some good stuff here. Definitely worth bookmarking for revisiting. I surprise how much effort you put to create such a great informative website
Hello to anyone who can help me.

I have been using Kodi for a long time now. I have been trying to get everything updated from a friend who introduced me to kodi. I cant get nothing to work anymore on my fire tv. I am looking for a smooth running system for movies, tv shows, and music. I have heard rumors you can subscribe to a better kodi system. Dont know what to do at this point. I went to the kodi webpage hoping they had systems with everything uploaded for sale. But I cant find anything. I went to youtube and the internet but i cant trust those guys. If anyone is willing to help I can paypal for services. Thank you in advanced for any help. My email is [email protected]

Best Regards,

Having trouble with repository.
Yes I finally got fire fox on my channel,those other apps didn't work out to good.Could you please send Kodi to my new fire fox app please.
Can anyone help I've tried to install using downloader and es file with no luck on firestick I've even used Internet explorer but same happens with that is it down or am I being blocked by my provider. It all worked fine yesterday
That solves the issue with the navigation sounds on the rear speakers, at least for XBMC. But all the other problems persist: Gnome's "Test Speakers" is still audible on multiple speakers at once and XBMC playback of 5.
Seems like this is extremely old. Hopefully there's an update on this. I'm super interested in using Kodi for game streaming.
Kodi Enthusiast / Spontaneous Box Buyer / Wannabe Dev
[ Current favs: Fastest: Ugoos AM6 Android Box / Budget: Omni Kodi Stick / Balance: KM3 Android Box ] 
(2020-01-30, 20:50)jlordon Wrote: Seems like this is extremely old. Hopefully there's an update on this. I'm super interested in using Kodi for game streaming.

I believe there's a steam launcher for Kodi somewhere, that launches the Steam app on the computer that Kodi is installed on. From there, you can start game streaming.
If you're using Kodi on a Raspberry Pi, I believe there's a build for the Steam Link app for Raspberry Pi 3 (or was it 4? Anyway, not the older versions). Not sure if there's a Kodi launcher for that, I haven't tested it.

But I believe this thread is for the old repository that used to exist for SteamOS, making it possible to run Kodi on your SteamOS machine.
I am new here and I got an error message can anybody help
  • 1
  • 6
  • 7
  • 8
  • 9
  • 10(current)

Logout Mark Read Team Forum Stats Members Help
[SteamOS] Kodi repository2
This forum uses Lukasz Tkacz MyBB addons.