Linux Correct settings for HDMI to TV, and SPDIF to Receiver
#1
I just wondered what the correct settings should be for system running Ubuntu 14.04 x64 and Gotham with an nVidia GT 640 to TV via HDMI, and onboard audio to 5.1 surround sound system via SPDIF (optical cable) should be please?

I seem to be having problems with audio starting off ok and then getting out of sync after about 20 minutes. The 5.1 doesn't seem as good as it was with my old receiver and build of Ubuntu 12.04. Also, during big actions scenes the audio goes slightly muffled and the comes back ok. The receiver and speakers are ok as I've tested them at fairly loud levels with mp3 files out of all speakers and there's no issues except for movie playback within XBMC.
Reply
#2
Long story, and probably fritsch will correct me, but I try to help you anyhow.
You need to do some basic stuffs:
Set configuration mode to advanced
Go to System Setting - Audio Output
Set Audio Output device as Analog (your analog card)
then set Number of Channels to 2.0 (note that this is not the number of speakers, but the bandwidth of SPDIF)
then set Enable Passthrough,
select as passthrough device SPDIF
set your receiver as capable of AC3, Dolby Digital and DTS

Then try again, it will probably work.
Reply
#3
Thank you for your reply.

I've got the Number of Channels set to 5.1 - it's a 5.1 system and I'm a bloke so natually I took a stab in the dark and set it to 5.1 Big Grin

I'll setup the Passthrough options as I'd not considered this and retest the setup!

Thanks again Smile
Reply
#4
(2014-06-17, 22:19)Claudio.Sjo Wrote: Go to System Setting - Audio Output
Set Audio Output device as Analog (your analog card)
then set Number of Channels to 2.0 (note that this is not the number of speakers, but the bandwidth of SPDIF)
then set Enable Passthrough,
select as passthrough device SPDIF
set your receiver as capable of AC3, .Dolby Digital and DTS

Sorry for sounding stupid but I don't have all of these settings in Audio Output. I can set the number of channels but there is no passthrough option, no passthrough device, and no option to configure the receiver.

The only place I can find the Enable Passthrough option is by bringing up the menu when I'm watching a film and going into Audio, The other options don't exist in there either.

I've reverted back to the Confluence skin and have Expert Level settings enabled.

I do seem to remember seeing those settngs in the past but I'm guessing that was in an older version of XBMC. I'm currently on Gotham 13.1 [June 6 2014]
Reply
#5
Thx for reading the Gotham FAQ: http://wiki.xbmc.org/index.php?title=XBM...otham)_FAQ
And the "read me before posting" thread: http://forum.xbmc.org/showthread.php?tid=34655
You most likely run pulseaudio: http://wiki.xbmc.org/index.php?title=PulseAudio
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#6
(2014-06-18, 09:37)fritsch Wrote: Thx for reading the Gotham FAQ: http://wiki.xbmc.org/index.php?title=XBM...otham)_FAQ
And the "read me before posting" thread: http://forum.xbmc.org/showthread.php?tid=34655
You most likely run pulseaudio: http://wiki.xbmc.org/index.php?title=PulseAudio

Whilst I appreciate you taking the time to respond, I don't believe the sarcasm was necessary.

I was simply asking for some advice, not reporting bug, not suggesting I'll move to another application if I can't make this one work and I wasn't talking about the application in a negative way. It was more of 'best practice' question than saying 'it doesn't work how I think it should'.

I should have gone back over the Gotham FAQ and I admit that and I apologise if anyone feels like I've wasted their time by starting this thread. But I will also admit that I was interested in hearing what other people had to say on the matter, tips / tricks and other user's feedback, particularly as far as Gotham was concerned with it being a new release. I'm not new to XBMC, I've been using it since the original XBox, but I'll also admit that I'm no Linux Guru and I'll still getting my head around a lot of things within that environment. That is why I tried to include as much information as I could see what other user's suggestions were.

I appreciate that being a developer can be frustrating when you are having to respond to the same question several times a day because people don't RTFM. But I don't 'think' I did anything which justified such a sharp response.

Once again I'd like to say thank you for pointing me in the right direction.
Reply
#7
But does it finally work?
I forgot to mention pulseaudio, it's actually evil and needs to be removed as first step.
Then you'll find the configuration parameter as I wrote before.

The guys doing the real job are fantastic, but this story about the passthrough audio is getting more and more boring for them.
Myself had a lot of posting and what is frustrating is that in my opinion xbmc on Linux could do a lot itself, for instance it could tell
in the Audio configuration page "Warning, you are using pulseaudio, this is not recommended", then since the bandwidth of SPDIF
is well-known, it could disable this choice about number of channels when enabling passthrough.
XBMC is incredibly powerful, but has a lot of configuration possibility that can confuse people.

I also understand that for developer is frustrating to get always the same questions, I have myself a problem dealing
with slideshow, but since the HTPC is in the sofa, I cannot make debugging without causing a revolution in my family,
and in order to update to Lubuntu 14.04 and Gotham I had to wait in order to get a 4 hours timeslot.
Reply
#8
Claudio, are you sure you've currently got Gotham installed as everything you keep posting seems to relate to the old Frodo settings.

In Gotham there is:

No "Audio output" setting that can be set to Analog, it's been removed.

No "Number of channels" setting when SPDIF is selected as the "Audio output device" as it is hidden from the user and is internally fixed to 2.0 channels.
Reply
#9
Hi,
I've just checked on my iMac.
It's Gohtham 13.1, System/Setting/System/Audio Output
first option : Audio Output - set to intel HDA Analog
Number of Channels - set to 2

In the HTPC, if I set Audio Output as SPDIF, independently from the number of channels, I get stereo audio.
If I set Audio Output to Analog, number of channels to 2.0 and passthrough to SPDIF, I get the proper audio.

The only think for which I can be guilty is because I'm still using the old .xbmc but all my configuration data are there, and I won't miss it.
Reply
#10
Ah ok, I think that explains it as if I remember right XBMC on OS-X for Mac's is slightly different and leaves the Number of channels setting exposed when SPDIF is select, it's definitely not that way on any if the other OS's including Linux.
Reply
#11
It didn't work unfortunately. I was still only getting 2 channel stereo once I'd set things up in pavucontrol.

In my old Ubuntu build document that I put together, I'd added a section in there specifically for removing Pulseaudio and using Alsa instead. Unfortunately this didn't work on 14.04 and wanted to remove a load of core os packages so I proceed with trying to make the system work as is.Pulseaudio seems to be more integrated than it's ever been!

I came across this thread http://ubuntuforums.org/showthread.php?t=1608804 and followed the instructions. Everything seemed to go ok until it came to doing the speaker test which failed. It was looking for the .la and .so files - I had to copy them to /usr/lib/x86_64-linux-gnu/pulseaudio instead of /usr/lib/alsa-lib/ but then the speaker test ran fine. I've tried a couple of movies and the sound does seem better but I need to test it properly tomorrow when people aren't in bed Smile

I also need to have a play around with the Stereo Upmix option to see how well it works in practice as it sounds good on paper!

I seem to have a bit of an issue with skipped frames but disabling 'Adjust Displays Refresh Rate to Match Video' and enabling 'Sync Playback to Display [A/V Sync Method : Audio Clock]' seems to have reduced this dramatically. They are still happening occastionally but I'll look into this separately.

Thanks again for helping me out. Whilst your solution didn't get me straight to the answer, it certainly helped to get me in the right direction Smile
Reply
#12
All you needed to do was suspend PulseAudio by starting XBMC with the ALSA environment variable, details are in the wiki page linked above.
Reply
#13
It's always the same - nobody can see what happens when user refuses to post a debug log ... so my sarcastic post was perfectly right. Now the user ends with a fucked up system, that is doing a52 encoding under the hood without any control by an application, while all of that could be done within xbmc by just reading the pulseaudio wiki entry and posting a Debug Log
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#14
There is also absolutely no need to compile anything from source, Ubuntu ships that a52 workaround in: libasound2-plugins-extra and a simple sudo apt-get install libasound2-plugins-extra will install those. But again all this is not needed by either enabling the passthrough options for pulseaudio (see the wiki) and configuring xbmc accordingly. Or by starting xbmc with AE_SINK=ALSA and also configuring xbmc correctly after doing so ...
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#15
I add another 10cents, as I had the chance to change my configuration and to try again.
I removed pulseaudio immediately after installing Lubuntu 14.04 anyhow.
My current setting is
Audio Output - SPDIF
(there are no number of channels to set anymore, they only exist if you select analog, thanks)
Enable Passthrough
Everythink works great.

This morning even the pictures are shown properly, thus I cannot add any debug log :-(
Reply



Logout Mark Read Team Forum Stats Members Help
Correct settings for HDMI to TV, and SPDIF to Receiver0
This forum uses Lukasz Tkacz MyBB addons.