Default Zoom Level
#1
Is it possible to set a default zoom level for Live TV only? Right now I have the default zoom level set but its for all video files, so any time I play a movie I have to zoom back out.
Reply
#2
There is no way to tell what default titles should be zoomed and what are to be handled normally... There could be workarounds with the keyboard 'Z' key toggle between normal, other and zoom modes. It might be possible to use an external player preset and configured for zoom when playing a certain extension. Once you get into scripting and editing xml code things get complicated pretty fast. If your just wanting a full screen look for older aspect videos you might investigate crop black bars (large error percentage) or display 4:3 videos as.... in settings.video.
Reply
#3
At the moment it's not possible, though technically it could be. Why do you need to set a zoom mode for all your TV channels anyway, usually it's just some that may need it?
Reply
#4
(2014-06-22, 23:28)negge Wrote: At the moment it's not possible, though technically it could be. Why do you need to set a zoom mode for all your TV channels anyway, usually it's just some that may need it?

My cable is not HD, but most channels are still broadcast in widescreen. Without zooming I end up with a box with black bars all the way around it.
Reply
#5
Have you tried the "crop black bars" setting in the video options, during playback on the On-screen-display buttons? In theory it should allow XBMC to automatically detect the black bars and auto crop, and 90% of the time it seems to work really well.
Reply
#6
As a lame workaround for now you can open your TV*.db database file in an SQLite editor and batch update the zoom level values for all PVR items.
Reply
#7
(2014-06-23, 08:08)Ned Scott Wrote: Have you tried the "crop black bars" setting in the video options, during playback on the On-screen-display buttons? In theory it should allow XBMC to automatically detect the black bars and auto crop, and 90% of the time it seems to work really well.

Doesn't seem to be cropping at all, unless I am missing something with this setting.
Reply
#8
Hmm, I can't get it to work either. It used to work...
Reply
#9
FYI: Crop Black Bars.

It still works (even with hardware acceleration on), just tested it with a few older 576 4:3 aspect files that almost filled the frame, but left a 5% black bard top & bottom, the crop black bar function zooms nicely to eliminate those bars. If the 4:3 aspect allow error is at 20% the image is stretched to full 16:9, anything less brings in the side black bars.

Gotham 13.1
Reply
#10
My MBP with OS X seems to crop just fine, but my Celeron miniPC on Ubuntu doesn't seem to want to. Hmmm...
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Default Zoom Level00