[Linux] [XBMCbuntu] Asus EB1037 - nvidia optimus issues

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
ant_thomas Offline
Fan
Posts: 467
Joined: May 2008
Reputation: 0
Location: Manchester, UK
Post: #1
Hello,

I've been banging my head against a brick wall for the past few days on how to sort this one.

The system I have is the Asus EeeBox EB1037

Spec:

CPU - Intel J1900
Discrete GPU - nvidia 820m

Since the system has both Intel HD and nvidia graphics where the Intel graphics can't be turned off in the BIOS/EFI this (if I'm correct) makes it an nvidia optimus system.

Starting with XBMCbuntu:
I've not given it much of a chance but when I try to boot all I get is a flashing cursor and nothing more. Could be a BIOS/UEFI issue maybe?

Openelec:
Openelec boots fine and quick but defaults to the Intel graphics. Someone in the openelec IRC channel said that it either works or doesn't. If it doesn't pick up the nvidia graphics by default then I'm probably out of luck.

ubuntu minimal:
I usually use this method for installing XBMC since I end up with a system that I have more control over. Due to a lack of graphics drivers "nomodeset" is required in the grub command to get it to boot. Once booted I've tried various versions of the nvidia drivers with bumblebee and optirun and xbmc.

Tried nvidia 319, 331, 337
Ubuntu 14.04
Kernel - 3.13 and 3.14.1

I realise this isn't an XBMC issue specifically but has anyone successfully managed to get bumblee or an optimus system working ubuntu and XBMC?

Errors I've come across are

Code:
kernel: [ 2103.239018] vgaarb: this pci device is not a vga device
kernel: [ 2103.240424] nvidia 0000:01:00.0: irq 113 for MSI/MSI-X
kernel: [ 2103.247963] NVRM: failed to copy vbios to system memory.
kernel: [ 2103.249699] NVRM: RmInitAdapter failed! (0x30:0xffffffff:714)
kernel: [ 2103.249714] NVRM: rm_init_adapter failed for device bearing minor number 0

What would people recommend to even have a chance of getting this system working?
find quote
wsnipex Offline
Team-Kodi
Posts: 6,466
Joined: Jun 2011
Reputation: 167
Post: #2
xbmc starts fine on my optimus notebook on the nvidia card when using optirun xbmc. But vdpau doesn't work, seems there is a mixup with mesa stuff in that case. Didn't really investigate. Using primus to always run on nvidia could work though
find quote
ant_thomas Offline
Fan
Posts: 467
Joined: May 2008
Reputation: 0
Location: Manchester, UK
Post: #3
I guess this is running ubuntu desktop rather than a server/minimal installation?
find quote
wsnipex Offline
Team-Kodi
Posts: 6,466
Joined: Jun 2011
Reputation: 167
Post: #4
indeed, but that shouldn't make any difference
find quote
ant_thomas Offline
Fan
Posts: 467
Joined: May 2008
Reputation: 0
Location: Manchester, UK
Post: #5
Still got the same "NVRM: failed to copy vbios to system memory." errors.

I'll see if I can have any success with Primus. I guess I should speak to the bumblebee people.
find quote
ant_thomas Offline
Fan
Posts: 467
Joined: May 2008
Reputation: 0
Location: Manchester, UK
Post: #6
Looking like an nvidia EFI/ACPI/CSM issue. I've tried posting on the nvidia forums but my post is currently "hidden".

Just going to go for the Intel graphics for the time being since I need to get using the box!
find quote