Lirc works, XBMC does not
#1
Hi, there. I am running XBMC 13.1 (f2acae7) Gotham on an Intel NUC and XBMCbuntu . Until yet I use the iOS RC software and I am quite happy with that. But when it’s dark I prefer a remote with physical buttons. That’s why I read quit a lot tutorials and documentation about Lirc, XBMC and the involved config files.
Lirc seems to work, but I cannot control XBMC using my RC.

My progress so far:
irw shows the expected output (I named my remote pioneer):
Code:
00000000f50a4fb0 00 KEY_UP pioneer
00000000c53a9966 00 KEY_DOWN pioneer
00000000c53a9966 00 KEY_LEFT pioneer
00000000c53a9966 00 KEY_RIGHT pioneer

my xbmc.log knows about my button presses:
Code:
21:16:30 T:140603647997888   DEBUG: LIRC: Update - NEW at 674076:00000000f50a4fb0 00 KEY_UP pioneer (KEY_UP)
21:16:30 T:140603647997888   DEBUG: LIRC: Update - NEW at 675019:00000000c53a9966 00 KEY_DOWN pioneer (KEY_DOWN)
21:16:36 T:140603647997888   DEBUG: LIRC: Update - NEW at 680837:00000000c53a9966 00 KEY_LEFT pioneer (KEY_LEFT)
21:16:38 T:140603647997888   DEBUG: LIRC: Update - NEW at 682129:00000000c53a9966 00 KEY_RIGHT pioneer (KEY_RIGHT)

my \~/.xbmc/userdata/Lircmap.xml looks like this:
Code:
<lircmap>
<remote device="pioneer">
<power>KEY_POWER</power>

<enter>KEY_ENTER</enter>
<left>KEY_LEFT</left>
<right>KEY_RIGHT</right>
<up>KEY_UP</up>
<down>KEY_DOWN</down>

<back>KEY_BACK</back>
<info>KEY_INFO</info>

<play>KEY_PLAY</play>
<pause>KEY_PAUSE</pause>
<stop>KEY_STOP</stop>


<reverse>KEY_REWIND</reverse>
<forward>KEY_FORWARD</forward>
<skipplus>KEY_NEXT</skipplus>
<skipminus>KEY_PREVIOUS/<skipminus>

<menu>KEY_HOME</menu>
</remote>
</lircmap>

my \~/.xbmc/userdata/keymaps/remote.xml looks like this. To keep it simple I only configured left and right. I expect left and right to be working within XBMC's home screen.
Code:
<keymap>
  <global>
    <remote>
      <left>Left</left>
      <right>Right</right>
    </remote>
  </global>
</keymap>

Thank you for your hints. If you need more information, I can provide lircd.conf and hardware.conf, too.
Reply
#2
Code:
<left>Left</left>
<right>Right</right>

Should be (at least in my keymap)

Code:
<left>left</left>
<right>right</right>

Also is this a typo here, or actually in your Lircmap.xml ?
Code:
<skipminus>KEY_PREVIOUS/<skipminus>
Could be upsetting the parsing of the file.
Learning Linux the hard way !!
Reply
#3
With one look you spotted the problem. Thank you. A tiny slash broke my config!
I spend more than 6 hours to look for the problem.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Lirc works, XBMC does not00
This forum uses Lukasz Tkacz MyBB addons.