Error in MAIL addon...
#1
Whenever I try to access my INBOX using the MAIL addon I keep getting "script error".

The debug log shows this:

Code:
23:52:54 T:140214064129792   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.AttributeError'>
                                            Error Contents: 'NoneType' object has no attribute 'groups'
                                            Traceback (most recent call last):
                                              File "/home/htpc/.xbmc/addons/plugin.programm.xbmcmail/addon.py", line 308, in <module>
                                                plugin.run()
                                              File "/home/htpc/.xbmc/addons/script.module.xbmcswift2/lib/xbmcswift2/plugin.py", line 332, in run
                                                items = self._dispatch(self.request.path)
                                              File "/home/htpc/.xbmc/addons/script.module.xbmcswift2/lib/xbmcswift2/plugin.py", line 306, in _dispatch
                                                listitems = view_func(**items)
                                              File "/home/htpc/.xbmc/addons/plugin.programm.xbmcmail/addon.py", line 122, in show_mailbox
                                                emails, has_next_page = client.get_emails(mailbox, limit, offset)
                                              File "/home/htpc/.xbmc/addons/plugin.programm.xbmcmail/resources/lib/client.py", line 104, in get_emails
                                                } for (email_id, flags), email in self._fetch_emails_by_ids(email_ids)]
                                              File "/home/htpc/.xbmc/addons/plugin.programm.xbmcmail/resources/lib/client.py", line 215, in <genexpr>
                                                for status, header in data
                                              File "/home/htpc/.xbmc/addons/plugin.programm.xbmcmail/resources/lib/client.py", line 232, in __parse_fetch_response
                                                email_id, flags_str = self.re_fetch_response.match(line).groups()
                                            AttributeError: 'NoneType' object has no attribute 'groups'
                                            -->End of Python script error report<--


I am running Arch Linux with Python version 2.7.8-1 and XBMC 13.1-3.

Has anyone encountered this before and is there a fix for it?

Thanks.
Reply
#2
You probably want to post in the relevant add-on thread.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#3
Oh ok.... just thought it was better to start a new thread related to the issue.

Np though will just re-post :-)
Reply

Logout Mark Read Team Forum Stats Members Help
Error in MAIL addon...0
This forum uses Lukasz Tkacz MyBB addons.