•   
  • 1
  • 16
  • 17
  • 18(current)
  • 19
  • 20
  • 24
  •   
Release TheMovieDB TV Show scraper
What he said Smile
Reply
Thank you both!
For troubleshooting and bug reporting please make sure you read this first.
Reply
(2018-11-22, 15:27)axlt2002 Wrote:
(2018-11-22, 11:40)scudlee Wrote: If you look in the addon.xml for metadata.tvdb.com, you'll see a part that says  cachepersistence="00:15".  Try adding that to the equivalent spot in the addon.xml for metadata.tvshows.themoviedb.org.  (You will need to stop and restart Kodi.) 
@scudlee thanks a lot for this further suggestion! Now everything work smoothly and very fast even with parsing nfo files (X-RateLimit-Remaining didn't go lower than 27)!

Are you going to udpate both tmdb.xml and addon.xml so that they will be in the next Kodi 18 nightly? I would even suggest to change the version number of the addon to 3.1.0.

Thanks again you all for the support!   

Hi @axlt2002, I'm sorry to "resurrect" this thread but I'm having your exact issues (continuous error 429 with the TV Show scraper, every time, every day) with Kodi 18.2 and The Movie DB addon v3.1.1. I opened a thread HERE (with the log) before discovering this discussion, because I didn't catch the error at first.

Anyway, should this issue be already solved with v3.1.1? Can you explain, please, how did you fix it?
Reply
Hy,
I've tried to add the following show to the media library:
The End of the F***ing World
(exported from the Netflix addon without touching the original name.)
I can see the .strm file in the export folder but the show doesn't appears in the media library after i update it. I've tried another shows all of them appering in the library but this one.
I think the problem is the *** symbols in the title.
Is there any solution to this?
Thanks!
Urobee
Reply
@urobee

I have not tested the show, but I agree with your conclusion, and the *** will be the cause of the problem.

You have two options...

1. Use a Parsing NFO File to point Kodi to the show... https://kodi.wiki/view/NFO_files#Parsing_nfo
2. Use one of the listed Alternate titles for the show...
Image
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
(2019-07-05, 00:53)Karellen Wrote: @urobee

I have not tested the show, but I agree with your conclusion, and the *** will be the cause of the problem.

You have two options...

1. Use a Parsing NFO File to point Kodi to the show... https://kodi.wiki/view/NFO_files#Parsing_nfo
2. Use one of the listed Alternate titles for the show...
Image

Hy,
I've selected an alternate title and it worked like a dream Smile
Thanks Smile
Reply
Hi, I have issue with ratings. For some series the script doesn't scrape the rating at all and some series have completely wrong value. I tried a clean installation, but it didn't help Sad
Reply
Which ratings - MPAA or User Ratings and Votes?

Which movies or tv shows? Provide the link and tell us what you scrape, but what you expect.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
Sorry. I mean User Ratings and Votes and problem is only with TV Shows.

Series without rating are for example Fortitude (should be 69%), Shetland (77%), Cirkus Bukowski (80%). Series with wrong rating are for example Fargo (should be 83%, Kodi shows 7.4), Band of Brothers (82% x 8.7), Blackadder (79% x 2.0), but it looks like all present ratings are wrong.

I'm using Kodi v18.3 Portable and TMDB scraper v3.1.1.
Reply
@mara.pavelka

Ok, I can confirm your results.

The series Fargo:
Kodi Displays : 7.4 with 10 votes
API returns : 8.3 with 1039 votes

The series Fortitude:
Kodi Displays: Nil
API returns : 6.9 with 117 votes

I do not know the reason for this. The developer @scudlee would need to look into this but he has not been around for a while. Maybe @olympia might know?
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
@mara.pavelka

If ratings are important to you, consider using this add-on... 316342 (thread)

It will scrape IMDB ratings. Just make sure you use v3.5.1 and remember to set IMDB ratings as Default in the settings screen for the add-on.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
Thanks for the tip to this add-on.

I did some resarch and I found where the problem is. In the Get Details API are two pairs of vote_average and vote_count items. First one is for the last aired episode and the other is for series and scraper gets first one.

I changed in the tmdb.xml file in addons/metadata.tvshows.themoviedb.org folder two lines and now it looks like the problem is solved.

Changed line #102 from <expression>&quot;vote_average&quot;Sad[^,]*),</expression> to <expression>&quot;type&quot;.+?&quot;vote_average&quot;Sad[^,]*),</expression>
and line #105 from <expression>&quot;vote_count&quot;Sad[0-9]+)</expression> to <expression>&quot;type&quot;.+?&quot;vote_count&quot;Sad[0-9]+)</expression>
Reply
Sorry, now withous smilies:

Changed line #102 from <expression>&quot;vote_average&quot;:([^,]*),</expression> to <expression>&quot;type&quot;.+?&quot;vote_average&quot;:([^,]*),</expression>
and line #105 from <expression>&quot;vote_count&quot;:([0-9]+)</expression> to <expression>&quot;type&quot;.+?&quot;vote_count&quot;:([0-9]+)</expression>
Reply
@mara.pavelka

Wow, thank you for the fix!! I haven't tested, but I will a bit later in the day Smile

Are you able to submit a PR on Github? https://github.com/xbmc/repo-scrapers
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
@Karellen 

PR submitted.
Reply
  •   
  • 1
  • 16
  • 17
  • 18(current)
  • 19
  • 20
  • 24
  •   
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
TheMovieDB TV Show scraper52