•   
  • 1
  • 44
  • 45
  • 46
  • 47(current)
  • 48
  •   
Release TIDAL music (former WiMP)
@Yomis - the forum language is English only please.

Use of services such as Google Translate is fine if required, although from the rogue font tags above I think you're maybe also which doesn't work so well on this forum.
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

Kodi Blog Posts
Reply
(2022-12-06, 03:21)Yomis Wrote: Hola. Primero da las gracias por el gran trabajo que estás haciendo. Estoy usando Tidal2 en Kodi instalado en Windows 10. Funciona perfectamente pero cuando escucho canciones de Dolby Atmos el volumen es muy bajo. ¿No le pasa a nadie más? He probado a cambiar de dispositivo pero en todos pasa lo mismo
Hi @Yomis

The tracks marked as "Dolby Atmos" are played as "Dolby Digital 5.1" because the "real" Dolby Atmos uses the Dolby-AC4 codec which is not playable with Kodi yet.
The sound level of this Dolby Digital streams is very low.
Reply
OK, thanks for the answer and sorry for the previous message, I did something wrong when copying the translation
Reply
Hello
Kodi is crashing after a few tracks and i dont know why.
Can someone help me? Here are the logs https://paste.kodi.tv/izanipoqum.kodi
Thank you
Reply
Hello sir. I thin I had gapless before, but I have gaps now, on RPi4 and Tidal. Any advice pleaseM
Reply
(2022-12-11, 11:23)Adriano93 Wrote: Hello
Kodi is crashing after a few tracks and i dont know why.
Can someone help me? Here are the logs https://paste.kodi.tv/izanipoqum.kodi
Thank you
Hi @Adriano93,

the inputstream.ffmpegdirect is the default player in your settings. But the log shows that you get normal http streams. Please try to deactivate the setting "Use inputstream.ffmpegdirect as default player".
see post #673
Reply
(2022-12-12, 23:03)jaybee01 Wrote: Hello sir. I thin I had gapless before, but I have gaps now, on RPi4 and Tidal. Any advice pleaseM
Hi @jaybee01 ,

On my github repository are some tips to solve gapless playback problems: https://github.com/arnesongit/plugin.aud...2/issues/5

Also the deactivatation of the setting "Use inputstream.ffmpegdirect as default player" can solve this, because the inputstream addons are handled as video playback addons.
There is no gapless playback in video mode.
Reply
Hello there!

I’m using the addon with CoreELEC 19.5 in a Odroid N2+.
In the first time I opened it was able to see some tracks being played at 24bit but then something happened and now it plays only at 16bit.
Using Tv Dolby Atmos device type. Music quality is set to MQA.
What might have changed?
Reply
(2022-12-17, 14:48)encryptedbr Wrote: Hello there!

I’m using the addon with CoreELEC 19.5 in a Odroid N2+.
In the first time I opened it was able to see some tracks being played at 24bit but then something happened and now it plays only at 16bit.
Using Tv Dolby Atmos device type. Music quality is set to MQA.
What might have changed?
Hi @encryptedbr,

not all MQA songs are payed with 24bit. Some are 16bit and some 24bit. It can also depend on the selected device type.
A good way to check the bit depth of a stream is to enable the setting "Use inputstream.ffmpegdirect as default player" and check the kod log file.
The inputstream.ffmpegdirect addon logs the codec details like this:
Example for 24bit:
Code:

AddOnLog: inputstream.ffmpegdirect: ffmpeg[AB8D011]:   Duration: 00:03:14.21, start: 0.000000, bitrate: 1658 kb/s
AddOnLog: inputstream.ffmpegdirect: ffmpeg[AB8D011]:   Stream #0:0: Audio: flac, 48000 Hz, stereo, s32 (24 bit)
Example for 16bit:
Code:

AddOnLog: inputstream.ffmpegdirect: ffmpeg[AB8D011]:   Duration: 00:03:20.00, start: 0.000000, bitrate: 0 kb/s
AddOnLog: inputstream.ffmpegdirect: ffmpeg[AB8D011]:   Stream #0:0: Audio: flac (fLaC / 0x43614C66), 44100 Hz, stereo, s16, 550 kb/s (default)
Reply
Hi @arneson, thanks for your support.
I has able to play 24 bit streams by disabling passthrough.
But there's another problem happening with more than 50% of the tracks I try to play.
They simply won't play and fail with the message to verify the log to more information.
In the log I can see the following when trying to play these tracks:


2022-12-18 12:04:19.221 T:3611     INFO <general>: VideoPlayer::OpenFile: plugin://plugin.audio.tidal2/play_track/12070154/12070149
2022-12-18 12:04:19.222 T:4818     INFO <general>: Creating InputStream
2022-12-18 12:04:19.224 T:4818     INFO <general>: AddOnLog: inputstream.ffmpegdirect: inputstream.ffmpegdirect: OpenStream() - Num Props: 2
2022-12-18 12:04:19.224 T:4818     INFO <general>: AddOnLog: inputstream.ffmpegdirect: inputstream.ffmpegdirect property: inputstream.ffmpegdirect.manifest_type = hls
2022-12-18 12:04:19.224 T:4818     INFO <general>: AddOnLog: inputstream.ffmpegdirect: inputstream.ffmpegdirect property: inputstream.ffmpegdirect.open_mode = ffmpeg
2022-12-18 12:04:19.224 T:4818     INFO <general>: AddOnLog: inputstream.ffmpegdirect: Stream mimetype: application/vnd.apple.mpegurl
2022-12-18 12:04:19.228 T:4818     INFO <general>: AddOnLog: inputstream.ffmpegdirect: OpenWithFFmpeg - IO handled by FFmpeg's AVFormat
2022-12-18 12:04:19.441 T:4813     INFO <general>: Python interpreter stopped
2022-12-18 12:04:24.641 T:4818    ERROR <general>: CVideoPlayer::OpenInputStream - error opening [plugin://plugin.audio.tidal2/play_track/12070154/12070149]
2022-12-18 12:04:24.641 T:4818     INFO <general>: CVideoPlayer::OnExit()
2022-12-18 12:04:24.641 T:4818     INFO <general>: ADDON: Dll Destroyed - Inputstream FFmpeg Direct
2022-12-18 12:04:24.657 T:3611     INFO <general>: CVideoPlayer::CloseFile()
2022-12-18 12:04:24.660 T:3611     INFO <general>: VideoPlayer: waiting for threads to exit
2022-12-18 12:04:24.660 T:3611     INFO <general>: VideoPlayer: finished waiting

Still couldn't solve it.
Reply
verbose log


2022-12-18 12:17:41.432 T:6388     INFO <general>: initializing python engine.
2022-12-18 12:17:42.279 T:6388     INFO <general>: [TIDAL2] GET https://api.tidal.com/v1/tracks/12070154...7ea734ff5f
2022-12-18 12:17:42.280 T:6388     INFO <general>: [TIDAL2] Got stream with soundQuality:LOSSLESS, codec:FLAC
2022-12-18 12:17:42.295 T:6388     INFO <general>: [TIDAL2] Got Dash stream with MimeType: audio/x-flac
2022-12-18 12:17:42.328 T:6388     INFO <general>: [TIDAL2] Using inputstream.ffmpegdirect for HLS playback
2022-12-18 12:17:42.345 T:6388     INFO <general>: [TIDAL2] Playing: http://localhost:5555/manifest.m3u8?data...BEPg%3D%3D with MimeType: audio/x-flac
2022-12-18 12:17:42.349 T:6388     INFO <general>: CPythonInvoker(11, /storage/.kodi/addons/plugin.audio.tidal2/addon.py): script successfully run
2022-12-18 12:17:42.549 T:5937     INFO <general>: ADDON: Dll Destroyed - Spectrum
2022-12-18 12:17:42.558 T:5937     INFO <general>: VideoPlayer::OpenFile: plugin://plugin.audio.tidal2/play_track/12070154/12070149
2022-12-18 12:17:42.561 T:6393     INFO <general>: Creating InputStream
2022-12-18 12:17:42.562 T:6393     INFO <general>: AddOnLog: inputstream.ffmpegdirect: inputstream.ffmpegdirect: OpenStream() - Num Props: 2
2022-12-18 12:17:42.562 T:6393     INFO <general>: AddOnLog: inputstream.ffmpegdirect: inputstream.ffmpegdirect property: inputstream.ffmpegdirect.manifest_type = hls
2022-12-18 12:17:42.562 T:6393     INFO <general>: AddOnLog: inputstream.ffmpegdirect: inputstream.ffmpegdirect property: inputstream.ffmpegdirect.open_mode = ffmpeg
2022-12-18 12:17:42.562 T:6393     INFO <general>: AddOnLog: inputstream.ffmpegdirect: Stream mimetype: application/vnd.apple.mpegurl
2022-12-18 12:17:42.563 T:6393     INFO <general>: AddOnLog: inputstream.ffmpegdirect: OpenWithFFmpeg - IO handled by FFmpeg's AVFormat
2022-12-18 12:17:42.574 T:6388     INFO <general>: Python interpreter stopped
2022-12-18 12:17:47.750 T:6393    ERROR <general>: CVideoPlayer::OpenInputStream - error opening [plugin://plugin.audio.tidal2/play_track/12070154/12070149]
2022-12-18 12:17:47.750 T:6393     INFO <general>: CVideoPlayer::OnExit()
2022-12-18 12:17:47.750 T:6393     INFO <general>: ADDON: Dll Destroyed - Inputstream FFmpeg Direct
2022-12-18 12:17:47.762 T:5937     INFO <general>: CVideoPlayer::CloseFile()
2022-12-18 12:17:47.765 T:5937     INFO <general>: VideoPlayer: waiting for threads to exit
2022-12-18 12:17:47.765 T:5937     INFO <general>: VideoPlayer: finished waiting
Reply
@encryptedbr please stop posting logs directly into the thread.

Did you not see the big red text above the "post reply" that states "Do not post logs in the forum. Use https://paste.kodi.tv/ instead." ?

Many thanks.
Always read the Wiki, FAQ and search the forum before posting.
Read/follow the forum rules.
Reply
Sorry, haven't seen.
Will stop and use paste.kodi from now on
Reply
@arneson had to change the decive type to automotive dolby atmos and now everything is working.
Reply
Hello everyone,

I'm new here and in my search for the best way to use Tidal, after a lot of trying and reading I ended up on this forum.
Now I have installed Tidal on Coreelec - Matrix 19.5 as described here and it works so far - even with Premium plus registration.

My problem is, that on my IFI Zen DAC V2 all songs that arrived under Android Tidal App as Original Sample Rate (purple) or USB Audio Player Pro (MQA Studio - blue) now arrive as PCM 44.1/48kHz (yellow). As I write this, one song was recognized as MQA (green) and another (not MQA) could not be played - but others that weren't MQA's were. I think I'm on the right track, but the finer points are still missing. Hope there is a solution and someone to show me the way.

I'm really excited about the support here
Reply
  •   
  • 1
  • 44
  • 45
  • 46
  • 47(current)
  • 48
  •   



Logout Mark Read Team Forum Stats Members Help
TIDAL music (former WiMP)8
This forum uses Lukasz Tkacz MyBB addons.