• 1
  • 44
  • 45
  • 46(current)
  • 47
  • 48
  • 81
Release Experimental Google Music Addon
(2016-04-07, 19:44)jmh2002 Wrote: Just a reminder for new users, it's against the forum rules to post logs, or snippets of logs directly. Please edit your posts.

See here: http://kodi.wiki/view/Debug_log

Do NOT post your logs directly in a forum. Always use a paste site like pastebin.com or xbmclogs.com. Post the link to your pasted log in the forum.

Aha, sorry, weird rule... gimme a sec. Done, Smile

D.
Reply
(2016-04-07, 19:35)DaLanik Wrote: I'm getting errors, no matter what version I use. I tried 1.81, 1.82, 1.8 and even 1.72, always error. Here is the log with 1.8.2, something to do with database if I understand correctly:

google music
Your error seems to be related to database cache corrupted, could you try to 'Clear Cache' in addon settings.
Reply
(2016-04-07, 13:23)icekiss Wrote: EDIT: Just read further up on this page that the plugin appends @gmail.com to the username. I input my complete email address as my username. If the plugin appended @gmail.com to that (resulting in [email protected]@gmail.com), then it obviously won't work. However, that error does not look like an authentication problem to me. And I would expect an authentication problem to be reported in the GUI, without having to dig into log files...
I am at work atm, so It'll be a few hours before I can test changing my username.
Not an authentication problem, it's a bug caused by missing track not expected in code.
Probably you have an empty playlist, try adding some songs, I'll prepare a fix for next version.
Reply
(2016-04-07, 20:20)foreverguest Wrote:
(2016-04-07, 19:35)DaLanik Wrote: I'm getting errors, no matter what version I use. I tried 1.81, 1.82, 1.8 and even 1.72, always error. Here is the log with 1.8.2, something to do with database if I understand correctly:

google music
Your error seems to be related to database cache corrupted, could you try to 'Clear Cache' in addon settings.

I tried that.... removed everything.. no go. Same error.
Reply
(2016-04-07, 20:58)DaLanik Wrote:
(2016-04-07, 20:20)foreverguest Wrote:
(2016-04-07, 19:35)DaLanik Wrote: I'm getting errors, no matter what version I use. I tried 1.81, 1.82, 1.8 and even 1.72, always error. Here is the log with 1.8.2, something to do with database if I understand correctly:

google music
Your error seems to be related to database cache corrupted, could you try to 'Clear Cache' in addon settings.

I tried that.... removed everything.. no go. Same error.

Could you try version 1.7 below, there was a change in the cache for posterior versions.
https://app.box.com/s/i8l3bwpd5a2tq1f16elnyrkhocpcsiws

Also if you could share your Android version/device, I may track compatible versions.
Reply
(2016-04-07, 20:29)foreverguest Wrote:
(2016-04-07, 13:23)icekiss Wrote: EDIT: Just read further up on this page that the plugin appends @gmail.com to the username. I input my complete email address as my username. If the plugin appended @gmail.com to that (resulting in [email protected]@gmail.com), then it obviously won't work. However, that error does not look like an authentication problem to me. And I would expect an authentication problem to be reported in the GUI, without having to dig into log files...
I am at work atm, so It'll be a few hours before I can test changing my username.
Not an authentication problem, it's a bug caused by missing track not expected in code.
Probably you have an empty playlist, try adding some songs, I'll prepare a fix for next version.

Yep, that was it. Your Plugin now works! Rofl
Thanks a bunch for your fast and pinpoint response! *bows*
Reply
Login Credential Errors...

Pastebin: http://pastebin.com/ycGnh5aZ

Windows 10 machine
Fresh install Kodi 16.2 RC2
Google music FREE
Working on my NVIDIA shield
Tried latest version and rolled back to 1.7 (what is on my nvidia)
2-Factor OFF
Less Secure APps ON

So the login should be as simple as posslb.e

Tried to delete the @gmail.com also (post from earlier)

Any ideas??
Reply
(2016-04-07, 21:29)foreverguest Wrote: Could you try version 1.7 below, there was a change in the cache for posterior versions.
https://app.box.com/s/i8l3bwpd5a2tq1f16elnyrkhocpcsiws

Also if you could share your Android version/device, I may track compatible versions.

Not working. Same error:

Quote: Error Type: <class 'sqlite3.OperationalError'>
Error Contents: no such table: songs

Android is 5.1, device is MQX Pro Amlogic S905

Thanx for your help! Funny is that it was working... I am not sure whether it stopped working after update.... could be I switched off tvbox w/o shutting down Kodi properly or something? Hm...

D.
Reply
I was looking forward to having this addon work.

The addon gives an error "Google Music EXP Error. Check the log for more information." on trying to play anything. The google account email address is set, and a application password is set due to two factor auth. This is on xbian on a raspberry pi2, fully updated as of yesterday. Network connection is wireless and stable.

Logs are at http://xbmclogs.com/phfcmxwnx. Hopefully the messages like the python exceptions in there are a clue.
Reply
I think everyone had issue. O have A pastebin up on a Windows machine same error - few posts above


Sent from my iPhone
Reply
(2016-04-10, 17:44)view Wrote: I was looking forward to having this addon work.

The addon gives an error "Google Music EXP Error. Check the log for more information." on trying to play anything. The google account email address is set, and a application password is set due to two factor auth. This is on xbian on a raspberry pi2, fully updated as of yesterday. Network connection is wireless and stable.

Logs are at http://xbmclogs.com/phfcmxwnx. Hopefully the messages like the python exceptions in there are a clue.

From your log I see you are a FREE user. I'm working on a version that works with free radio stations. For now we only support uploaded songs or subscribers.
Reply
(2016-04-08, 18:22)DaLanik Wrote: Not working. Same error:

Quote: Error Type: <class 'sqlite3.OperationalError'>
Error Contents: no such table: songs

Android is 5.1, device is MQX Pro Amlogic S905

Thanx for your help! Funny is that it was working... I am not sure whether it stopped working after update.... could be I switched off tvbox w/o shutting down Kodi properly or something? Hm...

D.

For some unknown reason the addon is not able to create the cache database.
It should be created in path '/Android/data/org.xbmc.kodi/files/.kodi/userdata/Database' with name 'googlemusic.db'.
Check if the file exists and manually delete it. If it don't exists you could try to run the addon in another device/computer and transfer the file created.
Reply
(2016-04-11, 05:31)foreverguest Wrote: For some unknown reason the addon is not able to create the cache database.
It should be created in path '/Android/data/org.xbmc.kodi/files/.kodi/userdata/Database' with name 'googlemusic.db'.
Check if the file exists and manually delete it. If it don't exists you could try to run the addon in another device/computer and transfer the file created.

It's OK after I installed v1.7.. It didn't work straight away but after reboot... Thanx!
Reply
(2016-04-11, 04:18)foreverguest Wrote:
(2016-04-10, 17:44)view Wrote: I was looking forward to having this addon work.

The addon gives an error "Google Music EXP Error. Check the log for more information." on trying to play anything. The google account email address is set, and a application password is set due to two factor auth. This is on xbian on a raspberry pi2, fully updated as of yesterday. Network connection is wireless and stable.

Logs are at http://xbmclogs.com/phfcmxwnx. Hopefully the messages like the python exceptions in there are a clue.

From your log I see you are a FREE user. I'm working on a version that works with free radio stations. For now we only support uploaded songs or subscribers.


When did you make this change? Was working a few months back with 1.7. I do have songs uploaded maybe that is why?

I was going to do a trial of YouTube red that includes music - will see if that fixes it
Reply
Is there a way to update the google libary manualy because i set it to do by the hour but i use kodi with the emby for kodi plugin so the libary is maintained by that, if i am in the google playmusic in kodi the update libary is grayout and i cannot push it? Im on the latest version of the google plugin and kodi 16.1 rc2
Reply
  • 1
  • 44
  • 45
  • 46(current)
  • 47
  • 48
  • 81

Logout Mark Read Team Forum Stats Members Help
Experimental Google Music Addon17
This forum uses Lukasz Tkacz MyBB addons.