•   
  • 1
  • 72
  • 73
  • 74(current)
  • 75
  • 76
  • 78
  •   
Release Experimental Google Music Addon
I would love to use this - one question though, can you upload to GPM using this?
Reply
(2019-03-27, 03:49)tantrum080 Wrote: I would love to use this - one question though, can you upload to GPM using this?

No, uploads not implemented.
Reply
Can I suggest it to be added if possible, I only have a droid devices so can not upload music to GPM as they only let you do this from a pc - wired how you can't do it with android - even if I change any browser to desktop mode it's impossible as it just does not work. I have no pc so - seems there's no way to get my music from my Nvidia shield or s7 to upload to GPM without a pc of somesort.
Reply
I can't find the option to Add my albums to my internal Kodi Library - thats what I was really hoping for with this addon... can anyone help?
Reply
(2019-03-29, 14:56)starslayer74 Wrote: I can't find the option to Add my albums to my internal Kodi Library - thats what I was really hoping for with this addon... can anyone help?

Sorry, this is not possible in Kodi.
Reply
Tried 1.12 on LibreElec 9.0.1 but seems like python is missing something there:
yayofukipi.kodi (paste)
Reply
(2019-03-29, 23:59)doucettom Wrote: Tried 1.12 on LibreElec 9.0.1 but seems like python is missing something there:
yayofukipi.kodi (paste)
Module lib2to3 come installed in Kodi python in Windows and on my python-2.7 in Debian, don't now why it is not available in LibreElec.
Reply
(2019-03-30, 04:34)foreverguest Wrote:
(2019-03-29, 23:59)doucettom Wrote: Tried 1.12 on LibreElec 9.0.1 but seems like python is missing something there:
yayofukipi.kodi (paste)
Module lib2to3 come installed in Kodi python in Windows and on my python-2.7 in Debian, don't now why it is not available in LibreElec.

I opened a thread on LibreELEC forum :
https://forum.libreelec.tv/thread/14994-...music-exp/
Reply
It used to work with former versions, seems like 1.12 started to claim lib2to3, I guess for compatibility with future python3 kodi releases (kodi 19)
Reply
(2019-03-31, 15:02)doucettom Wrote: It used to work with former versions, seems like 1.12 started to claim lib2to3, I guess for compatibility with future python3 kodi releases (kodi 19)

Actually it was because gmusicapi module started supporting oauth2 for login and I included its dependencies.
You can keep using version 1.11.1 if it was working for you, but I'm afraid these new dependencies will be necessary for new releases.
Reply
(2019-03-31, 15:02)doucettom Wrote: It used to work with former versions, seems like 1.12 started to claim lib2to3, I guess for compatibility with future python3 kodi releases (kodi 19)
Just unpack this file (it contains lib2to3 from the Python 2.7) into "/storage/.kodi/addons/script.module.future/libs/". It solved same issue for me on CoreElec 9.0.1 Blush
Reply
(2019-04-05, 17:15)vevs Wrote:
(2019-03-31, 15:02)doucettom Wrote: It used to work with former versions, seems like 1.12 started to claim lib2to3, I guess for compatibility with future python3 kodi releases (kodi 19)
Just unpack this file (it contains lib2to3 from the Python 2.7) into "/storage/.kodi/addons/script.module.future/libs/". It solved same issue for me on CoreElec 9.0.1 Blush 
Thanks! That worked for me  Cool Hopefully libreelec soon includes this.
Reply
How to get rid of invalid credentials or connectivity problem?
Reply
Please try this test version with oauth authentication (like youtube addon):
https://app.box.com/s/lb9wu4bmfsse3zgdfekgc2it9e50qvru
Reply
EDIT: I got 1.12 to work by removing the generated password from my Google Account and creating a new one and relinking the app. All is good now.

(2019-04-10, 23:14)foreverguest Wrote: Please try this test version with oauth authentication (like youtube addon):
https://app.box.com/s/lb9wu4bmfsse3zgdfekgc2it9e50qvru

There's not even a log-in in that beta's settings. I only have 4 options. Auto-update library, stream quality, yt quality and Pre-fetch.

And the usual debug settings.

The addon errors out on launch. Then again, it doesn't know my account at all, so I guess that's understandable. Or is it because it no longer supports Kodi 17?

I have to use 17 cause of MadVR and DSplayer. Smile
Reply
  •   
  • 1
  • 72
  • 73
  • 74(current)
  • 75
  • 76
  • 78
  •   
 
Thread Rating:
  • 16 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Experimental Google Music Addon516