•   
  • 1
  • 7
  • 8
  • 9(current)
  • 10
  • 11
  • 81
  •   
Release Experimental Google Music Addon
If I search for an artist I'll see the top songs and then the folders for the album's. When I go to the album nothing will load up. Just blank.
Reply
Also just wondering. How difficult would it be to setup an option in the context menu to send to another device? Like my tablet I can do the press and hold select play to and itll tell another device on my network to play it. Would this be something easily done or no? I'd think obviously both devices would need the plugin installed and configured with the credentials. I'd really like if google play noticed our xbmc with no hassle but that's just me dreaming.
Reply
(2014-11-28, 21:28)dexdeadly Wrote: If I search for an artist I'll see the top songs and then the folders for the album's. When I go to the album nothing will load up. Just blank.

Please check the log after you enter the album folder for any errors.

(2014-11-30, 09:15)dexdeadly Wrote: Also just wondering. How difficult would it be to setup an option in the context menu to send to another device? Like my tablet I can do the press and hold select play to and itll tell another device on my network to play it. Would this be something easily done or no? I'd think obviously both devices would need the plugin installed and configured with the credentials. I'd really like if google play noticed our xbmc with no hassle but that's just me dreaming.

Indeed it would be useful, I really don't know if it is possible. Never heard of an addon that could do this, if you do let me know.

Maybe we can send to another XBMC instance with the same addon installed and web interface enabled, but we would need to have it pre-configured with address and user/pass.
Reply
I'll check the error logs in a moment I haven't had a free moment. Now as far as the sharing goes. Right now with the yatse remote and probably the official remote as well. Anything I'm in that has a share button the option for send to xbmc is available. From what I can tell with say YouTube it will send the URL to xbmc and then xbmc sees its a YouTube URL and will launch the plugin and play the video. My wife and I do this all day with Minnie, paw patrol, Elmo and other kid shows for my daughter. Its flawless. My thinking is maybe it can work in a similar fashion? When the URL is sent to xbmc the plugin can load and play the URL coming through? I can try and look at the YouTube module and see if I can see how this is happening. If you'd like I can try and do this and test with you.
Reply
Here is what I got in the error log.

22:31:20 T:2528130128 NOTICE: -->Python Interpreter Initialized<--
22:31:20 T:2528130128 NOTICE: GoogleMusicEXP-1.2 ARGV: ['plugin://plugin.audio.googlemusic.exp/', '23', '?path=search_result&query=Abominationz%20(Monoxide)%20Twiztid']
22:31:24 T:2528130128 NOTICE: [GoogleMusicEXP-1.2] Loading auth from cache
22:31:26 T:2528130128 ERROR: /storage/.xbmc/addons/script.module.requests/lib/requests/packages/urllib3/connectionpool.py:730: InsecureRequestWarning: Unverified HTTPS request is being made. Adding certificate verification is strongly advised. See: https://urllib3.readthedocs.org/en/latest/security.html (This warning will only appear once by default.)
InsecureRequestWarning)
22:31:26 T:2561684560 NOTICE: Thread BackgroundLoader start, auto delete: false
Reply
(2014-12-02, 05:07)dexdeadly Wrote: I'll check the error logs in a moment I haven't had a free moment. Now as far as the sharing goes. Right now with the yatse remote and probably the official remote as well. Anything I'm in that has a share button the option for send to xbmc is available. From what I can tell with say YouTube it will send the URL to xbmc and then xbmc sees its a YouTube URL and will launch the plugin and play the video. My wife and I do this all day with Minnie, paw patrol, Elmo and other kid shows for my daughter. Its flawless. My thinking is maybe it can work in a similar fashion? When the URL is sent to xbmc the plugin can load and play the URL coming through? I can try and look at the YouTube module and see if I can see how this is happening. If you'd like I can try and do this and test with you.

I have read in thread somewhere that Yatse call Youtube addon on XBMC, so it should be done in Yatse side.
Reply
I'll reach out to them. How about the error I posted.
Reply
(2014-12-02, 20:40)dexdeadly Wrote: I'll reach out to them. How about the error I posted.

I don't have a clue about it, I'll try to do some tests and some research about this error maybe something pops out.
Reply
There is a URL in the error I read that says its missing the SSL information but I would think you'd have done that already considering you can play the initial files. I wish I knew more python to try and help more. I'm reading what I can.
Reply
OK spoke with Yatse team and he said he would need to know what needs sent. Also though he asked if this was an official add on. So I don't know if that would stop this from getting done.
Reply
FYI, I was having trouble getting this to work. I could see all my albums but nothing would play, it would just say "Opening Stream" it would fail and loop until I hit cancel. Then I installed the official on my iPhone to use AirPlay. I got a message that I had too many devices registered and I could not add the phone till I unregistered some. I found I had some old windows machine in there and removed a few. NOTE: You can only remove 4 devices a year!
Anyway, went back to XBMC and launched Google Play EXP and everything played great!
Thanks for this AddOn!
P.S. The Icon, not so great.
Reply
(2014-12-02, 23:34)dexdeadly Wrote: OK spoke with Yatse team and he said he would need to know what needs sent. Also though he asked if this was an official add on. So I don't know if that would stop this from getting done.

It should send this kind of url: 'plugin://plugin.audio.googlemusic.exp/?action=play_song&song_id=XXXXXXXXXX'
It is not official. But if it means being available in a official repository, we can try to submit it for inclusion.
Reply
(2014-12-03, 00:10)Distearth Wrote: FYI, I was having trouble getting this to work. I could see all my albums but nothing would play, it would just say "Opening Stream" it would fail and loop until I hit cancel. Then I installed the official on my iPhone to use AirPlay. I got a message that I had too many devices registered and I could not add the phone till I unregistered some. I found I had some old windows machine in there and removed a few. NOTE: You can only remove 4 devices a year!
Anyway, went back to XBMC and launched Google Play EXP and everything played great!
Thanks for this AddOn!
P.S. The Icon, not so great.

Thanks for your feedback, I'll add a note about this in troubleshooting.
About the icon, I agree with you. I choose it because it was freely available and was part of a favorite desktop theme I use. If you know an artist that could contribute a better icon, please let me know.
Reply
I am not much of a graphic artist but would like to try and do somequick renders. If I get a chance the the next day or 2 I'll send them over.
Reply
A quick draft of an icon. You can have it. If you want something special, let me know. https://drive.google.com/file/d/0B4OmbKN...sp=sharing
Reply
  •   
  • 1
  • 7
  • 8
  • 9(current)
  • 10
  • 11
  • 81
  •   



Logout Mark Read Team Forum Stats Members Help
Experimental Google Music Addon17
This forum uses Lukasz Tkacz MyBB addons.