•   
  • 1
  • 68
  • 69
  • 70
  • 71
  • 72(current)
Release -  Experimental Google Music Addon
(2019-02-05, 10:41)etchings13 Wrote: I don't know if this is helpful but this plug-in still works for me in Kodi 17.6. That includes radio stations but not "I'm Feeling Lucky". After recently upgrading (I tried a clean install as well) to 18.0, I lost everything except my uploaded songs, so I ended up downgrading back to 17.6 and it works as it did before. I just wanted to mention this in case people were thinking it was Google causing the radio issues when the problem might actually be Kodi 18.0.

I've been running 18 since the Alphas and have few issues with the Addon - except for Feeling Lucky and the preset Radios (as opposed to "start radio" on a song which still works).
Reply
(2018-12-31, 17:08)jmh2002 Wrote: I think google might have changed something to fix this. I haven't made any changes since it was 'broken', I don't have a widget, but I just tried to access my music and things seemed to be working normally again (I didn't check every feature but I can access my library and play music) Smile

On 17.6 everything is still working for me including stations and I'm feeling lucky.
If I have helped you or increased your knowledge please click the 'Thumb Up - Like' button to show me your appreciation :)

For YouTube questions see the OFFICIAL THREAD, with the Latest Info in Post 1 & 2, & the Personal API Key Instructions and FAQ in Posts 3 & 4 & more ;)
Reply
(2019-02-06, 19:09)jmh2002 Wrote:
(2018-12-31, 17:08)jmh2002 Wrote: I think google might have changed something to fix this. I haven't made any changes since it was 'broken', I don't have a widget, but I just tried to access my music and things seemed to be working normally again (I didn't check every feature but I can access my library and play music) Smile

On 17.6 everything is still working for me including stations and I'm feeling lucky. 
Oh, that's interesting. I might try them again tonight on 18 final and check what the error is in the logs.
Reply
(2019-02-07, 06:53)Abbaskip Wrote:
(2019-02-06, 19:09)jmh2002 Wrote:
(2018-12-31, 17:08)jmh2002 Wrote: I think google might have changed something to fix this. I haven't made any changes since it was 'broken', I don't have a widget, but I just tried to access my music and things seemed to be working normally again (I didn't check every feature but I can access my library and play music) Smile

On 17.6 everything is still working for me including stations and I'm feeling lucky.  
Oh, that's interesting. I might try them again tonight on 18 final and check what the error is in the logs. 
That'd be awesome, this is the only plug-in preventing me from updating to 18.
Reply
No idea what's causing it unfortunately. Tried debug logs, but still had no idea. Will have to leave to someone more clued in with Kodi than me
Reply
Does anyone know when the Google Music service will officially end their support (fully migrating to YouTube Music)?
Reply
I have a test version available, please check if the problems are present with it too.

Download link: https://app.box.com/s/m3wxz9rk9jnj123ohgeouu9kn8w3e2fa
Reply
(2019-02-08, 20:16)foreverguest Wrote: I have a test version available, please check if the problems are present with it too.

Download link: https://app.box.com/s/m3wxz9rk9jnj123ohgeouu9kn8w3e2fa

Does this also have the couple of pulls I submitted (and were merged) on the github?
Reply
(2019-02-08, 20:16)foreverguest Wrote: I have a test version available, please check if the problems are present with it too.

Download link: https://app.box.com/s/m3wxz9rk9jnj123ohgeouu9kn8w3e2fa

I'm feeling lucky is fixed, however listen now and browse stations (preset radios) still lead to a crash. I get as far as all the stations, select one to play, it spins a while like it's loading then crashes.
Reply
Do you see any error message on log before crash? Which OS are you using?
Reply
Ok, I was able to reproduce the crash.

Try new version below:
https://app.box.com/s/hw41fz8aam6ulekogg7vmebq863vxx7q
Reply
(2019-02-11, 18:38)foreverguest Wrote: Do you see any error message on log before crash? Which OS are you using?

I'll check the new version tonight, and if it crashes I'll upload a debug log. Using latest Kodi on Windows 10 btw.

But no message. From memory it was creating the radio (adding all the songs to the playlist), and as it goes to play the first song it crashes.

So you get a loading circle whilst it's creating the radio, then just crash.

Anyway, I'll test the new version and see how I go.
Reply
Ok, unfortunately still not working for Listen Now Radio stations (or I'm using Browsing Radios by genre etc).

Logs here:
qekuxuyega.kodi (paste)

Using Windows 10 and Kodi 18.

Here is another log, after changing to Estuary Skin (I noticed all the skin helper stuff, so thought maybe going to Estuary would help that, as I was using Titan MOD - then realise whilst Skin Helper was still running that was pointless anyway), and using Browse Radios, rather than Listen Now Radios:
rogetewuka.kodi (paste)

Funny enough, it doesnt seem to be all Listen Now radios, only some. I tried running some from my homescreen widget, the first worked, the second didn't:
buzetosoti.kodi (paste)
Edit: just realised this last point is incorrect. It works for Albums suggested in Listen Now, but not Radios. So definitely a preset Radio issue.

Let me know if there are any scenarios you'd like me to run through to recreate.
Reply
  •   
  • 1
  • 68
  • 69
  • 70
  • 71
  • 72(current)
 
Thread Rating:
  • 16 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Experimental Google Music Addon516