•   
  • 1
  • 216
  • 217
  • 218(current)
  • 219
  • 220
  • 258
  •   
  Thread Closed
Release -  YouTube (IMPORTANT - READ FIRST POST)
(2016-02-18, 14:11)hanfgnu2k Wrote: I'm trying to be independent from any old API keys, so I wanted to also change the "youtube-tv" key in login_client.py to the new private one I already used for "youtube-for-kodi-xx" (15 in my case).

However the "My Subscriptions" view, which uses the "youtube-tv" key in its request, stays empty. Digging around a bit in the code it seems this view uses another kind of request (v1), and results in an error 403 (forbidden) when using the same key used in "youtube-for-kodi-xx".

Does anyone know what kind of API key or client auth (or combination of it?) I have to create in the Google Developer Console to make this request also work?

Quoting myself from 10 or so pages back. This is actually related to all the people having trouble with their own keys and "My Subscriptions" not working.

The "youtube-tv" key seems to be different from the others and an API v3 key does not seem to work here. So if we could find out what kind of key is used there, we could use our own keys and "My Subscriptions" will still work.

I personally still use bromix's key for "youtube-tv" for the time being.
Thanks a million to who ever fixed this - I was lost without it!

For the record the only thing that worked for me was to uninstall, delete the locally stored YouTube folder as described a few posts back, reboot and then reinstall.

My subscriptions us working ad usual again.

I owe someone a beer
On RPi2 / Isengard / OSMC

Mine updated to 5.1.15d. I found that after it upgraded, I was able to change the follow section's API keys, client IDs, and Secrets with my own that I created on https://console.developers.google.com/apis. Doing so, fixed accessing "Popular", "My Channel" Etc... now are working:

1. youtube-quota
2. osmc-kodi15 (or whatever version you are using)
3. osmc-fallback
4. youtube-tv

Adding your own keys in those sections, along with the additional keys that were added to the script should get everything working nicely.
(2016-02-22, 23:07)jdf76 Wrote: Hi guys,

I've noitced that when you uninstall the youtube plug-in the addon_data stays around

You need to make sure you remove the userdata/addon_data/plugin.video.youtube folder then you should be able to restart youtube setup from scratch.

Jeff

mmmmmmmmmm..... you thinks you can help whit my problems whit bookmark on home ? where's all path used by youtube app ?? i can do a search like ls *youtube* on / by ssh access for find better ?
...only on your "little world" can you lay down the law...
(2016-02-23, 01:16)hanfgnu2k Wrote:
(2016-02-18, 14:11)hanfgnu2k Wrote: I'm trying to be independent from any old API keys, so I wanted to also change the "youtube-tv" key in login_client.py to the new private one I already used for "youtube-for-kodi-xx" (15 in my case).

However the "My Subscriptions" view, which uses the "youtube-tv" key in its request, stays empty. Digging around a bit in the code it seems this view uses another kind of request (v1), and results in an error 403 (forbidden) when using the same key used in "youtube-for-kodi-xx".

Does anyone know what kind of API key or client auth (or combination of it?) I have to create in the Google Developer Console to make this request also work?

Quoting myself from 10 or so pages back. This is actually related to all the people having trouble with their own keys and "My Subscriptions" not working.

The "youtube-tv" key seems to be different from the others and an API v3 key does not seem to work here. So if we could find out what kind of key is used there, we could use our own keys and "My Subscriptions" will still work.

I personally still use bromix's key for "youtube-tv" for the time being.

(2016-02-23, 03:36)kgoerbig Wrote: On RPi2 / Isengard / OSMC

Mine updated to 5.1.15d. I found that after it upgraded, I was able to change the follow section's API keys, client IDs, and Secrets with my own that I created on https://console.developers.google.com/apis. Doing so, fixed accessing "Popular", "My Channel" Etc... now are working:

1. youtube-quota
2. osmc-kodi15 (or whatever version you are using)
3. osmc-fallback
4. youtube-tv

Adding your own keys in those sections, along with the additional keys that were added to the script should get everything working nicely.

I have two questions for you, first, is your "My Subscriptions" page working with your current setup? And if so my second question is related to hanfgnu2k's post above yours which I also quoted here asking which Google API's you have activated since the Youtube v3 API alone doesn't seem to work for My Subscriptions for many of us here.

Thanks for any help you can give me with this issue.
(2016-02-23, 01:54)Alfreado Wrote: Thanks a million to who ever fixed this - I was lost without it!

For the record the only thing that worked for me was to uninstall, delete the locally stored YouTube folder as described a few posts back, reboot and then reinstall.

My subscriptions us working ad usual again.

I owe someone a beer
I did the same but the "My Subscriptions" doesn't work. Using the "subscriptions" selection isn't the same because there you get all the channels while in the "My subscriptions" you only get the updates from your channels (which is the most useful for me)
(2016-02-22, 20:22)jdf76 Wrote: Unfortunately i don't have an Google android device. I only have the Amazon FireTV. Since that was based on the same apk as the android i assumed it would install in the same location.

Here is what i have
....

. I hope this helps, but if it doesn't i apologize for not being able to help you any more.

Thanks
Jeff

No, thank you dude, no reason to apologize.

We are talking about the same thing, it's simply that on your setup, it doesn't appear you've setup unique profiles as I have.

I follow you now.

ALTHOUGH, the only thing I had to do on my Kodi-auto-updated YT version (5.1.17) was to logout, restart, log back in and everything began working, except the one category, "Live".

HOWEVER today, I am getting "Bad Request" again upon "Search" and have to repeat my command multiple times to get it to go through.

Again, only "Live" doesn't work at all ("Project marked for deletion"), *AND*
"My Subscriptions" does work fine for me in this scenario.

I would like to know, where I could download a copy of 5.1.16 so perhaps I can start fresh and make my own keys.

For some reason, there's no "Rollback" available on *any* of my addons-- don't know why.
(2016-02-23, 01:16)hanfgnu2k Wrote:
(2016-02-18, 14:11)hanfgnu2k Wrote: I'm trying to be independent from any old API keys, so I wanted to also change the "youtube-tv" key in login_client.py to the new private one I already used for "youtube-for-kodi-xx" (15 in my case).

However the "My Subscriptions" view, which uses the "youtube-tv" key in its request, stays empty. Digging around a bit in the code it seems this view uses another kind of request (v1), and results in an error 403 (forbidden) when using the same key used in "youtube-for-kodi-xx".

Does anyone know what kind of API key or client auth (or combination of it?) I have to create in the Google Developer Console to make this request also work?

Quoting myself from 10 or so pages back. This is actually related to all the people having trouble with their own keys and "My Subscriptions" not working.

The "youtube-tv" key seems to be different from the others and an API v3 key does not seem to work here. So if we could find out what kind of key is used there, we could use our own keys and "My Subscriptions" will still work.

I personally still use bromix's key for "youtube-tv" for the time being.

If only subscription shows and error notify "API is not enough...", API key is not enabled using Youtube API.
There is a links for youtube on first left-side menu page.

Image
The problem for me is that I can't uninstall Youtube cause it is connected with other addons too and Kodi refuses to uninstall it.Is there anything else to do?
Update some generated API keys in script. Hope it helps. kodi 15/16/17 (on my repo, kodi 16/17 only)

https://github.com/rasberryrabbit/plugin...master.zip
(2016-02-23, 09:56)zerocool7545 Wrote: The problem for me is that I can't uninstall Youtube cause it is connected with other addons too and Kodi refuses to uninstall it.Is there anything else to do?
I had to uninstall the addons that used YouTube before I could uninstall YouTube.
(2016-02-23, 11:28)parcel Wrote: Update some generated API keys in script. Hope it helps. kodi 15/16/17 (on my repo, kodi 16/17 only)

https://github.com/rasberryrabbit/plugin...master.zip

Thank you, this worked like a charm.

(2016-02-23, 13:17)striker64 Wrote: I had to uninstall the addons that used YouTube before I could uninstall YouTube.
You can just disable them, much less of a hassle than uninstalling them and then installing them again..
Could someone knowledgeable in the kinds of API keys needed perhaps create a simple python script that walks through the steps to create all the api keys necessary? If possible it could open the Google API url in the right place, tell the user what options to select and then let them paste the generated key back into the terminal.

At the end the python script could spit out a keys.py file containing the correct variable definitions for the keys that could be copied into the youtube plugin directory in kodi, and the main youtube plugin could be modified to try and import this file if it exists.
(2016-02-22, 21:47)blueribb Wrote:
(2016-02-22, 21:29)Heebs Wrote:
(2016-02-22, 20:31)moJinn Wrote: Heebs, here's what you do,

First uninstall the youtube addon in Kodi

Exit Kodi

Download (using firefox or chrome, I checked both and worked) http://offshoregit.com/finalmakerr/Fixed...5.1.17.zip (then move it to your addon folder: C:\Users\*****\AppData\Roaming\Kodi\addons)

Go to your addon_data folder: C:\Users\****\AppData\Roaming\Kodi\userdata\addon_data

Delete the youtube addon file 'plugin.video.youtube'

Startup Kodi

Go in to settings, then addons, then install from zip file and choose the file you downloaded earlier

and from there you should be set (you will have to sign in again and do the two step authentication process)

this is what worked for me (but still no my subscriptions) but for now its better than nothing!

hope that helps

Hello Mojinn

Many thNks for your. Helpful answer...I got as far as e it Kodi after uninstalling YouTube Add on but opening Firefox on my magic tv box linked to my tv and downloading etc is something I am not aware how to do...do I use android on the box...and download onto the box....?

Use a USB Flash Drive. Put the ZIP file on the flash drive and plug it into your box. Access the file from within Kodi. I hope this helps.

Hello All
everyone has been so helpful....as i am using the magictv box connected to my tv for kodi...i downloaded the zip file on usb as instructed ...but when i go into add ons extract from zip file the file is empty in all folders so no extraction can be done as the ok button doesnt light up for me to download.

if anyone can help me with kodi on tv boxes...to get my youtube working again I would be so grateful...
Many thanks
Wink 
(2016-02-19, 00:03)marriol123343 Wrote: 1) Log out
2) uninstall
3) delete folder
4) install
5) Do not start, go to Config Addon and click on Setup-Assistent, start Addon and do the Activation twice.

Everything will work fine if you do it this way.

Thanks Marriol123343 this works for me. Rofl
The activation is done via a web browser with this URL http://youtube.com/activate
REMEMBER Twice (2 times) addon will give a code to activate in browser.


Using it now.... But 1 question How to watch in 1080p? I only see 720p maximum vids.
  •   
  • 1
  • 216
  • 217
  • 218(current)
  • 219
  • 220
  • 258
  •   
  Thread Closed
 
Thread Rating:
  • 20 Vote(s) - 3.9 Average



Logout Mark Read Team Forum Stats Members Help
YouTube (IMPORTANT - READ FIRST POST)3.920