Win How to configure XBox 360 Media Remote for XBMC
#1
Brick 
So I recently bought an Intel NUC to install XBMC on.
After installing XBMC I expected my XBox 360 Media Remote to work out of the box.
But it sure did not. I was only able to switch my NUC on and off.
After a lot of research I finally discovered that Windows doesn't listen to this kind of remote by default.

To fix this you have to change some stuff in the registry by following these steps:
1) Press the Windows + R buttons to open the Run window
2) Type in regedit and hit Enter
3) Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HidIr\Remotes\745a17a0-74d3-11d0-b6fe-00a0c90f57da
4) Change the value of CodeSetNum0 from 1 to 0(enables all type of remotes)
5) Delete the three entries CodeSetNum1, CodeSetNum2, CodeSetNum3
6) Reboot

Now that you changed this Windows will finally recognize the signals your remote sends.
But XBMC will still not react to them, this can easily be fixed by doing this:
1) Start XBMC
2) Open the System Settings Window
3) Go to the input devices settings
4) Select Remote control sends keyboard presses

Once you did this the basic buttons will work in XBMC.
There are still some buttons specific to this remote which need be added manually to the register.
Only after doing that you will be able to map them for usage in XBMC.
Luckily baijuxavior made a tool to configure the extra buttons.
This tool is universal so some buttons may not work on our remote.
1) Download the Advanced MCE Remote Mapper Tool
2) Once you have the file you will have to execute it as administrator
2.1) Right click on .exe file
2.2) Run As Administrator
3) Use the table to map the remote buttons to a Key (here you find all the key shortcuts of xbmc)
Example:
The Info button will not work by default but can be fixed.
Button Id: 0F
Button Name: Info/More
Key: I instead of Info
XBMC uses the keyboard button I to show the info of a movie.

Do this for all the missing button configurations.
Here you can find a list of the buttons and the corresponding Button ID.
I also included the keys I mapped to, of course you can change those to the keys of your own preference.
PHP Code:
Remote Button Name --> Button ID --> The key I chose
--------------------------------------------------------------------------
Xbox Logo --> 64 --> (Open the shutdown menu)
Yellow button (Y) --> 26 --> / Shared with Guide button :(
Blue button (X) --> 68 --> (Open subtitle search)
Green button (A) --> 66 --> (Open subtitle search)
Red button (B) --> 25 --> / Shared with Live TV button :(
Menu --> 24 --> (Open context menu)
Record --> 17 --> Stop (To stop a movie)
Info --> 0F --> (Show extra info of movie)
Guide --> 26 --> (Enable/Disable subtitles)
Live Tv --> 25 --> Home (To go to top of a list)
Last --> 1C --> End (To go to bottom of a list)
Chanel Up --> 6C --> PageUp (to next page of list)
Chanel Down --> 6D --> PageDown (to prev page of list)
Disp (Display) --> 4F --> Alt+Window+Return (to minimize screen

I hope this will help you to make the Xbox 360 Media Remote usefull in XBMC.
Reply
#2
Thanks for the nice tutorial, but in my case it did not work.

Please see if I have all the necessary:

Image

Image

And my machine specs:

MotherBoard: G43-ITX Wifi
OS: Windows 7 Professional
XBMC version: 13.2

Please help me, I purchased the receiver and the remote just to use in my HTPC.

Thanks in advance and excuse my bad english, I'm using google translate
Reply
#3
can anyone help me?
Reply
#4
(2014-08-30, 12:20)ninjitisu Wrote: can anyone help me?

That remote uses infrared, that receiver is for an xbox 360 gamepad which uses its own wireless solution.
You gonna need a proper CIR.
Reply
#5
Or use a xbox controller
Aussie, Aussie, Aussie, Oi, Oi, Oi

Don't forget the Thank User button if i have helped!
|
V
Reply
#6
Thank you very much for this guide @Beejee !
I have this working with the Logic3 Xbox 360 Pro Remote.
Its replacing my old Hauppauge Media Center Remote Control. The Back and Pause buttons don't work anymore, even after cleaning it more than once.
Using the IR Receiver that came with the Hauppauge Kit with no problems.

Thanks again!
Reply
#7
I know this is super old, any chance to get the xbox 360 media remote (Black) to power on the NUC from any state?

Remote works perfect while machine is powered up in Kodi and can put the machine to sleep with the remote but it will not power it on or wake it from sleep.

Remote is the original Microsoft not generic.
Machine is Intel NUC6i7KYK Skull Canyon
Bios is set to wake from CIR
I have tried all 3 remote profiles in bios
Generic MCE
XBOX One
RC6 MCE

Nothing will power the machine back on.

Side note i have a Steam Controller and dongle and when i push the steam button it will wake the machine from sleep.

Thanks for any help you may be able to provide.
Main Kodi Build
HP Chromebox Intel Celeron 4gb mem 128 SSD
Libreelec 010 Kodi 17.

Test Builds
Gen 1 Compute Stick 32gb Version NO WINDOWS
Gen 2 Compute Stick X5 Version Cherry Trail

Future Builds
Gen 2 Compute Stick m5
RPi 3
Reply
#8
Old thread but same issue universal programmed as a Microsoft MCE remote powers on and off, the nuc, true Microsoft Xbox 360 media remote everything but wake from sleep.
Reply
#9
I know this is an old thread, i apologize in advance. I have searched for a while and cant find any specific answers so i am asking here. Ca i get the Xbox one media remote to work using this method?
↯ Ω ☿
Reply
#10
I figured I'd come back to this thread with new issues.

I have not been able to get the Xbox 360 remote working on anything newer than Windows 10 1709. I've done quite a bit of troubleshooting, but nothing has worked. Standard RC6 remotes still work, but not the Xbox remote. If I downgrade back to 1709, everything works again. I've tried CodeSetNum at 0 and 8, neither seem to work.

Another issue, probably related, is functionality within YouTube Leanback using the Chrome browser. I use the Chrome Launcher addon with Kodi that launches Youtube.com\TV in kiosk mode. If my remote has a Stop button (whether by default of if I use the Windows Media Center remapping tool to make a stop button. On the black 360 remote I remapped the Menu button to Stop), I can stop youtube videos with it which brings me back to the video lists...if I'm on Windows 10 1709 or older. 1803 and newer, the stop button does nothing. I can still use the enter button to pause the video and the directional buttons still work as well, but no stop.
I figure there's got to be a common thread to all this, but I can't figure it out. Anyone else work through this already?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
How to configure XBox 360 Media Remote for XBMC00