• 1(current)
  • 2
  • 3
  • 4
  • 5
  • 132
  •   
  Thread Closed
v13 Titan MediaBrowser skin
#1
Wink 
As a day-one Microsoft MCE with Mediabrowser user I was looking for an alternative as MCE is no longer developed and actively supported. In the years I've tried Mediaportal several times and XBMC, didn't like Mediaportal (personal opinion) and the lack of support for other platforms than Windows. XBMC in the other hand blew me away with it's stability and support of plugins, platforms etc. But the user interface of XBMC was always somewhat "techie" and not "wife-friendly" to me.

What I really did like in the latest Mediaportal releases was the Titan skin, with it's attractive graphics and simple big buttons.
For me that skin simply had the "wow" factor and even my wife and guests liked the user interface ;-)
In my search for the perfect HTTPC I stubled across an unfinished project by user reazorFX who did the first attempt to port the Titan skin from MediaPortal to XBMC. I finished his really great work and made the skin completely functional. After that I started adding lot's of features like extra views and custom library support. I even changed the look and feel of the skin to a more modern approach (Original style still available as theme in the skin).

Skin key features:

- Compatible with XBMC 13 Gotham and Kodi Helix
- multiple homescreen layouts, fully customizable
- Nice looking artwork everywhere in the theme
- Weather with accurate live artwork
- Support to "switch" the XBMC library to third party add-on like MediaBrowser, Plex or Netflix
- Optimized for speed while retaining nice looking graphics
- Very user friendly (high W.A.F.)
- Lot's of views to fit your media and personal needs
- Full touchscreen support (has to be enabled in skin settings)
- support for tv shows next aired
- support for video extras
- support for extendedinfo script
- custom and predefined widgets
- fully customizable appearance settings

screenshots:

watch gallery


This skin is available in the official XBMC repository.

Installation instructions:
1. In XBMC, go to Settings --> Appearance --> Skin
2. Press the "Get more" button
3. Select "Titan MediaBrowser" and hit install
4. Default installation now complete and you can sit back and enjoy :-)

TIP: The skin is highly customizable. Go to XBMC settings --> Skin Settings

Skin theme
The skin's default theme is my own more modern approach of the Titan skin. If you like the classic MediaPortal style better, you can change the theme of the skin to "classic". Open up settings --> Appearance --> Under skin you have the option to select the theme.

Touchscreen support
The skin is fully touchscreen compliant, actually it even has seperate controls and code to make life easier navigating on a touch device.
You have to enable the "touch mode" of the skin in the skin settings.

Beta version repository and more information about MediaBrowser integration
If you want to try out the latest features and/or if you're interested in the MediaBrowser integration install the beta repository which is hosted at MediaBrowser bacause my involvement in the xbmb3c (mediabrowser) addon for kodi.

Bug reports and feature requests
Feel free to post a message on this forumtopic or send me a PM to get support for the skin, I'll be glad to assist. Also I'm also looking for users with feedback or suggestions about the skin. If you have a feature you would like to see included, please ask on the feature requests thread!


If you like this skin and you feel that you would like to help out a little bit then you can buy me a beer :-)
#2
I fixed the imgur gallery for you.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
#3
(2014-07-31, 11:56)Montellese Wrote: I fixed the imgur gallery for you.

thanks! I was wondering how to do that ;-)
#4
Thumbs Up 
Thank you for continuing development of this amazing skin, and then adding the XBMB3C cherry on on top. Nod
#5
Nice skin. Just given it a try. Unfortunately something doesn't seem to be right.

I only have movies and TV show tiles enabled. If I click on either of them nothing happens.

I enabled the videos tile temporarily and that worked, but nothing from the others.

This is just using standard xbmc library, I don't use mediabrowser.
#6
(2014-08-07, 23:53)Carcharius Wrote: Nice skin. Just given it a try. Unfortunately something doesn't seem to be right.

I only have movies and TV show tiles enabled. If I click on either of them nothing happens.

I enabled the videos tile temporarily and that worked, but nothing from the others.

This is just using standard xbmc library, I don't use mediabrowser.

Hi Carcharius,

Seems like something is off with the Mediabrowser detection. Do you by any chance have the XBMB3C plugin installed and you don't use it ?
The simple fix would be to go into settings --> skin settings --> skin mode and toggle the mediabrowser mode to on and off again and you should be fine.
Could you tell me if this solves your problem ? I will then fix this issue in an upcoming release.
#7
No I don't have the XBMB3C plugin installed and have never done so to my knowledge.

I'm away from the machine now until this evening, but I'm sure I did try toggling the mediabrowser mode on and off again and still have the problem.

What I didn't try however was toggling the settings for each category on and off, I can give that a try later if you think it would help.

While I'm here...

When I first used the skin, and first clicked the settings tile I got a bit confused by the popup menu that lets you select settings, shutdown etc.

The reason for the confusion was that the highlighted option was coloured in a dim grey, while the others were bright white, which initially made me think it wasn't selected. Any chance another colour could be used to make it clearer? Invert the colours perhaps so the selected one is bright and the others dim?

I haven't been able to get far enough into the skin to see if that is a problem anywhere else yet.
#8
@Carcharius: I have fixed the issue for you and it is available in latest version of the skin: 1.8.2.
In case you have installed the skin from repo then you should be fine and get the update automatically.
Can you confirm that you're at least on version 1.8.1 ?

Good suggestion about the settings menu, I'll fix that.
#9
I installed it from the repo last night, and was pretty sure that when trying it I saw it showing version 1.8.2 already.

I just remoted in to my box and checked the contents of the skin.titan/addon.xml and it does say version 1.8.2 in there.

I've NOT updated (and can't unless it can be triggered from a command line) since your post.
#10
OK, thanks, this means that there maybe still is an issue. please let me know your findings after toggling the "mediabrowser mode" button.
In the meanwhile I'll test it myself on a clean box.

Just to be sure: I suppose that your libraries are indead scanned and filled with content ?
#11
Just to clarify - I haven't updated or installed the skin since you posted earlier today that you'd fixed the problem in 1.8.2. I'm seeing 1.8.2 on a copy of the skin installed yesterday.

I am also sure that I did toggle mediabrowser mode on and off again, but I will try it again and try toggling the settings for each category as well.

My libraries are indeed scanned and full of content. My library is stored in MySQL (mariadb) running on my unRAID server.

I currently use jurialmonkeys arctic skin with no issues.

If it's of any use, I'm running it on an openelec 4.0.7 install, running on an i3 haswell nuc.
#12
Looks great. Does Netflix work with XBMC though? Especially OpenElec?
Server: Synology Diskstation 1511+ with 8x WD Red NAS 3TB drives, DSM 5.2
Main HTPC: Home Built i3, 8GB RAM, Corsair 128GB SSD, nVidia 630GTX, Harmony Home Control, Pioneer VSX-53, Panasonic VT30 65" 3D TV, Windows 10, Isengard
Bedroom HTPC: Zotac-ID 41 8GB RAM, 128GB SSD, Rii micro keyboard remote, Samsung HW-E550, Sony 32" Google TV, OpenElec 6.0 beta 4
#13
(2014-08-08, 17:04)Carcharius Wrote: Just to clarify - I haven't updated or installed the skin since you posted earlier today that you'd fixed the problem in 1.8.2. I'm seeing 1.8.2 on a copy of the skin installed yesterday.

I am also sure that I did toggle mediabrowser mode on and off again, but I will try it again and try toggling the settings for each category as well.

My libraries are indeed scanned and full of content. My library is stored in MySQL (mariadb) running on my unRAID server.

I currently use jurialmonkeys arctic skin with no issues.

If it's of any use, I'm running it on an openelec 4.0.7 install, running on an i3 haswell nuc.

I indeed fixed the problem so it won't occur again, but its for fresh installs only. I'm pretty sure that in your case just toggling the MB mode will do the trick. Please let me know!

(2014-08-08, 18:30)patseguin Wrote: Looks great. Does Netflix work with XBMC though? Especially OpenElec?

Yes, it does!. I have it working on several Linux boxes, including openelec.
#14
Just fired my box up and found the skin had updated to 1.8.3.

Movie and TV show tiles now work.

Have found a couple of issues - I noticed that, in poster views (maybe others I haven't checked fully) my TV shows aren't showing posters for the last season in the list. The posters are present and show by other skins.

While poking around trying to get the posters to show, I noticed that some of the dialogs (specifically the choose art ones) weren't showing a border. Leaving the buttons floating and difficult to see in some cases, depending on the screen behind.

I also couldn't seem to get artwork downloaded to do anything when triggered from the choose art dialogs. Works fine from other skin.
#15
(2014-08-08, 23:35)Carcharius Wrote: Just fired my box up and found the skin had updated to 1.8.3.

Movie and TV show tiles now work.
Glad to hear that it was fixed. I have it covered now in the skin so that it won't happen again.

Quote:Have found a couple of issues - I noticed that, in poster views (maybe others I haven't checked fully) my TV shows aren't showing posters for the last season in the list. The posters are present and show by other skins.
That's strange! The skin itself only displays content (like tvshows or seasons), it doesn't alter it. I (and some other users who test the skin) have tested it very often and never saw this problem occur. Is there a possibility that in other skins you can choose to display seasons/episodes that aren't on your disk or haven't been broadcasted yet ? That's the only thing that comes in my mind reading your issue. Sure I want to look in to it for you, but I have to replicate the problem.

Quote:While poking around trying to get the posters to show, I noticed that some of the dialogs (specifically the choose art ones) weren't showing a border. Leaving the buttons floating and difficult to see in some cases, depending on the screen behind.
Could you please make me a screenshot what dialog you mean ? I made sure that all text, buttons and dialogs are perfectly readable.

Quote:I also couldn't seem to get artwork downloaded to do anything when triggered from the choose art dialogs. Works fine from other skin.
What do you mean with "artwork downloaded to do anything" ? The artwork downloader let's you choose/download a specific image, like poster or thumb to use in the views. For example the "banner list" view uses banners and clearart which aren't available by default. This way you can add this missing artwork yourself.

TIP: If you don't want to fool around with for example artwork, use MediaBrowser as your database instead. It handles artwork and infoscraping much better then XBMC libraries do.
  • 1(current)
  • 2
  • 3
  • 4
  • 5
  • 132
  •   
  Thread Closed
 
Thread Rating:
  • 14 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
Titan MediaBrowser skin4.514