•   
  • 1
  • 10
  • 11
  • 12(current)
  • 13
  • 14
  • 19
  •   
Release [Windows] Kodi - Texture Tool (.xbt)
MSVCP140.dll & VCRUNTIME140.dll is missing when try run TexturePacker from cmd.
Reply
https://www.microsoft.com/de-de/download...x?id=48145

Install Visual C++ Redistributable for Visual Studio 2015 32 bit and 64 bit Smile then it will work.

both dlls include "VC" in the name and are delivered with Visual C++ Runtime.

I'll try to catch the output in future and give you the hint.

Anyway when u started the tool there was a messagebox hint that it will not run without Smile
Reply
Another Day, another Release. Sorry for the bunch of updates right now..

Version 2.7.2

- checking vcredist via 2 system dlls.
- added about window stuff
Reply
******************Program start*****************
Current Time: 2016.06.02-09:57:22
Running Version: 2.7.2
RegRead: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\10.0\VC\VCRedist\x86: 1
C:\WINDOWS\SysWOW64\msvcp140.dll: 0
C:\WINDOWS\system32\msvcp140.dll: 0
C:\WINDOWS\SysWOW64\VCRUNTIME140.dll: 0
C:\WINDOWS\system32\VCRUNTIME140.dll: 0
09:57:22: TexturePacker Version: 1.1.1.0
09:57:22: Update function started.
09:57:22: No update found!
09:57:30: Compile Mode started.
09:57:47: Directory is fine.
09:57:47: Path to directory: C:\Users\z_dane\AppData\Roaming\Kodi\addons\skin.aeon.nox.5\media\Textures
09:57:51: Directory is fine.
09:57:51: Path to output file: C:\Users\z_dane\AppData\Roaming\Kodi\addons\skin.aeon.nox.5\media\Textures.xbt
09:57:53: Running command:TexturePacker -input C:\Users\z_dane\AppData\Roaming\Kodi\addons\skin.aeon.nox.5\media\Textures -output C:\Users\z_dane\AppData\Roaming\Kodi\addons\skin.aeon.nox.5\media\Textures.xbt
09:57:53: TexturePacker.exe running.
09:57:53: TexturePacker.exe close

Still same result after install MVS and use latest version. Or its maybe specific problem with Windows10 64?
Reply
the dll files from vcredist are still missing

C:\WINDOWS\SysWOW64\msvcp140.dll: 0
C:\WINDOWS\system32\msvcp140.dll: 0
C:\WINDOWS\SysWOW64\VCRUNTIME140.dll: 0
C:\WINDOWS\system32\VCRUNTIME140.dll: 0

0 = not available
1 = available

hm, you can try

https://www.microsoft.com/de-de/download...x?id=14632
Microsoft Visual C++ 2010 Redistributable Package (x64)
https://www.microsoft.com/de-de/download...x?id=13523
Microsoft Visual C++ 2010 SP1 Redistributable Package (x64)

https://www.microsoft.com/de-de/download...px?id=5555
Microsoft Visual C++ 2010 Redistributable Package (x86)

example log where it works fine:

******************Program start*****************
Current Time: 2016.06.02-11:08:59
Running Version: 2.7.2
RegRead: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\10.0\VC\VCRedist\x86: 1
C:\WINDOWS\SysWOW64\msvcp140.dll: 1
C:\WINDOWS\system32\msvcp140.dll: 1
C:\WINDOWS\SysWOW64\VCRUNTIME140.dll: 1
C:\WINDOWS\system32\VCRUNTIME140.dll: 1
11:09:00: TexturePacker Version: 1.1.1.0
11:09:00: Update function started.
11:09:00: No update found!
11:09:01: Compile Mode started.
11:09:05: Directory is fine.
11:09:05: Path to directory: C:\sd
11:09:10: Directory is fine.
11:09:10: Path to output file: C:\Users\xxx\Desktop\Textures.xbt
11:09:11: Running command:TexturePacker -input C:\sd -output C:\Users\xxx\Desktop\Textures.xbt
11:09:11: TexturePacker.exe running.
11:11:07: TexturePacker.exe closed.
******************Closed by User*****************
Reply
Thank you, Finally it working. I did copy manually this 2 files to directory SysWOW64 and system32.
I'm not sure why this 2 files were not being there. Its quite strange because I face no problem with last month version but I cant remember which version.
Anyway tqvm for your support
Reply
(2016-06-02, 11:29)z_dane Wrote: Thank you, Finally it working. I did copy manually this 2 files to directory SysWOW64 and system32.
I'm not sure why this 2 files were not being there. Its quite strange because I face no problem with last month version but I cant remember which version.
Anyway tqvm for your support

no problem, yea was facing the same issue since texturepacker updated to 1.1.1 it required me those dlls.
after i installed vcredit is was fine...so strange that its not working for you.
Reply
Problem solved I downloaded virtual studio
Thank you for your support
Reply
Hi, this does not seem to be unpacking for me... I'm unpacking the default "confluence" textures.xbt, and it appears to initiate fine, but it's been running for about 10 minutes, with no extractions... the original textures.xbt is 4.6MB.

I hope you are able to help, or have any ideas?

******************Program start*****************
Current Time: 2016.06.03-23:33:30
Running Version: 2.7.2
RegRead: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\10.0\VC\VCRedist\x86: 1
C:\WINDOWS\SysWOW64\msvcp140.dll: 1
C:\WINDOWS\system32\msvcp140.dll: 1
C:\WINDOWS\SysWOW64\VCRUNTIME140.dll: 1
C:\WINDOWS\system32\VCRUNTIME140.dll: 1
23:33:30: TexturePacker Version: 1.1.1.0
23:33:30: Update function started.
23:33:31: No update found!
23:33:36: Decompile Mode started.
23:33:41: Path to .xbt File: E:\Work Drive Backup\SDC Studios Work\Kodi Skin\skin.essentials\textures.xbt\Textures.xbt
23:33:43: Path to output directory:E:\Work Drive Backup\SDC Studios Work\Kodi Skin\skin.essentials\textures.xbt\Decompile
23:33:57: Running command:base.exe "E:\Work Drive Backup\SDC Studios Work\Kodi Skin\skin.essentials\textures.xbt\Textures.xbt" "E:\Work Drive Backup\SDC Studios Work\Kodi Skin\skin.essentials\textures.xbt\Decompile
Reply
The log doesnt show that you have pressed the start button for the decompile, select Input file, output directory and then press start
Reply
I have pressed the start button several times, the log isn't updating with the start button being pressed, but the program does have the green progress bar going through over and over again with no results...
Reply
Hm okay strange, can you upload me the Texture File? Will Check it today then
Reply
I've managed to progress further with it and it's started the extract, but it hasn't finished updated the log even though it is still "running".

The initial issue was a windows file permissions issue, the application regardless of whether it was running normally or under administrator credentials, wouldn't extract to the original location, so instead I tried extracting to a folder on the desktop and it started working... Damn you Windows 10 and your stupid file permissions...
Reply
Sooooo glad this exists! Finally able to add HEVC flags to skins that don't have them without having to download mods.
Reply
Think I'm having the same as some others, seems like the texturepacker is not running[/quote]

Code:
******************Program start*****************
Current Time: 2016.06.22-15:34:08
Running Version: 2.7.2
RegRead: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\10.0\VC\VCRedist\x86: 1
C:\WINDOWS\SysWOW64\msvcp140.dll: 1
C:\WINDOWS\system32\msvcp140.dll: 1
C:\WINDOWS\SysWOW64\VCRUNTIME140.dll: 1
C:\WINDOWS\system32\VCRUNTIME140.dll: 1
15:34:09: TexturePacker Version: 1.1.1.0
15:34:09: Update function started.
15:34:09: No update found!
15:35:16: About window opened.
15:35:17: Kodiboard URL.
15:38:24: About window closed.
15:38:35: Compile Mode started.
15:38:44: Directory is fine.
15:38:44: Path to directory: C:\temp\new
15:38:49: Directory is fine.
15:38:49: Path to output file: C:\temp\Textures.xbt
15:38:58: Running command:TexturePacker -input C:\temp\new -output C:\temp\Textures.xbt
15:38:58: TexturePacker.exe running.
15:38:58: TexturePacker.exe closed.
Reply
  •   
  • 1
  • 10
  • 11
  • 12(current)
  • 13
  • 14
  • 19
  •   
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
[Windows] Kodi - Texture Tool (.xbt)52