MySQL Connection Failure
#1
I'm running Amahi Home Server 7.1 (Linux Fedora 19) which also installs Mariadb (MySQL "drop in replacement").

Following the wiki, I have setup 2 OpenElec 4.1.4 boxes to use Mariadb on my server.

My issue is that most times, when booting the OpenElec boxes, they fail to connect to the database on the server. Several OpenElec reboots will eventually succeed and the shared database works as expected.

The XBMC log shows messages with MySQL connection failures when OpenElec boots and does not connect to MySQL (Mariadb as it were).

Any suggestions as to why the failures to connect to MySQL on boot?
The server is also hosting the Media Library and using the files path, my media files are visible and available.
Reply
#2
Yes, most likely XBMC is starting before your network interface is ready.

Enable OpenELEC's option to wait for the network before starting.

Specifically in OpenELEC settings, Network Tab. I have mine max out at 10 s but it never takes that long.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#3
That appears to be the ticket.

I had to set the max wait time to 25 seconds as my friends units were taking 8-15 seconds to finish waiting on the Network to start. My friend is connecting to his server with a wireless connection (and aggressively rejecting my suggestion to use wired Ethernet).
Reply
#4
Yeah wireless takes even longer. Sneak a cable in there and see if he notices the difference!
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
MySQL Connection Failure00
This forum uses Lukasz Tkacz MyBB addons.