Bug "Kodi has stopped working" - on quit
#1
Log

Posting in forums as I'm not confident posting a bug report. Kodi Alpha (details below) hangs on quit with "Kodi has stopped working" error.


System details:
10:13:23 T:4132 NOTICE: Starting Kodi (14.0-ALPHA4 Git:20140831-dd441f6). Platform: Windows NT x86 32-bit
10:13:23 T:4132 NOTICE: Using Release Kodi x32 build
10:13:23 T:4132 NOTICE: Kodi compiled Aug 31 2014 by MSVC 180021005 for Windows NT x86 32-bit version 6.0 (0x06000000)
10:13:23 T:4132 NOTICE: Running on Windows 7 SP1, kernel: Windows NT x86 64-bit version 6.1
10:13:23 T:4132 NOTICE: Host CPU: Intel® Core™2 Duo CPU P7550 @ 2.26GHz, 2 cores available
10:13:23 T:4132 NOTICE: Desktop Resolution: 1280x800 32Bit at 60Hz
10:13:23 T:4132 NOTICE: Running with administrator rights
10:13:23 T:4132 NOTICE: Aero is enabled
10:13:23 T:4132 NOTICE: special://xbmc/ is mapped to: C:\Program Files (x86)\XBMC
10:13:23 T:4132 NOTICE: special://xbmcbin/ is mapped to: C:\Program Files (x86)\XBMC
10:13:23 T:4132 NOTICE: special://masterprofile/ is mapped to: C:\Users\Ross\AppData\Roaming\XBMC\userdata
10:13:23 T:4132 NOTICE: special://home/ is mapped to: C:\Users\Ross\AppData\Roaming\XBMC\
10:13:23 T:4132 NOTICE: special://temp/ is mapped to: C:\Users\Ross\AppData\Roaming\XBMC\cache
10:13:23 T:4132 NOTICE: The executable running is: C:\Program Files (x86)\XBMC\XBMC.exe
10:13:23 T:4132 NOTICE: Local hostname: Mac7
10:13:23 T:4132 NOTICE: Log File is located: C:\Users\Ross\AppData\Roaming\XBMC\xbmc.log


Error bit of log:
10:14:37 T:4132 NOTICE: unload sections
10:14:37 T:4132 NOTICE: application stopped...
10:14:37 T:4132 DEBUG: PVRManager - destroyed
10:14:37 T:4132 DEBUG: SECTION:UnloadDll(special://xbmcbin/system/libcurl.dll)
10:14:37 T:4132 ERROR: dllFreeLibrary - Invalid hModule specified
Reply
#2
Just renamed my userdata file to userdata.old (fresh start) and kodi exits without issue. The issue re-emerged with the PVR re-enabled (DVBLink).
Reply
#3
I am seeing this issue as well.

Some information:
Kodi 14 Alpha 3
Windows 8.1 x64
Intel Core i5-2400
16GB Ram
Hauppague Colossus Capture Card using NextPVR
AMD Radeon 7800

In truth, all versions of Kodi 14 - previous Alphas and nightlies - have all given me this issue, but I haven't taken the time to post the issue until today.
To further test, I uninstalled Kodi completely and made sure every trace was gone from the AppData\Roaming directory. I did a fresh install of Alpha 3 and here is what I discovered - It exits just fine UNTIL I enable the PVR. I am using NextPVR and Mitchell.Ross says he is using DVBLink. When I exit Kodi prior to enabling NextPVR it exits without an error. As soon as I enabled NextPVR I get an error. I would bet Mitchell.Ross would see the same behavior if he uninstalled and reinstalled.
Here is the full xbmc.log with debugging turned on - http://xbmclogs.com/show.php?id=285175

If I can provide any additional details please let me know!
Reply
#4
(2014-09-03, 18:34)mantene Wrote: In truth, all versions of Kodi 14 - previous Alphas and nightlies - have all given me this issue

Same here.
Reported a couple times in threads with no response. I haven't followed up because I assume it is something that will get fixed along the way and it doesn't seem to impact anything.

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Matrix see: Aeon MQ5 Mod Martix release thread
Leia see: Aeon MQ5 Mod Leia release thread
Aeon MQ 5 skin and addon repo
Reply
#5
No, it doesn't seem to impact anything while Kodi is running, it only hampers exiting the program.
Scott, are you using a PVR addon in Kodi?
Reply
#6
Same here. Using dvbviewer PVR.

NOTICE: closing down remote control service
22:21:13 T:3508 NOTICE: unload sections
22:21:13 T:4276 DEBUG: Thread RemoteControl 4276 terminating
22:21:13 T:3508 NOTICE: special://profile/ is mapped to: special://masterprofile/
22:21:13 T:3508 DEBUG: CAnnouncementManager - Announcement: OnClear from xbmc
22:21:13 T:3508 NOTICE: destroy
22:21:13 T:3508 WARNING: Attempted to remove window 10013 from the window manager when it didn't exist
22:21:13 T:3508 WARNING: Attempted to remove window 10014 from the window manager when it didn't exist
22:21:13 T:3508 WARNING: Attempted to remove window 10015 from the window manager when it didn't exist
22:21:13 T:3508 WARNING: Attempted to remove window 10016 from the window manager when it didn't exist
22:21:13 T:3508 WARNING: Attempted to remove window 10017 from the window manager when it didn't exist
22:21:13 T:3508 WARNING: Attempted to remove window 10018 from the window manager when it didn't exist
22:21:13 T:3508 WARNING: Attempted to remove window 10019 from the window manager when it didn't exist
22:21:13 T:3508 WARNING: Attempted to remove window 10021 from the window manager when it didn't exist
22:21:13 T:3508 WARNING: Attempted to remove window 10107 from the window manager when it didn't exist
22:21:13 T:3508 WARNING: Attempted to remove window 10115 from the window manager when it didn't exist
22:21:13 T:3508 WARNING: Attempted to remove window 10104 from the window manager when it didn't exist
22:21:13 T:3508 NOTICE: closing down remote control service
22:21:13 T:3508 NOTICE: unload sections
22:21:13 T:3508 NOTICE: application stopped...
22:21:13 T:3508 DEBUG: PVRManager - destroyed
22:21:13 T:3508 DEBUG: SECTION:UnloadDll(special://xbmcbin/system/libcurl.dll)
22:21:13 T:3508 ERROR: dllFreeLibrary - Invalid hModule specified
Reply
#7
This issues should be fixed in the current nightly. If you want to test it, make sure you have a backup of your userdata folder, since the folder gets move to a new location (kodi).
Reply
#8
I can confirm that this issue is fixed in the latest nightly. Thank you so much!
Reply



Logout Mark Read Team Forum Stats Members Help
"Kodi has stopped working" - on quit0
This forum uses Lukasz Tkacz MyBB addons.