Solved Ack!!! Great tool and now it is FUBAR
#1
So I went to update my media library today and went to fire up TMM. It went through the familiar loading up screen and then went to the new 2.6.1 loading screen where it now sticks for upwards of 6 minutes while it is"loading ui". After running out of patience the first few times, I discovered that the only way to even get out of it was to completely log off or reboot the machine. Ultimately, I'm not sure exactly how long it took, but after I had tried a series of installs, cleanups, reinstalls and reloading, I finally gave up after the aforementioned 6 minutes and went to pick my daughter up from preschool. The new interface was loaded when I got back 30 minutes later.

The new look is nice.

As per my normal procedure I hit the <Refresh> arrow (nice touch) to update my sources and it appeared to start the process. However, there was no way to be sure if it was actually doing anything since there is no movement from any indicator on the screen. If I minimize it and come back, the screen is just black. Waited a few minutes till I lost patience and finally logged out and logged back in.

Sad

I even tried to roll back to v2.5.5 because it just worked and worked well, but apparently there is no way to avoid the "Auto-Updater" and nowhere is there an archive of the older versions. I love/loved TMM v2.5.5.

I know the new version isn't huge and bloated but it sure seems that way. The delays and waits are unbearable and there is no way to go back to previous working versions. Even if I unplugged my ethernet cable and ran the old installer it tells me that it has failed to update in the previous 5 attempts and won't let me get anywhere.

I shouldn't whine about something so awesome that is free, but v2.5.5 was light and slick and did what I wanted to do without being intrusive. Now, I am forced to use a newer, slower version and I don't even have the choice to go back to a version that I didn't want to have updated in the first place. Did Sony or Microsoft purchase TMM?
Reply
#2
please submit a bug report after tmm loaded, so we can try to find anything useful in the logs. (please also attach the config.xml to the bug report)

We tried several different scenarios on 3 different OS with new installations and migration from 2.5.5 and everything worked. We never saw any similar issue..

btw: 2.6 finally brings optional updates
tinyMediaManager - THE media manager of your choice - available for Windows, Mac OSX and Linux
Help us translate tinyMediaManager Weblate
Image
Reply
#3
I tried it on both my WHS 2011 server and on my Win7 Pro (accessing via SAMBA) and it behaved almost exactly the same. Incidentally, I am trying to just recreate the database in case it is an issue there, but just removing a source takes a REALLY long time.

The server is using an SSD so it isn't the speed of the HDDs.

Could it be size of database?

I will get those logs to you when I get a chance

--Update--

I deleted my sources and initialized the database.
Then I uninstalled TMM and reinstalled.
Loaded up TMM and it came up almost immediately
Of course, The database was empty.
Intialize Database again to be sure and restarted TMM.
Added back my sources and it seemed to be going smoothly
My database must be nuking the whole thing because when I added back my source folders and hit update sources, TMM started t do its thing and then locked up. When I left that window and came back, TMM was dark, you know how a Windows program gives you a blank screen with nothing but the header containing the program name at the top. I'm sure it will come back, given enough time, but it is disconcerting and I never had anything like this with previous versions.

Is it because I have all of my titles in just a couple of different folders?
Reply
#4
how much movies/tv shows do you have? Do you have movie sets and an artwork folder?
Is there anything special with your setup?

logs would be definitely useful..
tinyMediaManager - THE media manager of your choice - available for Windows, Mac OSX and Linux
Help us translate tinyMediaManager Weblate
Image
Reply
#5
the performance issue will be fixed in 2.6.2
tinyMediaManager - THE media manager of your choice - available for Windows, Mac OSX and Linux
Help us translate tinyMediaManager Weblate
Image
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Ack!!! Great tool and now it is FUBAR00