Playing WEBM & OGV encoded files with XBMC in Raspbian
#1
Hello !

While I don't have any issues playing .MP4 and .AVI files inside XBMC/Raspbian, I experience problems with WEBM & OGV encoded files, those will only play audio, but no video is visible ? How should I proceed to enable also video ?

Jan
Reply
#2
WEBM and OGV are containers so its not certain what video codecs they contain (likely VP8 and Theora respectively, but can be different).
Can you post the mediainfo?

Can you try context menu then "play using dvdplayer"?
Reply
#3
I'm experiencing the same problem.

My file is a WebM containing VP8 video and Vorbis audio.
Audio plays fine, video doesn't play at all in neither the standard player nor the dvdplayer.
Switching video acceleration from hardware to software has no effect (my guess was that only H264 acceleration is supported in hardware, but I'm not sure).

My setup is this:
Raspberry Pi B
Raspbian Wheezy from 2014-09-09
XBMC 13.1 from Michael Gorven's repository

Any insights if and how such WebMs can be played would be appreciated! Thank you! Smile
Reply
#4
(2014-11-09, 14:31)saltedDog Wrote: My file is a WebM containing VP8 video and Vorbis audio.
Audio plays fine, video doesn't play at all in neither the standard player nor the dvdplayer.
Switching video acceleration from hardware to software has no effect (my guess was that only H264 acceleration is supported in hardware, but I'm not sure).

Can you post a sample file?
Reply
#5
For most of the concerned files, I can't due to copyright issues.
However, this music video (in WebM) is an example of what won't play:
https://www.youtube.com/watch?v=61PL3KJFPss
Reply
#6
(2014-11-10, 21:13)saltedDog Wrote: For most of the concerned files, I can't due to copyright issues.
However, this music video (in WebM) is an example of what won't play:
https://www.youtube.com/watch?v=61PL3KJFPss

I've downloaded the vp8 version that is 480x350 and it plays okay for me.

Note that GPU accelerated software codecs (and camera) are only available from start_x.elf.
Add start_x=1 to config.txt (or use raspi-config and enable camera).
Reply
#7
Thumbs Up 
YES! That was the missing bit!
start_x=1 did the trick nicely, thank you!

(I'd like to add to your reputation points, but I'm apparently too n00b to see the buttons. Smile )
Reply



Logout Mark Read Team Forum Stats Members Help
Playing WEBM & OGV encoded files with XBMC in Raspbian0
This forum uses Lukasz Tkacz MyBB addons.