Need your HD multichannel audio experience
#1
Hi,

I am fighting for few weeks to get my Pi to play HD multichannel FLAC files without drops.
I opened a thread
but I can't have any answer for what is the culpride software or hardware.
The only think I know is that there is no passthrought with FLAC files.

If you have an AVR/Amplifier with 5.0 or 5.1 speakers could you test some files in this site 2L.
Choose "Test bench HD audio files" at the upper right hand side and choose
Surround 5.1 FLAC 24BIT/96kHz column.
I mainly use Beethoven: Sonate 32 - Maestoso Tor Espen Aspaas (solo piano)

To download audio files username: 2L and password: 2L is requested.

Then let me know if you have sound drops or not with PAPlayer and DVDplayer. Please post an answer if it's good or not good.
Could you check as well the sample rate displayed by your AVR.

Another point is I think there is a bug but have no confirmation:
Quote:Playing a file 5.1, 24/96 with DVDplayer

System > Settings > Audio output > output configuration = Fixed
Limit sampling rate = 44.1
then back to
System > Settings > Audio output > output configuration = Best match or Optimized
When playing, sample rate is 44.1

System > Settings > Audio output > output configuration = Fixed
Limit sampling rate = 88.2
then back to
System > Settings > Audio output > output configuration = Best match or Optimized
When playing, sample rate is 88.2
Could you do the same and report what your AVR shows as sample rate?

Many thanks for your help.
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
#2
OpenELEC Helix build: #0927

Same issues.
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
#3
I had some trouble in the past with Raspbmc Gotham and my own 5.1/96KHz flac files, so I thought I'd give yours a try.

I played your sample file with paplayer, dvdplayer and omxplayer and they all played correctly without any drops. My Yamaha RXV-671 AVR reported 96 KHz for paplayer and dvdplayer but 48 KHz for omxplayer.

So then I went back to my own files and they play without drops as well. Since I last tried playing them I have upgraded Raspbmc and my pi settings so I'm not sure what improved playback.

my pi settings:

Code:
hdmi_force_hotplug=1
gpu_mem_512=256
hdmi_edid_file=1
arm_freq=1000
core_freq=450
sdram_freq=450
over_voltage=6
disable_overscan=1
gpu_mem=128
start_file=start_x.elf
fixup_file=fixup_x.dat
hdmi_ignore_cec_init=1

my system -> audio settings

number of channels = 7.1
output configuration = optimized
stereo upmix = off
normalize levels on downmix = on
resample quality = medium
Reply
#4
Thanks averylinden for your post.

My config (with RPi_monitor) is:
Code:
Firmware Version
Sep 27 2014 15:02:59
Copyright (c) 2012 Broadcom
version 1e1705d83daf22b7a50331d9538258c4c7acf656 (clean) (release)

temp=29.9'C

arm:     frequency(45)=700000000
core:     frequency(1)=250000000
h264:     frequency(28)=250000000
isp:     frequency(42)=250000000
v3d:     frequency(43)=250000000
uart:     frequency(22)=3000000
pwm:     frequency(25)=0
emmc:     frequency(47)=250000000
pixel:     frequency(29)=146250000
vec:     frequency(10)=0
hdmi:     frequency(9)=163683000
dpi:     frequency(4)=0
core:     volt=1.35V
sdram_c: volt=1.20V
sdram_i: volt=1.20V
sdram_p: volt=1.23V
H264=enabled
MPG2=disabled
WVC1=disabled
MPG4=enabled
MJPG=enabled
WMV9=disabled

Config info
config is unknown
arm_freq=1000
core_freq=500
sdram_freq=500
over_voltage=6
hdmi_force_hotplug=1
hdmi_channel_map=8
disable_overscan=1
program_serial_random=1
config_hdmi_boost=2
emmc_pll_core=1
hdmi_force_cec_address=65535
hdmi_edid_file=1
temp_limit=85
force_pwm_open=1
pause_burst_frames=1
avoid_fix_ts=1

Memory split
arm=384M
gpu=128M
I only understand overclock is higher in my Pi than your, I can't see something else wrong.
Do you see something wrong?
Someone could have a look and let me know?
My HDD is connected with USB (see my hardware config in my signature).
Still no idea why it's not good for me Confused

Regarding "48 kHz for omxplayer" (instead of 96) this is due to the parameter in System > Settings > Audio output > output configuration = Fixed. At this time it is set to 48 kHz. In fact System > Settings > Audio output > output configuration is always set to fixed with omxplayer.
I think this is a bug but nobody care of it, so I am not sure.
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
#5
If you have an extra SD card, maybe you can try Raspbmc and see if you get the same results.
Reply
#6
Hi averylinden,

I've been away from Raspbmc for a while and due to the name changes I don't know where to find the build you advised me.
Could you provide a link? and BTW a link to install method.

Thanks
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
#7
I installed Raspbmc with this howto
http://www.raspbmc.com/wiki/user/os-x-li...tallation/
but when I play counter changes but I can't get any sound through HDMI. I didn't test analog.
Any idea?
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
#8
I reinstalled it and it's playing now but I have the same issue with drops.

I am wondering if there is an incompatibility with the Denon AVR.
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
#9
Back to first question in first post:
After 6 days and 288 views, I hope some of you will get time to test the HD file (see in first post) and let me known.

Thanks
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
#10
New OpenELEC Helix build: #1003

Unfortunately, I still have drops with the above HD file.

Thanks for your helps and advices
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Need your HD multichannel audio experience00