Win Library won't update automaticaly
Hey guys

So i'm running XBMC 13.2 on a Windows 8.6 64 bit with all my video content on a Synology DS412+ and using it as a shared library as well. The sources points directly at my NAS and I use a username and password to access it. My problem is that when I start XBMC and it tries to update the library(auto update) it just say pending for a while but nothing happens. I can then try to manually update the library but still same problem. If i then go under videos and click on one my sources that points to the NAS, it does the "working" for a few seconds and then I see my source content and I can now manually update the library. That is until I restart my machine or something like that.. Then it starts over.

Anyone know a fix for this?
do your drives go to sleep in the NAS? Sounds like the drives are spun down, and takes them a little while to get back up.
That could be but still, I don't think that's suppeose to matter here. I want it to do the update automatically so I don't have to do this "video - sources - click" workaround...
yeah but what I'm suggesting is that if you can change a setting on your NAS you wouldn't have to do your current method. because they drives are already spun up.
Okay so now I have disabled the sleep mode for my NAS drives. Will check tomorrow if it has any impact.
Tested it again today, problem still there. I think it has something to do with the user authentication, that for some reason the library update process can't do the login but as soon as I navigate to one of my sources under video - files it starts right away... I have my sources in the sources.xml and all my login information in a password.xml. I tried having the user and password included in the sources.xml but then my raspberry pi, running openELEC, couldn't access the video content..
grab a debug log
I'm getting a error when i try to upload my log file. Just uploaded it to dropbox instead. Hope it can be used?
yeah the source is definitely not available when it comes time to scan........

do you boot straight to XBMC when windows loads up? or do you load windows, then open XBMC?

also, have you tried the Wake On Lan Settings?
I just put it in the startup folder so it boots when Windows is loaded. I haven't tried the wake on lan setting. I remember reading about that feature coming in v13, since I also had this problem when I used v12. I just thought it was enabled by default... I'll try enable the setting, see if it dosen't solve the problem.
Quote:startup folder so it boots when Windows is loaded

this is probably your issue, windows hasn't fully loaded your network interface before xbmc tries to go to talk to your NAS. So an easy option to solve this is to use:

Quote:1.7 Upon booting, start XBMC with a delay.

When starting XBMC on Windows startup it can be that some sub services weren't started when XBMC is up. To delay XBMC just add the parameter -d X (in the Target field after the closing quotation mark) to the shortcut's properties used to launch XBMC, with X equal to the startup delay in seconds
I tried the Wake on lan setting, no result. Just tried the boot delay. I sat it to 30 seconds. I'm using an SSD so my computer is Definitely up and running by those 30 seconds. Still no results..
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Library won't update automaticaly00
This forum uses Lukasz Tkacz MyBB addons.