Thread Rating:
  • 0 Vote(s) - 0 Average
Media key problem on Arch Linux
#16
media keys work fine for me on XFCE, xev and kodi both see them correctly
Reply
#17
And with LXDE the multimedia keys work!

So it is Unity (and Gnome) to blame.
Reply
#18
http://forum.xbmc.org/showthread.php?tid...pid1806406

Thanks for ALL!!!Blush
MediaCenter: Fractal Design Node 605/ASUS Maximus VI Extreme/i3-4170/nVidia [email protected] V4000 Mod (Passive)/TBS6904/Arch Linux Multiseat/Krypton x 3/HP Media IR remote/Sony PS3 BD remote/PulseEight USB-CEC(AnyNet+)/3 LCDTV over HDMI/SONY MDR-HW700DS ;)
Reply
#19
(2014-10-02, 13:20)jhsrennie Wrote: @Memphiz: I can reproduce this (Ubuntu 14.04 trunk build).

It's fixed by removing the shortcuts in Settings, Keyboard, Shortcuts, Sound and Media. I can't remember if this was necessary in previous builds though I have an idea it was. Anyhow, can you try it and see if that fixes the problem?

Has any of the SDL removal stuff actually made its way into the trunk builds?

Thanks so much! This solved my problem also. Saved me a lot of aggravation Big Grin
Best
Reply
#20
(2014-10-03, 12:44)jhsrennie Wrote: And with LXDE the multimedia keys work!

So it is Unity (and Gnome) to blame.

How can you blame the window manager for a regression in XBMC/Kodi? It worked fine in 13.2. It is broken in 14.0 without my having made any changes to the window manager or window manager configuration files.

That, to me, is a bug in Kodi, pure and simple. I have filed http://trac.kodi.tv/ticket/15643 about it.

xev sees the events correctly, unchanged from pre-Kodi behavior, e.g, keycode 172 (keysym 0x1008ff14, XF86AudioPlay). Kodi does not recognized the keycode, keysymbol or whatever; The debug log shows it (non-)handling a code of 0xF200 which, as far as I know, is the keycode it assigns to unrecognized keys.
Reply
#21
I tried jhsrennie's fix of removing the shortcuts. It fixed the play/pause, stop, next and previous buttons, i.e. all those listed in System Settings. Strangely enough when I restored the shortcuts, Kodi continued to work, even after a system reboot. I first disabled the shortcuts, then I ran Kodi and tested. I exited Kodi and restored the shortcuts. I ran Kodi again and the keys were still working. I then rebooted the system and restarted Kodi. The keys continue to work. Most peculiar but I am happy because that means use of these buttons with other applications won't be broken.

However the fast-forward, rewind, menu and info buttons, all of which worked in 13.2, are still broken.
Reply
#22
Hi,

I had the same issue until I found a solution. It doesn't seem related to the WM but to acpi. When pressing XF86AudioLowerVolume I have no keypress event reported by xev. However I have an acpi event: button/volumedown VOLDN 00000080 00000000 K
So I just created a file : /etc/acpi/event/hotkeys-volume-down containing the following two lines:
event=button/volumedown VOLDN 00000080 00000000 K
action=kodi-send --action=VolumeDown

Then do the same with other non-working keys, et voilà!

Note: This is just a trick to have your hotkeys proporly functionning, but it doesn't fix anything. Maybe some one should dig a bit deeper into acpi and warn acpi ?

Cheers
Psylox
Reply
#23
(2014-10-02, 13:20)jhsrennie Wrote: @Memphiz: I can reproduce this (Ubuntu 14.04 trunk build).

It's fixed by removing the shortcuts in Settings, Keyboard, Shortcuts, Sound and Media. I can't remember if this was necessary in previous builds though I have an idea it was. Anyhow, can you try it and see if that fixes the problem?

Has any of the SDL removal stuff actually made its way into the trunk builds?

Awesome. That worked for me too. Thanks.

Kodi 16.1
Ubuntu 14.04
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Media key problem on Arch Linux00