Linux Play, stop, and pause remote buttons stop working with Helix Beta
#1
I compiled Helix beta 2 (as tagged in Git) -- and now my remote's play, stop, and pause buttons don't work.

The other buttons work fine (colors, right, left, up, down, select, back).

The buttons presses don't appear in ~/.kodi/temp/kodi.log (other buttons do appear). I've tried many things, including:

>>edit your remote.xml and change "<play>Play</play>" to "<play>PlayPause</play>", the latter being the new system default.

from this thread: http://forum.kodi.tv/showthread.php?tid=205385

which seems to be the identical problem? I'm kind of baffled what could be happening, any ideas?
Reply
#2
ubuntu? if so you need to unbind those media keys in ubuntu itself so that kodi can see them (somewhere in keyboard shortcuts or so)
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#3
Yes, Ubuntu.

Excellent, that fixed the problem in 2 minutes!

Weird, I've never touched (or even seen) these settings before, and suddenly they were active upon upgrading.
Reply
#4
unity does some strange things Smile
Reply
#5
Hi there,

I have remote control vrc-1100. On xubuntu 14.04 with XMBC all buttons wok. After installing kodi, the volume up/down/mute, pause,play,power and another buttons stops working.

The buttons presses don't appear in ~/.kodi/temp/kodi.log.

does anybody know how to unbind this media keys in xubuntu 14.04 (xfce)?

I did not find it in any settings keyboard shortcuts.

Thanks
Reply
#6
Found this problem too with no apparent solution. Tried two different approaches.

1) Moved .xbmc folder to a backup location and ran kodi with a clean configuration. STOP, PLAY and PAUSE on remote don't work.

2) Copied the backup back to .xbmc and removed .kodi folder. Ran kodi again to migrate settings - same result as 1).

For me this is a show-stopper. I've installed XBMC on several friends PCs using Mint 17.1 and the remote keys only stopped working when kodi was installed/upgraded. The keys work perfectly fine with latest Gotham build under Mint 17.1.

I've gone into System settings/Keyboard in Mint, and can't see any bindings for the STOP, PAUSE and PLAY buttons on the remote.

Interestingly outside of XBMC/Kodi pressing any of these keys comes up with a operation forbidden-like watermark, similar to what you see when pressing a button on DVD/BluRay player that isn't allowed.

At this stage if I can't work out how to get the keys working I won't be recommending people upgrade to Kodi, and will probably roll back to Gotham.

Cheers,

Matt.
Reply
#7
Hi MattH7

try this:

http://kodi.wiki/view/HOW-TO:Configure_V...for_Ubuntu

After configuring the remote, according to this manual, the remote stops working as usb mouse/keyboard, only lirc scans the remote keys. All keys are now working fine in Kodi.

In Lircmap.xml file you have to choose only defined keys (start,power,stop,info). I tryed to set my own for remote keys which wasn't mapped, but it was not working and I have to use one of "defined" keys. I used <eject> for one of undefined remote key.

Tomas
Reply
#8
(2014-12-27, 01:20)porubat Wrote: Hi there,

I have remote control vrc-1100. On xubuntu 14.04 with XMBC all buttons wok. After installing kodi, the volume up/down/mute, pause,play,power and another buttons stops working.

The buttons presses don't appear in ~/.kodi/temp/kodi.log.

does anybody know how to unbind this media keys in xubuntu 14.04 (xfce)?

I did not find it in any settings keyboard shortcuts.

Thanks

I had this exact problem, with the exact same remote/receiver but with Ubuntu 14.10.

Not sure if it's the same for Xubuntu, but try go to System Settings > Keyboard > Shortcuts > Sound and Media and disable each of the relevant shortcuts by selecting them then pressing backspace.
Reply
#9
I had this exact problem too with a Logitech dinovo mini bluetooth keyboard.

This keyboard's media keys (play, stop, pause, volume+, volume-) were working fine in all Frodo and Gotham versions, but they stopped working in Kodi Helix beta/14.0 release.

When pressing these keys in Kodi, I have the same behaviour described by someone in this thread: An icon overlay appears showing a start icon, a stop icon, or a volume increase or decrease icon, but nothing happens in Kodi (nor in ubuntu mixer underneath).

I couldnt find where to "unbind" these keys in Ubuntu, but if I uninstall Kodi and reinstall Gotham 13.1 or 13.2, all the media keys get back to work again, flawlessy.

I posted about this here: http://forum.kodi.tv/showthread.php?tid=215696

I would really appreciate some directions on this.
Reply
#10
PROBLEM SOLVED, in my case at least.

It was indeed, as pointed out by Memphiz and denz13, a conflict with ubuntu keyboard shortcuts.

It was just a matter of going to System Settings > Keyboard > Shortcuts > Sound and Media and disabling all shortcuts. After that, all media keys on the Logitech dinovo mini started to work again in Kodi.

Thank you very much, Memphiz and denz13.
Reply
#11
I have taken it upon myself to update the following page with this solution, from Memphiz and denz13, which also worked for me:

http://kodi.wiki/view/HOW-TO:Configure_V...for_Ubuntu

Now, if somebody could tell me how to effect this same solution also on Lubuntu... which is what is running on my new Odroid-C1... I would be a happy man. (Apparently, everything is different on Lubuntu... except the selectively non-working keys on the VRC-1100 remote, which seem to be identical. Lubuntu doesn't use Unity and instead has LXDE as the desktop environment and Openbox as the window manager. I've asked in the LXDE forums, yesterday, how to make this work, but so far no response at all. Bummer. Searching for an emoticon representing teardrops...)
Reply
#12
Since this is one of two threads now referenced by a number of other threads about the VRC-1100, I'll add something I previously wrote about this remote:

Green Start Key and IE Key
After you fix Unity 'grabbing' the media keys (in settings / keyboard / shortcuts) -- the VRC-1100's (1) green "Start" key and the (2) IE key will still be non-functional. You can improve the green key.

I set the green start key to go to the "top menu" by adding this line to /home/htpcuser/.kodi/userdata/keymaps/keyboard.xml in the <keymap> <global> <keyboard> section:

Code:
<return mod="alt">XBMC.ActivateWindow(Home)</return> <!--VRC-1100 Green Start Key Support-->

However, I was unable to fix the IE key, I asked about it here: http://forum.kodi.tv/showthread.php?tid=208896 but there weren't many suggestions.

Volume and Channel
Another thing that might improve your VRC-1100 is switching the "volume +/-" and "channel +/-" functionality. The VRC-1100 doesn't normally have a "fast repeat" of the volume button, but it does have a fast repeat of the channel button. So, by flipping the buttons functionality, you will get fast repeat on volume rather than channel (which I think is way more useful).

You need to edit the <pageup> and <pagedown> lines in /home/htpcuser/.kodi/userdata/keymaps/keyboard.xml . This will flip the buttons and make the physical "channel button" quick repeat volume up and down. And the physical "volume button" will change channels without a repeat. You probably already have these lines present, you will need to edit each occurrence in the keyboard.xml file to look like this:

Code:
<pageup>VolumeUp</pageup>            <!-- MAKE CHANNEL NOW VOLUME, SO IT REPEATS -->
<pagedown>VolumeDown</pagedown>      <!-- MAKE CHANNEL NOW VOLUME, SO IT REPEATS -->

<volume_down>PageDown</volume_down>  <!-- VOLUME REPEATS RATHER THAN CHANNEL-->
<volume_up>PageUp</volume_up>        <!-- VOLUME REPEATS RATHER THAN CHANNEL-->

Edit, I marked this as solved, but I just re-read above and saw that Ronbaby still has a problem with Lubuntu, so I'll unmark it solved. Also, I added about the volume keys.
Reply
#13
Smile 
Hello,

I had the same problem with Lubuntu. Many keys at a HAMA MCE are working. But the Volume up, Volume down and Mute are not working.

According this thread and this page https://help.ubuntu.com/community/Lubuntu/Keyboard
I edited the file ~/.config/openbox/lubuntu-rc.xml
I commented out the section:
Code:
<!-- Keybinding for Volume management -->
<!--    <keybind key="XF86AudioRaiseVolume">
        <action name="Execute">
            <command>amixer -q sset Master 3%+ unmute</command>
        </action>
    </keybind>
    <keybind key="XF86AudioLowerVolume">
        <action name="Execute">
            <command>amixer -q sset Master 3%- unmute</command>
        </action>
    </keybind>
    <keybind key="XF86AudioMute">
        <action name="Execute">
            <command>amixer -q sset Master toggle</command>
        </action>
    </keybind> -->

After a restart of the xsession the Volume keys and Mute works :-)

Regards
herd
Reply
#14
(2014-12-27, 01:20)porubat Wrote: Hi there,

I have remote control vrc-1100. On xubuntu 14.04 with XMBC all buttons wok. After installing kodi, the volume up/down/mute, pause,play,power and another buttons stops working.

The buttons presses don't appear in ~/.kodi/temp/kodi.log.

does anybody know how to unbind this media keys in xubuntu 14.04 (xfce)?

I did not find it in any settings keyboard shortcuts.

Thanks

Xfce4 user on Xubuntu 14.04.3 here. I made an account just for this post, since your issue was exactly the same as mine. It turns out that the solution mentioned by others,

Quote:It was just a matter of going to System Settings > Keyboard > Shortcuts > Sound and Media and disabling all shortcuts.

actually DOES work for Xfce. (!) To my great surprise, despite installing Xubuntu to deliberately avoid the Unity UI, I have some Unity commands kicking around. In particular, running

Code:
unity-control-center

Allows changing the keyboard shortcuts as above. Doing that got things going for me. Good luck!!
Reply
#15
(2015-01-24, 19:01)Alfa60 Wrote: PROBLEM SOLVED, in my case at least.

It was indeed, as pointed out by Memphiz and denz13, a conflict with ubuntu keyboard shortcuts.

It was just a matter of going to System Settings > Keyboard > Shortcuts > Sound and Media and disabling all shortcuts. After that, all media keys on the Logitech dinovo mini started to work again in Kodi.

Thank you very much, Memphiz and denz13.

Have tried to solve this problem for weeks. Would not work with Flirc or Sony BT remote. I had narrowed it down to Ubuntu but couldn't get anywhere.
Thank you.
Will pass this on to the Flirc forum.
Reply



Logout Mark Read Team Forum Stats Members Help
Play, stop, and pause remote buttons stop working with Helix Beta1
This forum uses Lukasz Tkacz MyBB addons.