Thread Rating:
  • 0 Vote(s) - 0 Average
VideoOSD Full Screen info not appearing anymore.
#1
As the title states "VideoOSD Full Screen info not appearing anymore." when watching a video full screen, my old skin allowed video info to appear at the bottom as Full screen music does. However, this no longer works.

Any ideas why. No debug info, no errors, the white buttom just doesn't show the info anymore. I going crazy trying to figure it out.

Was the keymap changed? or is it even a possible reason.

PS: LOVE THE NEW FORUM. Now my default.

Quote:<window>

<id>2005</id>
<defaultcontrol>13</defaultcontrol>

<controls>

<!-- codec infos -->

<control>
<description>preset background image</description>
<type>image</type>
<id>0</id>
<posx>-10</posx>
<posy>40</posy>
<width>760</width>
<height>85</height>
<texture>background-dialog.png</texture>
<colordiffuse>AAFFFFFF</colordiffuse>
<animation effect="fade" time="300">VisibleChange</animation>
<visible>Player.ShowCodec</visible>
</control>

<control>
<description>row 1 label</description>
<type>label</type>
<id>10</id>
<posx>75</posx>
<posy>50</posy>
<label>-</label>
<align>left</align>
<font>font12</font>
<animation effect="fade" time="300">VisibleChange</animation>
<visible>Player.ShowCodec</visible>
</control>

<control>
<description>row 2 label</description>
<type>label</type>
<id>11</id>
<posx>75</posx>
<posy>75</posy>
<label>-</label>
<align>left</align>
<font>font12</font>
<animation effect="fade" time="300">VisibleChange</animation>
<visible>Player.ShowCodec</visible>
</control>

<control>
<description>row 3 label</description>
<type>label</type>
<id>12</id>
<posx>75</posx>
<posy>100</posy>
<label>-</label>
<align>left</align>
<font>font12</font>
<animation effect="fade" time="300">VisibleChange</animation>
<visible>Player.ShowCodec</visible>
</control>

<!-- buffering dialog -->

<control>
<description>buffering label</description>
<type>label</type>
<id>24</id>
<posx>210</posx>
<posy>520</posy>
<label>15107</label>
<width>291</width>
<align>center</align>
<font>font12</font>
<include>textcolorwhite</include>
</control>


<!---------------------------------
HERE IS THE CONTENT THAT NO LONGER APPEARS
<!_-------------------------------

<!-- media infos -->
<control>
<description>media info background image</description>
<type>image</type>
<id>1</id>
<posx>-10</posx>
<posy>335</posy>
<width>760</width>
<height>105</height>
<visible>Player.ShowInfo</visible>
<animation effect="fade" time="1000">VisibleChange</animation>
<texture>background-dialog.png</texture>
<colordiffuse>AAFFFFFF</colordiffuse>
</control>

<control>
<description>Music Shadow</description>
<type>image</type>
<id>1</id>
<posx>75</posx>
<posy>330</posy>
<width>100</width>
<height>105</height>
<texture>blue_rectangle_music.png</texture>
<visible>Player.ShowInfo</visible>
<animation effect="fade" time="1000">VisibleChange</animation>
<aspectratio>keep</aspectratio>
</control>

<control>
<description>Music Logo</description>
<type>image</type>
<id>1</id>
<posx>80</posx>
<posy>335</posy>
<width>90</width>
<height>94</height>
<info>VideoPlayer.Cover</info>
<texture>defaultAlbumCover.png</texture>
<visible>Player.ShowInfo</visible>
<animation effect="fade" time="1000">VisibleChange</animation>
<aspectratio>keep</aspectratio>
</control>


<control>
<description>Title label</description>
<type>label</type>
<id>1</id>
<width>445</width>
<posx>180</posx>
<posy>338</posy>
<info>VideoPlayer.Title</info>
<visible>Player.ShowInfo</visible>
<animation effect="fade" time="1000">VisibleChange</animation>
<align>left</align>
<font>special12</font>
</control>

<control>
<description>Video Director/Year Label</description>
<type>label</type>
<id>1</id>
<width>430</width>
<posx>180</posx>
<posy>359</posy>
<label>$INFO[VideoPlayer.Director] | $INFO[VideoPlayer.Year]</label>
<visible>Player.ShowInfo</visible>
<animation effect="fade" time="1000">VisibleChange</animation>
<align>left</align>
<font>special13</font>
</control>

<control>
<description>Genre label</description>
<type>label</type>
<id>1</id>
<width>430</width>
<posx>180</posx>
<posy>387</posy>
<info>VideoPlayer.Genre</info>
<visible>Player.ShowInfo</visible>
<animation effect="fade" time="1000">VisibleChange</animation>
<align>left</align>
<font>font10</font>
</control>

<control>
<description>time label</description>
<type>label</type>
<id>1</id>
<width>430</width>
<posx>180</posx>
<posy>410</posy>
<label>$INFO[videoplayer.Time]$INFO[videoplayer.Duration, / ]</label>
<visible>Player.ShowInfo</visible>
<animation effect="fade" time="1000">VisibleChange</animation>
<align>left</align>
<font>font10</font>
</control>

</controls>

</window>

Hades_666
Reply
#2
are the images displaying still?
Reply
#3
Nothing below the "THIS Don't appear" appears

It is almost like the white button is disabled during video Full screen or the
<visible>Player.ShowInfo</visible>
is not being respected anymore.

Hmm...
Reply
#4
yeah, it's clearly the visiblity tags if you're not even getting the basic images.
Reply
#5
Stranger still the MUSICVISUALIZATION.XML works fine with the Tag. It is onlt with that window.

Quote:<window>

<id>2006</id>
<defaultcontrol>2</defaultcontrol>
<allowoverlay>no</allowoverlay>

<controls>

<control>
<description>visualisation</description>
<type>visualisation</type>
<id>2</id>
<posx>0</posx>
<posy>0</posy>
<width>720</width>
<height>576</height>
</control>

<!-- codec & viz infos -->

<control>
<description>preset background image</description>
<type>image</type>
<id>0</id>
<posx>-10</posx>
<posy>40</posy>
<width>760</width>
<height>65</height>
<texture>background-dialog.png</texture>
<colordiffuse>AAFFFFFF</colordiffuse>
<visible>Player.ShowCodec</visible>
<animation effect="fade" time="300">VisibleChange</animation>
</control>

<control>
<description>Codecinfo</description>
<type>label</type>
<id>0</id>
<width>600</width>
<posx>75</posx>
<posy>50</posy>
<label>Audio | $INFO[musicplayer.Codec,Codec:,]$INFO[musicplayer.Bitrate, - Bitrate:,kbps]$INFO[musicplayer.bitspersample, - Bits:,bit]$INFO[musicplayer.Samplerate, - Freq.: ,kHz]$INFO[musicplayer.Channels, - Channels: ]</label>
<align>left</align>
<font>font12</font>
<visible>Player.ShowCodec</visible>
<animation effect="fade" time="300">VisibleChange</animation>
</control>

<control>
<description>Presets label</description>
<type>label</type>
<id>0</id>
<posx>75</posx>
<posy>75</posy>
<width>560</width>
<label>Visuals | fps: $INFO[System.FPS] -</label>
<font>font12</font>
<align>left</align>
<visible>Player.ShowCodec</visible>
<animation effect="fade" time="300">VisibleChange</animation>
</control>

<control>
<description>Presets label</description>
<type>label</type>
<id>0</id>
<posx>225</posx>
<posy>75</posy>
<width>420</width>
<label>$INFO[Visualisation.Name]$INFO[Visualisation.Preset, - ]</label>
<font>font12</font>
<align>left</align>
<visible>Player.ShowCodec</visible>
<animation effect="fade" time="300">VisibleChange</animation>
</control>

<control>
<type>image</type>
<description>Preset locked image</description>
<id>0</id>
<posx>210</posx>
<posy>76</posy>
<width>12</width>
<height>15</height>
<visible>Visualisation.Locked + Player.ShowCodec</visible>
<animation effect="fade" time="300">VisibleChange</animation>
<texture>arenaitem-private.png</texture>
</control>

<!-- media infos -->
<control>
<description>media info background image</description>
<type>image</type>
<id>1</id>
<posx>-10</posx>
<posy>335</posy>
<width>760</width>
<height>105</height>
<visible>Player.ShowInfo</visible>
<animation effect="fade" time="1000">VisibleChange</animation>
<texture>background-dialog.png</texture>
<colordiffuse>AAFFFFFF</colordiffuse>
</control>

<control>
<description>Music Shadow</description>
<type>image</type>
<id>1</id>
<posx>75</posx>
<posy>330</posy>
<width>100</width>
<height>105</height>
<texture>blue_rectangle_music.png</texture>
<visible>Player.ShowInfo</visible>
<animation effect="fade" time="1000">VisibleChange</animation>
<aspectratio>keep</aspectratio>
</control>

<control>
<description>Music Logo</description>
<type>image</type>
<id>1</id>
<posx>80</posx>
<posy>335</posy>
<width>90</width>
<height>94</height>
<info>MusicPlayer.Cover</info>
<texture>defaultAlbumCover.png</texture>
<visible>Player.ShowInfo</visible>
<animation effect="fade" time="1000">VisibleChange</animation>
<aspectratio>keep</aspectratio>
</control>


<control>
<description>Artist label</description>
<type>label</type>
<id>1</id>
<width>445</width>
<posx>180</posx>
<posy>338</posy>
<info>MusicPlayer.Artist</info>
<visible>Player.ShowInfo</visible>
<animation effect="fade" time="1000">VisibleChange</animation>
<align>left</align>
<font>special12</font>
</control>

<control>
<description>Title label</description>
<type>label</type>
<id>1</id>
<width>430</width>
<posx>180</posx>
<posy>359</posy>
<info>MusicPlayer.Title</info>
<visible>Player.ShowInfo</visible>
<animation effect="fade" time="1000">VisibleChange</animation>
<align>left</align>
<font>special13</font>
</control>

<control>
<description>Album label</description>
<type>label</type>
<id>1</id>
<width>430</width>
<posx>180</posx>
<posy>387</posy>
<info>MusicPlayer.Album</info>
<visible>Player.ShowInfo</visible>
<animation effect="fade" time="1000">VisibleChange</animation>
<align>left</align>
<font>font10</font>
</control>

<control>
<description>time label</description>
<type>label</type>
<id>1</id>
<width>430</width>
<posx>180</posx>
<posy>410</posy>
<label>$INFO[musicplayer.Time]$INFO[musicplayer.Duration, / ]</label>
<visible>Player.ShowInfo</visible>
<animation effect="fade" time="1000">VisibleChange</animation>
<align>left</align>
<font>font10</font>
</control>

<control>
<description>Playlist Pos No</description>
<type>label</type>
<id>1</id>
<width>200</width>
<posx>645</posx>
<posy>410</posy>
<label>$INFO[musicplayer.Playlistposition,$LOCALIZE[435] ]$INFO[musicplayer.Playlistlength, / ]</label>
<visible>Player.ShowInfo + !MusicPartyMode.Enabled</visible>
<animation effect="fade" time="1000">VisibleChange</animation>
<align>right</align>
<font>font10</font>
</control>

<control>
<description>PartyMode Enabled</description>
<type>label</type>
<id>1</id>
<width>200</width>
<posx>645</posx>
<posy>410</posy>
<label>589</label>
<visible>Player.ShowInfo + MusicPartyMode.Enabled</visible>
<animation effect="fade" time="1000">VisibleChange</animation>
<align>right</align>
<font>font10</font>
</control>

</controls>

</window>
Reply
#6
Well just a a good guess here the white button isn't set to Player.showinfo in the VideoFullScreen.xml its set to call the dialog progress now. So at a guess as a solution you could add it to the DialogProgress.xml with a condition thing of "Window.IsActive(2005)"
Reply



VideoOSD Full Screen info not appearing anymore.00