•   
  • 1
  • 49
  • 50
  • 51(current)
  • 52
  • 53
  • 111
  •   
OpenELEC Testbuilds for RaspberryPi (Kodi 15.0) Part 1
Well, it's possible but makes the check process more complicated and would incur delays so it's been dropped.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-02-24, 17:45)popcornmix Wrote:
(2015-02-24, 17:42)visata Wrote: I didn't like the slow channel switching on IPTV mpeg2 streams on 14.1 version, so I decided to give a try and test #0223 build. It works really fast!

The only issue I noticed that if deinterlacing was set to Auto or On, my IPTV streams were lagging, so I had to disable it. I have mpeg2 license and it is enabled.

Pi1 or Pi2? Is omxplayer enabled in video/acceleration settings?

Yes, omxplayer wasn't enabled. When I enabled it, no more lag. I also had to restart Pi2 in order to make it work.
(2015-02-24, 21:06)Milhouse Wrote:
(2015-02-24, 20:46)evanspae Wrote: I didnt #0214 onwards.. all have same problem

Can you give step-by-step instructions on how to set this up (and hopefully reproduce the crash). Argus TV seems to have a Windows component, where is this and how does it need to be configured (does it need extra hardware, ie. tuners etc.?) I enabled the Argus TV PVR addon, but it kept on saying "Connection lost" and I saw nothing in Confluence that would allow me to access the Live TV (and, hopefully, crash).

Argus PVR addon is indeed a client to a Windows based recorder (ie it does have seperate hardware and tuners on a windows platform), which schedules recordings etc.The RPI ArgusTV PVR addon is purely a kodi client to this Windows host to enable kodi to play live Tv and display epg etc.

The version I am using comes as part of the kodi collection of PVR clients. I am using the ArgusTV ver 1.10.1
To set up it requires an ip address to host (192.168.0.47) a port 49943, windows user and password.

This has all been working flawlessly up to #0213, and fails with crash on all releases since then (both rpi/rpi2). I'm not sure how the updated 4.3.8 vdr-addon works, is it in additon to the ArgusTV plugin or will it replace it?
Location UK; Media server Windows 7 with ArgusTV 2.3 with TBS6981 DVB-S2 x4 and DVB-T x 2:All network connections cabled on 1Gb router Raspberry Pi2 1GB x 2; RPI 3 x1; PiB+512MB x 3; TV Samsung 55" C8000; AV Denon AVR X2200W
New OpenELEC I****** build #0224: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 3.19.0 #1 Tue Feb 24 23:44:54 GMT 2015 armv6l GNU/Linux

# vcgencmd version
Feb 24 2015 12:50:21
Copyright (c) 2012 Broadcom
version 784e0c6a418a9f1e07c0531468162e968acdeefd (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20150224234406-#0224-g24ed310 [Build #0224]

# vcdbg log msg 2>&1 | grep DTOK
001540.130: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (24ed3102, changelog) and tip of XBMC master (8a75d67e, changelog) with the following modifications: Build Highlights:
  1. New firmware
  2. Fix crash when seeking and no seek steps configured (@zaphod24)
  3. Updated kodi-addon-xvdr
  4. Subtitle update limit and view mode fixes in newclock4
  5. Reverted vdr/vdr-addon - any effect on Argus TV?
Build Details:
  1. Firmware (Feb 24):
    • firmware: ldconfig: Fix sort order to handle underscores and add check for sortedness. See: link
    • firmware: L1 cache fix part 2
    • firmware: ldconfig: Sort config options and use bsearch for lookups
    • firmware: video_decode: Require a small factor improvement for fifo timestamps. See: link
    • firmware: video codec: allow length-delineated input to have startcodes as well. See: link
  2. OpenELEC:
    • lcdproc: don't build parallel (PR:3946, 1 commit, 1 file changed)
  3. XBMC:
    • [win32] addons: fix filtering foreign language addons (PR:6524, 3 commits, 4 files changed)
    • [seek] fix crash if no seek steps are found for the selected direction (PR:6536, 1 commit, 1 file changed)
    • [ActiveAE] - ActiveAESink: Change several LOGNOTICE to LOGDEBUG (PR:6527, 1 commit, 1 file changed)
    • json-rpc: fix duplicate "lastplayed" in "Video.Fields.TVShow" (thanks Tolriq) (9039930d)
  4. kodi-addon-xvdr:
    • PVR API 1.9.4 (PR:147, 1 commit, 5 files changed)
  5. newclock4:
    • New commits in this build:
      • [omxplayer] Limit subtitle updates to 10fps to avoid stuttering with closed captions (0c5e93e8)
      • TEST: decrease priority of BackgroundInfoLoader thread. (fc7a892e)
      • [mmalrenderer] Fix for stereo view modes (11638612)
    • Commits no longer in build:
  6. kernel 3.19.y:
    • New commits in this build:
      • config: remove bcm2835_sdcard_defconfig (417b8573)
      • pinctrl-bcm2835: Fix interrupt handling for GPIOs 28-31 and 46-53 (23c76b7f)
  7. Additional commits/pull requests/changes not yet merged upstream:
    • Reverted: f334d939: vdr: update to vdr-2.1.10
    • Reverted: 3937ea56: vdr-addon: bump to 4.3.8
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-02-25, 00:57)evanspae Wrote: This has all been working flawlessly up to #0213, and fails with crash on all releases since then (both rpi/rpi2). I'm not sure how the updated 4.3.8 vdr-addon works, is it in additon to the ArgusTV plugin or will it replace it?

Sorry, no idea. I'm not even sure it's related. Presumably you've never installed it, and it's not included as part of the standard build (it needs to be created as an addon, then downloaded to be installed). See if you have it installed on your system, if not we can rule it out.

For what it's worth, In the latest build I've reverted the vdr changes that were added on 14 Feb - if the latest build also crashes then I'm pretty sure we can rule out these vdr changes (although what else might be responsible, I'm at a loss).

Try a recent OpenELEC official nightly - these are based on Helix/14.x and might give more clues if they also crash (or don't, as the case may be).

Do you know who maintains the Argus TV PVR addon? Maybe they can help.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-02-22, 16:41)popcornmix Wrote: Okay, so that doesn't narrow it down too much. There are ~60 builds between those two points, so you should be able to find
the exact build in about 6 tests (by always testing a build from the middle of newest working and oldest non-working build).

Okay popcornmix, I got it.
The problem seems to start from build #102. I have not tested all versions, but:
#101 is fine, #102 maybe - I'm not sure - #106, #118 and #119 are broken.

Below a screenshot of #119:
Image

Hope this could be helpful.

Thanks
Millhouse the browsing with movie art is much faster. It's almost flawless now.
(2015-02-25, 12:02)slack3r Wrote: Okay popcornmix, I got it.
The problem seems to start from build #102. I have not tested all versions, but:
#101 is fine, #102 maybe - I'm not sure - #106, #118 and #119 are broken.

Could you try again with #102. That build introduced:
Quote:Enable dirty regions for full screen video

which could be relevant, although that commit mostly affects video playback. Would be good to confirm it is that build.
(2015-02-25, 13:26)popcornmix Wrote: Could you try again with #102. That build introduced:
Quote:Enable dirty regions for full screen video

which could be relevant, although that commit mostly affects video playback. Would be good to confirm it is that build.

OK, I'm running #102. In the past this build has showed the issue, but only for few seconds. I'll let you know.

P.s.
There is a way to disable dirty regions?
(2015-02-25, 13:42)slack3r Wrote: There is a way to disable dirty regions?

See options here

algorithmdirtyregions=3 is the default. 1 and 2 are not supported on GL ES, but might be interesting to try 0.
@popcornmix - monoscopic 3D is fixed now - thanks. You will have to drop 4bade80 because it's not solving the issue. Menake/anaconda confirmed my PR to be working as expected now and it got merged.
Sorry to report #0224 no solution to ArgusTV live TV crash problem.

I will check latest official Openelec builds.
Location UK; Media server Windows 7 with ArgusTV 2.3 with TBS6981 DVB-S2 x4 and DVB-T x 2:All network connections cabled on 1Gb router Raspberry Pi2 1GB x 2; RPI 3 x1; PiB+512MB x 3; TV Samsung 55" C8000; AV Denon AVR X2200W
(2015-02-25, 13:57)da-anda Wrote: @popcornmix - monoscopic 3D is fixed now - thanks. You will have to drop 4bade80 because it's not solving the issue. Menake/anaconda confirmed my PR to be working as expected now and it got merged.
Yes, I dropped 4bade80 with last rebase. Let me know any 3d issues that still remain.
(2015-02-25, 13:49)popcornmix Wrote:
(2015-02-25, 13:42)slack3r Wrote: There is a way to disable dirty regions?

See options here

algorithmdirtyregions=3 is the default. 1 and 2 are not supported on GL ES, but might be interesting to try 0.

Tested build #224 with
Code:
<?xml version="1.0" encoding="UTF-8"?>
<advancedsettings>

  <algorithmdirtyregions>0</algorithmdirtyregions>

</advancedsettings>
in '~/.kodi/userdata/advancedsettings.xml', but nothing to do.
Damn!

Ok, rollback to #0102.
@popcornmix

I have found that there is a big difference in GUI rendering between build #0104 and #0106.

Take a look:

with build #0104 - and #0101, #0102 - GUI runs at 60fps during video playback:

Image


But with build #0106 and same video GUI runs at ~30fps:

Image

Could the problem be here?
  •   
  • 1
  • 49
  • 50
  • 51(current)
  • 52
  • 53
  • 111
  •   



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 15.0) Part 112
This forum uses Lukasz Tkacz MyBB addons.