•   
  • 1
  • 57
  • 58
  • 59(current)
  • 60
  • 61
  • 111
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 15.0) Part 1
(2015-03-04, 18:31)darzur Wrote: This fix makes radio, music ad GUI ridiculously loud in comparison to videos. Loudness was much more even in builds before #301.

I'm afraid the new behaviour is how it should be. omxplayer volume now matches dvdplayer (it didn't before).
The relative levels of volume should now match Kodi on other platforms.
I see. It looks like I have to get used to it.
o.k. - here i am ;-)

The men with his Video_TS/vob over smb.

#0303 on RP B+ , play only in PCM stereo with 100% CPU0, the video is async to the audio, after 1 minute i have no sound.

http://xbmclogs.com/ptntc4j1x

#208 on the RP B+ with the same file - a little bit faster but also async audio. Video is playing with pcm sound.

http://xbmclogs.com/p0oeveocb

without debugging it seems the Video play corect. (?)
With build #228 on my RPi v2, I couldn't get my DVB-T tuner to show up at all in the web GUI but with #303 on my RPi B it does. I'll try #303 on my RPi v2 but if anyone has any suggestions, please post to my thread here:
1945467 (post)

EDIT: Tried build #303 on my RPi v2 and the tuner still doesn't show up in the Web GUI.
I'm not sure if I managed to corrupt some files on the flash partition.

My cmdline.txt reads "boot=/dev/mmcblk0p1 disk=/dev/mmcblk0p2 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 sss quiet" when I'm sure that should be ssh, not sss.

I also saw this in config.txt:

# default GPU memory split (do not change if you do not know what you are doing)
gpu_mem=384

# SDRAM size based GPU memory split, uncomment and setup to override 'gpu_mem'
gpu_mem_256=384
gpu_mem_512=384
gpu_mem_1024=64

and thought the last line didn't make any sense, so I commented them all out just leaving gpu_mem=384 and then my RPi v2 got stuck on the rainbow screen on rebooting!

EDIT: Changing it to ssh didn't help, nor did uncommenting the gpu_mem_256 and gpu_mem_512 lines.

I've pasted the full config.txt here http://pastebin.com/WY3uWjrM

I tried commenting out the last few lines after it says "End of default configuration" in case they were messing things up but that just changed the rainbow screen from 16:9 to 4:3.

EDIT2: Looking at the #303 tar, I see there's a bcm2709-rpi-2-b.dtb on my /flash that's not in the tar, so I guess that's left over from #228 and I can delete that. I'll extract the files to the uSD again and see if that fixes it.

Nope, still stuck on the rainbow screen Sad
@doveman2: are you sure you are installing the correct build (ie. RPi2 build on a Pi2, RPi build on a Pi1 etc.)?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New OpenELEC Isengard build #0304: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 3.19.0 #1 Wed Mar 4 21:03:01 GMT 2015 armv6l GNU/Linux

# vcgencmd version
Mar  3 2015 15:29:03
Copyright (c) 2012 Broadcom
version 4b55b3e95322381c9964fa6576476cd933f678a4 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20150304210211-#0304-g6014b59 [Build #0304]

# vcdbg log msg 2>&1 | grep DTOK
001520.292: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (6014b59e, changelog) and tip of XBMC master (2ad47418, changelog) with the following modifications: Build Highlights:
  1. Fix for local season art when adding new seasons
  2. Fix thread blocking during JSON library clean/scan
  3. JumpToFirstUnplayedItem - two new options in Video -> Library
  4. Updated RPi2 HEVC NEON optimisations
Build Details:
  1. OpenELEC:
    • libva: x11: dri2: fix double Unlocks/SyncHandle (PR:3978, 1 commit, 1 file changed)
  2. XBMC:
    • Refactor #6489 JumpToFirstUnplayedItem to SelectFirstUnwatchedItem (PR:6505, 1 commit, 9 files changed)
    • CVideoLibraryQueue: fix segfault in CancelJob() if CJobQueue::CancelJob() deletes the job to be cancelled (PR:6594, 1 commit, 1 file changed)
    • [videoinfoscanner] add season art when new season are added (PR:6580, 3 commits, 4 files changed)
    • pvr build clean-up and fix (PR:6585, 2 commits, 2 files changed)
    • fix video library cleaning not initiated by a user blocking the main thread (PR:6598, 2 commits, 2 files changed)
    • [addons] fix post install of context items after #6549 (58cf730e)
    • [addons] revert force clearing of strings after loading context item label (2ad47418)
  3. newclock4:
    • New commits in this build:
      • Revert "[emufnc] Disable support for READ_TRUNCATED. To be reverted after Helix release." (e2b29b8d)
      • test: fix for dirty rendering with skipped updates (26d76109)
      • test: Set and reset the dirty flag in a more sane way (0bb640d4)
    • Commits no longer in build:
      • adds GetTvShowSeasons (79a21915)
      • move AddSeason() public. (e2ded694)
      • add season art when new season are added (fixes #14339) (faaa6980)
      • CVideoLibraryQueue: fix segfault in CancelJob() if CJobQueue::CancelJob() deletes the job to be cancelled (2398009d)
      • Fix CDVDPlayer::SwitchChannel signature to match IPlayer::SwitchChannel signature. (78577650)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: patch: hevcdsp: ARM NEON optimized deblocking filter (ffmpeg)
    • Added: patch: hevcdsp: ARM NEON optimized epel functions (ffmpeg)
    • Added: patch: avcodec/hevcdsp: ARM NEON optimized qpel functions (ffmpeg)
    • Added: patch: hevcdsp: ARM NEON optimized transforms (ffmpeg)
    • Added: patch: HEVC deblocking ARM NEON register clobber fix (ffmpeg)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Can the Pi 2 software decode hevc now? I don't have a sample on hand.
(2015-03-05, 02:26)Milhouse Wrote: @doveman2: are you sure you are installing the correct build (ie. RPi2 build on a Pi2, RPi build on a Pi1 etc.)?

Doh! I installed the RPi build on my B but then installed the same build on my RPi2 Tongue

Thanks for the nudge. It'll be a lot simpler when I give the B to my sister and only have v2's in my house Smile

Can you confirm that this line is correct for cmdline.txt please?

boot=/dev/mmcblk0p1 disk=/dev/mmcblk0p2 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 ssh quiet

After installing the correct build, the USB tuner still doesn't work on the v2 though and the 02_System.log http://pastebin.com/3ZMpYGdf doesn't seem to have any reference to it, unlike on the B where it shows:

[ 2.296726] usb 1-1.3: new high-speed USB device number 4 using dwc_otg
[ 2.394884] usb 1-1.3: New USB device found, idVendor=1b80, idProduct=e409
[ 2.394913] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 2.394928] usb 1-1.3: Product: DVB-T TV Stick
[ 2.394943] usb 1-1.3: Manufacturer: ITE Technologies, Inc.

Although the 03_Hardware.log from my v2 seems to refer to it as a "Zolid Mini DVB-T Stick" (I need to check what the log from my B says): http://pastebin.com/AWegQdT1

I know it's probably not a priority for you but I had the same experience as before updating this B from Gotham to #303, where it lost all the settings. I observed the state after booting, before going through the wizard and I noticed that Userdata\addon_data\service.openelec.settings was empty until I stepped through the wizard, so either that's getting wiped or it was previously located elsewhere. The other files (guisettings.xml) were still present though, so I don't know why it lost those settings (reset from Expert to Basic being the most obvious). Comparing guisettings.xml from immediately after booting and after completing the wizard, the only significant difference is that the latter has the <skinsettings> section populated with basic settings for Confluence, whereas the former has this section empty, so perhaps that is getting wiped when updating for some reason.
(2015-03-05, 06:12)f1vefour Wrote: Can the Pi 2 software decode hevc now? I don't have a sample on hand.
On my Turbo overclocked RPi 2, it can handle 1280x536p HEVC decodes at up to a Max bitrate of 1.3Mbps.
Good enough for TV Rips. Quality is very good.

- PapaSierraAlpha ! Wink

(2015-03-05, 06:15)doveman2 Wrote: Can you confirm that this line is correct for cmdline.txt please?

boot=/dev/mmcblk0p1 disk=/dev/mmcblk0p2 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 ssh quiet

I'd suggest the following is all you require:
Code:
boot=/dev/mmcblk0p1 disk=/dev/mmcblk0p2 ssh quiet

(2015-03-05, 06:15)doveman2 Wrote: After installing the correct build, the USB tuner still doesn't work on the v2 though and the 02_System.log http://pastebin.com/3ZMpYGdf doesn't seem to have any reference to it, unlike on the B where it shows:

Can you test with official OpenELEC 5.0.5 for RPi2 - if you get the same behaviour, it's an upstream issue and needs to be reported to the OpenELEC developers.

(2015-03-05, 06:15)doveman2 Wrote: I know it's probably not a priority for you but I had the same experience as before updating this B from Gotham to #303, where it lost all the settings. I observed the state after booting, before going through the wizard and I noticed that Userdata\addon_data\service.openelec.settings was empty until I stepped through the wizard, so either that's getting wiped or it was previously located elsewhere.

"or it was previously located elsewhere." - that's entirely possible, as the addon handling OpenELEC settings changed name in Helix (OpenELEC 5.x) - the addon is now called "OpenELEC-settings", and before Helix it was "service.openelec.settings", and your old Gotham settings wouldn't have migrated to Helix. Just one of the reasons why in-place upgrades are not advised.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Hi,
here is somthing wrong in the OSD in the #304 build.

Image

...would mak some settings in the audio [ms], because DVD i have no chance to sync Audio with video on Rp1 (B+) , yeh, over smb:// :-(

...all drifted over 3-4 sec.

Make some tests with Rp2 now:

Works now perfect with DVDs over smb:\\
...max 12% CPU :-)

Absolutly smooth and very fast now.
thanks for this hard work.

It looks that way, Pi "one" B+ is not good enough by half to play this DVD Files over network ?
Over USB the cpu runn also to 100% with a DVD_file, hmmm
-> refuse bin
(2015-03-05, 14:16)doldi Wrote: Hi,
here is somthing wrong in the OSD in the #304 build.

@popcornmix - it looks like the help description for "videolibrary.showallitems" and "musiclibrary.showallitems" has nicked the #38012 string id being used for id="audiooutput.latency" label in rbp.xml/rbp2.xml.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-03-05, 09:39)wrxtasy Wrote:
(2015-03-05, 06:12)f1vefour Wrote: Can the Pi 2 software decode hevc now? I don't have a sample on hand.
On my Turbo overclocked RPi 2, it can handle 1280x536p HEVC decodes at up to a Max bitrate of 1.3Mbps.
Good enough for TV Rips. Quality is very good.

- PapaSierraAlpha ! Wink
Thanks for the information.
(2015-03-04, 20:07)popcornmix Wrote: I'm afraid the new behaviour is how it should be. omxplayer volume now matches dvdplayer (it didn't before).
The relative levels of volume should now match Kodi on other platforms.

Maybe this thread is not the perfect place for this but from the very beginning of XBMC/Kodi the audio streams of various addons (shoutcast, radio.de, radiotunes, ...) have much higher volume level than the audio track of videos (avi container with mp3 audio and h264 video) played with dvdplayer. omxplayer is never used due to sound output over a hifiberry board.
Is there any way to normalize both to one level?
  •   
  • 1
  • 57
  • 58
  • 59(current)
  • 60
  • 61
  • 111
  •   
  Thread Closed
 
Thread Rating:
  • 12 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 15.0) Part 14.512